Nie jesteś zalogowany na forum.

#1 2019-08-29 03:22:45

neo386
Użytkownik
Data rejestracji: 2018-11-22
Liczba postów: 97

[SOLVED] - Cups i jego autostart

Witajcie

Mam problem z uruchomieniem CUPS-a

Nie pomagają komendy

systemctl enable org.cups.cupsd.service

Ale działa

systemctl start org.cups.cupsd.service

(Jedynie pod kontem root)

Chciałbym, aby automatycznie system odpalał ten serwer wydruku (wersja cups-2.2.12-1)

Pozdrawiam

[Tak wygląda po  załadowaniu systemu

[[email protected] ~]$ systemctl status org.cups.cupsd.service
● org.cups.cupsd.service - CUPS Scheduler
   Loaded: loaded (/usr/lib/systemd/system/org.cups.cupsd.ser>
   Active: inactive (dead)
     Docs: man:cupsd(8)

[Tak wygląda jak go się ręcznie wystartuje]

[[email protected] ~]$ systemctl status org.cups.cupsd.service
● org.cups.cupsd.service - CUPS Scheduler
   Loaded: loaded (/usr/lib/systemd/system/org.cups.cupsd.ser>
   Active: active (running) since Thu 2019-08-29 04:38:24 CES>
     Docs: man:cupsd(8)
 Main PID: 1190 (cupsd)
    Tasks: 1 (limit: 4446)
   Memory: 3.0M
   CGroup: /system.slice/org.cups.cupsd.service
           └─1190 /usr/bin/cupsd -l

Pewnym sposobem doszedłem do rozwiązania.

Ostatnio edytowany przez neo386 (2019-08-29 05:04:41)

Offline

#2 2019-08-29 07:29:31

pavbaranov
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-22
Liczba postów: 2,056
WWW

Odp: [SOLVED] - Cups i jego autostart

Przydałoby się, abyś jeszcze to rozwiązanie pokazał.


Hardware: AMD: A8-7410 APU with Radeon R5; Arch testing+kde-unstable, kernel linux-pb, KDE+poprawki, kf5.65rc; kernel własny zawsze z najnowszej linii
https://deviantart.com/pavbaranov/ https://pavbaranov.blogspot.com https://linux-pavbaranov.blogspot.com

Online

#3 2019-08-29 20:14:42

neo386
Użytkownik
Data rejestracji: 2018-11-22
Liczba postów: 97

Odp: [SOLVED] - Cups i jego autostart

Należy stworzyć plik cupsstart.service w ;
/usr/lib/systemd/system/cupsstart.service

O zawartości ;

[Unit]
Description=cups
After=cups.target

[Service]
Type=simple
ExecStart=/etc/cupsd.sh

[Install]
WantedBy=multi-user.target

Tworzymy plik ;
/etc/cupdsd.sh

Z komendą ;

systemctl start org.cups.cupsd.service

Na koniec nadajemy prawa zapisu/odczytu (dla WSZYSKICH). podnosimy usługę ===>> systemctl enable cupsstart.service
I reboot-ujemy system.

Także widzicie drodzy Koledzy.... czasami trzeba trochę sprytu i pomysłowości.
Zaręczam, że sama komenda ;

systemctl enable org.cups.cupsd.service

Nie zdaje egzaminu.

Ostatnio edytowany przez neo386 (2019-08-29 20:25:20)

Offline

#4 2019-08-29 20:29:59

pavbaranov
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-22
Liczba postów: 2,056
WWW

Odp: [SOLVED] - Cups i jego autostart

Ok, zamykam, choć sam mam ustawione wyłącznie to co w pierwszym poście (jeszcze też *.socket). I działa.


Hardware: AMD: A8-7410 APU with Radeon R5; Arch testing+kde-unstable, kernel linux-pb, KDE+poprawki, kf5.65rc; kernel własny zawsze z najnowszej linii
https://deviantart.com/pavbaranov/ https://pavbaranov.blogspot.com https://linux-pavbaranov.blogspot.com

Online

Stopka

Forum oparte na FluxBB