Nie jesteś zalogowany na forum.

#1 2019-07-25 18:46:20

WojAbuk
Użytkownik
Data rejestracji: 2019-07-25
Liczba postów: 21

Problem z uruchomieniem KDE

Cześć, wczoraj pierwszy raz zainstalowałem Linuksa Arch (ostatnie 6 lat korzystałem z Debiana) i nie jestem w stanie uruchomić środowiska KDE. Przy każdej próbie dostaje komunikat "id not set oraz Canona to tej x serwer". Próbowałem zastosować ten poradnik https://wiki.archlinux.org/index.php/Xorg ale bez efektów. Gdy wpisze polecenie X tracę dostęp do komputera (czarny ekran). Nie testowałem innych środowisk. Mam kartę graficzną AMD Radeon RX 470 (mogłem pomylić model, ale seria 400 na pewno jest). Przepraszam, jeśli pisze w złym dziale.

Ostatnio edytowany przez WojAbuk (2019-07-26 14:41:10)

Offline

#2 2019-07-25 19:56:18

pavbaranov
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-22
Liczba postów: 2,006
WWW

Odp: Problem z uruchomieniem KDE

Który kernel zainstalowałeś oraz czy zainstalowałeś sterownik amdgpu oraz prawidłowo firmware dla AMD? Najlepiej po prostu pokaż:

uname -a && pacman -Qs amd && pacman -Qs xf86-video

Hardware: AMD: A8-7410 APU with Radeon R5; Arch testing+kde-unstable, kernel linux-pb 5.2, KDE+poprawki
https://deviantart.com/pavbaranov/ https://pavbaranov.blogspot.com https://linux-pavbaranov.blogspot.com

Offline

#3 2019-07-25 20:30:43

WojAbuk
Użytkownik
Data rejestracji: 2019-07-25
Liczba postów: 21

Odp: Problem z uruchomieniem KDE

https://drive.google.com/file/d/1-5WjE1 … p=drivesdk Wybacz że w takiej formie, ale nie potrafię tego udostępnić w lepszej formie, bo na telefonie pisze na forum, a komputer bez X.

Offline

#4 2019-07-25 20:44:30

pavbaranov
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-22
Liczba postów: 2,006
WWW

Odp: Problem z uruchomieniem KDE

Ok, drążymy temat dalej.
1. Jak uruchamiasz Plazmę?
2. Masz zainstalowane i podniesione SDDM?


Hardware: AMD: A8-7410 APU with Radeon R5; Arch testing+kde-unstable, kernel linux-pb 5.2, KDE+poprawki
https://deviantart.com/pavbaranov/ https://pavbaranov.blogspot.com https://linux-pavbaranov.blogspot.com

Offline

#5 2019-07-25 20:55:09

WojAbuk
Użytkownik
Data rejestracji: 2019-07-25
Liczba postów: 21

Odp: Problem z uruchomieniem KDE

Próbowałem polecenia startkde i startplasmacompositor. Pierwsze daje komunikat który przepisałem, a drugie powoduje wyświetlenie kursora na czarnym ekranie i chwilę (zwykle kilkanaście minut, ale bywa kruczej i dużej) później komunikat o błędzie. Mam zainstalowane SDDM, ale nie jest skonfigurowane.

Offline

#6 2019-07-25 21:04:52

pavbaranov
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-22
Liczba postów: 2,006
WWW

Odp: Problem z uruchomieniem KDE

Zatem po prostu włącz tę usługę. Obie metody startowania Plazmy (X i Wayland) z konsoli wymagają nieco więcej konfiguracji niż tylko wywołanie "z palca", a i tak nie udało mi się jeszcze jej uruchomić w taki sposób. Inna sprawa, że bardzo się nie starałem :) Z SDDM startuje 1/1.


Hardware: AMD: A8-7410 APU with Radeon R5; Arch testing+kde-unstable, kernel linux-pb 5.2, KDE+poprawki
https://deviantart.com/pavbaranov/ https://pavbaranov.blogspot.com https://linux-pavbaranov.blogspot.com

Offline

#7 2019-07-26 07:59:29

WojAbuk
Użytkownik
Data rejestracji: 2019-07-25
Liczba postów: 21

Odp: Problem z uruchomieniem KDE

A jak wyłączyć tą usługę? Pod
Debianem nie masłem potrzeby robić to inaczej niż przez aptitude i wydaje mi się że tu init działa inaczej.

Offline

#8 2019-07-26 08:45:05

pavbaranov
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-22
Liczba postów: 2,006
WWW

Odp: Problem z uruchomieniem KDE

Chyba włączyć (wiem, że piszesz z komórki, ale pewnie z uwagi na autokorektę, niekiedy trzeba się domyślać, wolę spytać). Jeśłi tak, to tak jak w każdym systemie gdzie jest systemd:

sudo systemctl enable sddm
sudo systemctl start sddm

Pierwsze - startuje SDDM automatycznie przy uruchamianiu systemu, drugie startuje ją (bez drugiej konieczny restart, ale nie wypróbujesz czy działa; jeśli nie, to możesz mieć problem z uruchomieniem w trybie graficznym). Możesz wypróbować drugie i jeśli będzie działać dodać również pierwsze. Sugerowałbym wpierw wypróbować samo drugie rozwiązanie.


Hardware: AMD: A8-7410 APU with Radeon R5; Arch testing+kde-unstable, kernel linux-pb 5.2, KDE+poprawki
https://deviantart.com/pavbaranov/ https://pavbaranov.blogspot.com https://linux-pavbaranov.blogspot.com

Offline

#9 2019-07-26 09:29:39

WojAbuk
Użytkownik
Data rejestracji: 2019-07-25
Liczba postów: 21

Odp: Problem z uruchomieniem KDE

Tak, włączyć. Tak auto korekta + dysleksja.
Ja nie mam polecenia systemd, ale za to mam kilkanaście poleceń systemd-*.

Offline

#10 2019-07-26 09:35:55

pavbaranov
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-22
Liczba postów: 2,006
WWW

Odp: Problem z uruchomieniem KDE

Przepraszam - tak to jest jak się myśli o 2 rzeczach na raz - nie systemd oczywiście a systemctl. Prawidłowe komendy już w poprawionym poście.
Aha i jeszcze jedno - bo widzę, że operujesz na koncie root (dlaczego???; powinienś robić wszystko co potrzebujesz na swoim koncie /zwykłego użytkownika/ a jedynie wówczas, gdy jest to bezwzględnie wymagane użyć konta root) - w takim przypadku oczywiście bez "sudo".


Hardware: AMD: A8-7410 APU with Radeon R5; Arch testing+kde-unstable, kernel linux-pb 5.2, KDE+poprawki
https://deviantart.com/pavbaranov/ https://pavbaranov.blogspot.com https://linux-pavbaranov.blogspot.com

Offline

#11 2019-07-26 14:13:26

WojAbuk
Użytkownik
Data rejestracji: 2019-07-25
Liczba postów: 21

Odp: Problem z uruchomieniem KDE

W domyślnej konfiguracji Debiana sudo nie działa (Chyba że się nie ustawi hasła dla roota) dlatego używam polecenia su - które jest równoważne sudo -i (pomijam fakt że podaje inne hasło) lub polecenia su -c które działa identycznie jak sudo, ale to drugie mi mniej psuje. Poza tym nie lubię gdy użytkownik jest w grupie sudo (działania na grupie sudo to prawie tak jak na grupie root). Wydawało mi się że pacman wymaga roota dlatego użyłem robota.

Teraz mi już działa, ale mam takie pytanie przy użyciu drugiego polecenia widzę na ekranie ciąg komunikatów, a po użyciu pierwszego mam odczucie jak by komputer się zawiesił przy stracie, bo widzę tylko jeden komunikat i chwilę nic. Da się ustawić żebym widział serię komunikatów? Też nawyk z Debiana, brak komunikatów przez dużej niż 2 s (gdy nie było znaku zachęty) praktycznie nie występował dlatego zawsze gdy coś takiego widzę odczuwam niepokój.

Offline

#12 2019-07-26 14:24:07

pavbaranov
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-22
Liczba postów: 2,006
WWW

Odp: Problem z uruchomieniem KDE

WojAbuk napisał/a:

Teraz mi już działa, ale mam takie pytanie przy użyciu drugiego polecenia widzę na ekranie ciąg komunikatów, a po użyciu pierwszego mam odczucie jak by komputer się zawiesił przy stracie, bo widzę tylko jeden komunikat i chwilę nic. Da się ustawić żebym widział serię komunikatów? Też nawyk z Debiana, brak komunikatów przez dużej niż 2 s (gdy nie było znaku zachęty) praktycznie nie występował dlatego zawsze gdy coś takiego widzę odczuwam niepokój.

Po pierwsze - nie rozumiem. Jakiego "pierwszego", czy "drugiego" polecenia. Nadto - pytanie nie jest chyba związane z tematem wątku. Jeśli KDE startuje - oznacz temat za rozwiązany (przydałoby się zmienić jego tytuł, który nie ma nic wspólnego z "problemem"), a nowy temat zacznij w nowym wątku.
I Arch to nie Debian. Na całe szczęście ;)


Hardware: AMD: A8-7410 APU with Radeon R5; Arch testing+kde-unstable, kernel linux-pb 5.2, KDE+poprawki
https://deviantart.com/pavbaranov/ https://pavbaranov.blogspot.com https://linux-pavbaranov.blogspot.com

Offline

#13 2019-07-26 15:05:30

WojAbuk
Użytkownik
Data rejestracji: 2019-07-25
Liczba postów: 21

Odp: Problem z uruchomieniem KDE

1) pierwsze
systemctl enable sddm
2) drugie
systemctl start sddm

Offline

#14 2019-07-26 17:47:24

pavbaranov
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-22
Liczba postów: 2,006
WWW

Odp: Problem z uruchomieniem KDE

Raz zatem jeszcze:
- pierwsze polecenie powoduje dodanie usługi do uruchamiania jej przez systemd podczas startu systemu; jeśli to wykonasz otrzymujesz informację o tym, że symlink jest dodawany,
- drugie z poleceń po prostu startuje usługę.


Hardware: AMD: A8-7410 APU with Radeon R5; Arch testing+kde-unstable, kernel linux-pb 5.2, KDE+poprawki
https://deviantart.com/pavbaranov/ https://pavbaranov.blogspot.com https://linux-pavbaranov.blogspot.com

Offline

#15 2019-07-26 17:55:28

WojAbuk
Użytkownik
Data rejestracji: 2019-07-25
Liczba postów: 21

Odp: Problem z uruchomieniem KDE

Chyba się nie zrozumieliśmy. Gdy SDDM jest uruchamiane przy stracie systemu podaje tylko jeden komunikat i przez chwilę nic się nie dzieję (co jest dla mnie nie komfortowe). Czy jest możliwość żeby przy starcie systemu dawało taką serię jak to drugie? Przy drugim widzę że komputer coś mieli, a jak SDDM startuje wraz z systemem wydaje mi się że komputer się zawiesił.

Offline

#16 2019-07-26 22:12:02

pavbaranov
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-22
Liczba postów: 2,006
WWW

Odp: Problem z uruchomieniem KDE

Nie rozumiem kompletnie.


Hardware: AMD: A8-7410 APU with Radeon R5; Arch testing+kde-unstable, kernel linux-pb 5.2, KDE+poprawki
https://deviantart.com/pavbaranov/ https://pavbaranov.blogspot.com https://linux-pavbaranov.blogspot.com

Offline

#17 2019-08-12 20:49:24

rzax666
Użytkownik
Data rejestracji: 2018-12-11
Liczba postów: 43

Odp: Problem z uruchomieniem KDE

daj logi

Offline

#18 2019-08-13 10:10:56

pavbaranov
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-22
Liczba postów: 2,006
WWW

Odp: Problem z uruchomieniem KDE

WojAbuk napisał/a:

Gdy SDDM jest uruchamiane przy stracie systemu podaje tylko jeden komunikat i przez chwilę nic się nie dzieję (...). Czy jest możliwość żeby przy starcie systemu dawało taką serię jak to drugie? Przy drugim widzę że komputer coś mieli, a jak SDDM startuje wraz z systemem wydaje mi się że komputer się zawiesił.

Ok, już chyba - mniej więcej zaczynam rozumieć o co chodzi. Będzie dłuższy opis i masz odpowiedzieć: tak/nie (tam, gdzie wskazuję).

1. Masz uruchomioną usługę sddm:

# systemctl enable sddm

T/N?
2. Jeśli tak, to system startuje (jeśli nie masz "cichego" startu, czyli w GRUB bez "quiet") to widzisz jakieś pojawiające się informacje, potem... Potem nic, system wisi na jakiejś informacji tekstowej (prawdopodobnie, że podnosi układ grafiki). Od tej pory, można skakać, płakać i tak nic się nie dzieje, bo nie widzisz ani ekranu logowania (czyli SDDM) ani nie startuje Plazma. T/N?

Teraz pytania:
1. Czy na pewno masz właściwie skonfigurowane Xy? Zerknij na wiki Archa, a w szczególności na tę informację. Jeśli to właściwa podpowiedź, to tak zrób jak w podpowiedzi. Prawdopodobnie będziesz musiał wystartować system bez podnoszenia Xów, albo w momencie gdy "stoi" i nic się nie dzieje, przejść do konsoli: ctrl+alt+Fx (konkretny klawisz sprawdź sobie, ja zwykle daję F3).

2. Czy - jeśli SDDM nie jest skonfigurowane do automatycznego podnoszenia ("enable") a wywołujesz przez start usługi, to pojawia się ekran logowania? T/N?

3. Czy Ty masz komputer oparty o CPU i GPU AMD, czy też masz układ CPU Intela a GPU AMD?

4. Zerknij na info o konfiguracji SDDM. Teoretycznie obecnie SDDM winien startować nawet jeśli plik sddm.conf nie znajduje się w /etc/, jednakże niekiedy bywają z tym problemy. Prosto i domyślnie:

# cp /usr/lib/sddm/sddm.conf.d/default.conf /etc/sddm.conf

i zresetuj komputer.


Hardware: AMD: A8-7410 APU with Radeon R5; Arch testing+kde-unstable, kernel linux-pb 5.2, KDE+poprawki
https://deviantart.com/pavbaranov/ https://pavbaranov.blogspot.com https://linux-pavbaranov.blogspot.com

Offline

#19 2019-08-13 10:33:48

WojAbuk
Użytkownik
Data rejestracji: 2019-07-25
Liczba postów: 21

Odp: Problem z uruchomieniem KDE

1) Tak
2) Jak sprawdzić czy mam cichy start? Tak, ale po durniejszej chwili pojawia się ekran logowania.
Odpowiedzi na pytania:
1) Gdy uruchamiam przy użyciu start ekran logowania również się pojawia po trochę krótszej chwili (w moim odczuciu), ale gdy czekam na pojawienie się ekranu logowania cały czas widzę nowe komunikaty przez co nie zastanawiam się czy komputer mi się zawiesił.
2) Zarówno mam Ryzen 5 pierwszej generacji, bez zintegrowanego GPU na płycie z wyjściami graficznymi.
3) plik /etc/sddm.conf nie istniał.

Ostatnio edytowany przez WojAbuk (2019-08-13 10:34:12)

Offline

#20 2019-08-13 11:15:58

pavbaranov
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-22
Liczba postów: 2,006
WWW

Odp: Problem z uruchomieniem KDE

Plik sddm.conf, możesz sobie skopiować jak podałem i dostosować do siebie i swoich potrzeb.
Rozumiem, że obecnie system (Plazma) startuje, ale nie bardzo Cię zadowala czas startu tak samego SDDM, jak i Plazmy. Zgadza się?
Jeśli tak w istocie jest, no to jest to kwestia pewnej konfiguracji poprzedzonej poznaniem logów i sprawdzeniem, czy nie ma tam jakichś błędów. Logi to oczywiście journalctl, jednakże w AUR jest bardzo fajna nakładka i będzie Ci łatwiej. To qjournalctl - możesz sobie spokojnie zainstalować, bo działa przednio i nie trzeba pamiętać wszystkich przełączników dziennika.
Wpierw jednak proszę o info, czy sama Plazma startuje, a jeśli tak - to w istocie - logi od bieżącego logowania. Jeśli Ci się uda, to przytnij do samych błędów. Druga kwestia - info o:
1. używanym kernelu (linux-zen lekko lepiej się zachowuje wg mnie z AMD także),
2. jeśli kernel to lts - przejdź na "bieżący" - jest/bywa lepiej (choć u mnie - mam AMD, ale nie jest to Ryzen, lepiej było z 5.0 i 5.1 niż obecnym 5.2); oczywiście lts możesz zachować jako drugi,
3. jakiego schedulera używasz, bo z różnymi w przypadku AMD różnie bywa; ba nawet bywa tak, że z bfq raz jest fajnie, a innym razem gorzej; do wypróbowania,
4. pokaż ustawienia programu bootującego,
5. pokaż

systemd-analyze && systemd-analyze blame

6. czy dysk to HDD, czy SDD i jaki system plików na nim masz?

Jeśli chcesz widzieć komunikaty - po prostu usuń "quiet" z opcji bootowania kernela.


Hardware: AMD: A8-7410 APU with Radeon R5; Arch testing+kde-unstable, kernel linux-pb 5.2, KDE+poprawki
https://deviantart.com/pavbaranov/ https://pavbaranov.blogspot.com https://linux-pavbaranov.blogspot.com

Offline

#21 2019-08-13 12:24:01

WojAbuk
Użytkownik
Data rejestracji: 2019-07-25
Liczba postów: 21

Odp: Problem z uruchomieniem KDE

[email protected]:~$ sudo fdisk -l
[sudo] hasło użytkownika root: 
Dysk /dev/sda: 223,58 GiB, bajtów: 240057409536, sektorów: 468862128
Model dysku: GOODRAM         
Jednostki: sektorów, czyli 1 * 512 = 512 bajtów
Rozmiar sektora (logiczny/fizyczny) w bajtach: 512 / 512
Rozmiar we/wy (minimalny/optymalny) w bajtach: 512 / 512
Typ etykiety dysku: gpt
Identyfikator dysku: 97DD6DDC-3A32-47DA-B871-3216DA594D49

Urządzenie  Początek    Koniec   Sektory Rozmiar Typ
/dev/sda1       2048   1050623   1048576    512M System EFI
/dev/sda2    1050624 126050303 124999680   59,6G Linux - system plików
/dev/sda3  126050304 145582079  19531776    9,3G Linux - system plików
/dev/sda4  145582080 178980863  33398784   15,9G Linux swap
/dev/sda5  178980864 186793983   7813120    3,7G Linux - system plików
/dev/sda6  186793984 468860927 282066944  134,5G Linux - system plików

Konfiguracja dysków wygląda tak to jest dysk SSD (w tym wątku jest widoczne więcej https://forum.archlinux.org.pl/viewtopic.php?id=794 nie miałem ostatnio czasu, więc jeszcze nie skonfigurowałem swap). Widzę że pominąłem pytanie o Xy wydaje mi się że mam skonfigurowane poprawnie, ale głową nie ręczę. Korzystam z btrfs partycje z wyjątkiem sda6 (home) są sformatowane przy instalacji arch, a sda6 przez instalator debina.

Offline

#22 2019-08-13 17:36:43

WojAbuk
Użytkownik
Data rejestracji: 2019-07-25
Liczba postów: 21

Odp: Problem z uruchomieniem KDE

Ja mam domyślne jądro dla instalacji arch amd64 i nie za bardzo rozumiem co dalej piszesz o jądrze. Moja wiedza kończy się na tym że druga liczba w wersji jądra oznacza czy mam wersję stabilną i że wiele dystrybucji dostarcza zmodyfikowane jądro które zwykle działa lepiej w danej dystrybucji.
Linux-Zen to jądro wyspecjalizowane dla procesorów AMD?

Nie wiem jakiego schedulera używam. Jak to sprawdzić. Zainstalowałem jakiś sterownik z repozytorium (nie amd-pro).

Bez włączonego SDDM start trwa mniej niż  2 s, więc ustawienia grub nie mają znaczenia.

[email protected]:~$ systemd-analyze && systemd-analyze blame
Startup finished in 14.218s (firmware) + 3.234s (loader) + 3.272s (kernel) + 3.421s (userspace) = 24.145s 
graphical.target reached after 3.420s in userspace
          1.777s home.mount
           964ms systemd-logind.service
           481ms lvm2-monitor.service
           417ms dev-sda2.device
           322ms systemd-networkd.service
           241ms systemd-udevd.service
           239ms systemd-resolved.service
           232ms systemd-journald.service
           177ms systemd-journal-flush.service
           132ms upower.service
            90ms polkit.service
            89ms udisks2.service
            55ms tmp.mount
            55ms systemd-udev-trigger.service
            52ms var.mount
            45ms dev-sda4.swap
            34ms [email protected]
            27ms bluetooth.service
            18ms systemd-tmpfiles-setup.service
            16ms dev-hugepages.mount
            14ms systemd-tmpfiles-clean.service
            14ms [email protected]
            11ms systemd-tmpfiles-setup-dev.service
            11ms sys-kernel-debug.mount
            11ms systemd-modules-load.service
            11ms kmod-static-nodes.service
            11ms systemd-remount-fs.service
            10ms dev-mqueue.mount
             7ms systemd-update-utmp.service
             7ms systemd-user-sessions.service
lines 1-30

Offline

#23 2019-08-13 18:03:08

pavbaranov
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-22
Liczba postów: 2,006
WWW

Odp: Problem z uruchomieniem KDE

Zainstalowałeś i skonfigurowałeś firmware AMD (amd-ucode)? Chyba tu problem. Odsyłam do wiki, bo wytłumaczone bardzo dobrze.

Jeśli czegoś nie rozumiesz, to musisz w sposób bardziej wyraźny napisać o co chodzi, wówczas odpowiem ja, czy ktokolwiek.

EDIT:
Nie, linux-zen nie jest "wyspecjalizowany dla procesorów AMD". Jest on natomiast w nieco większym stopniu robiony dla zastosowań desktopowych. Podstawowy problem, to nigdy nie wiadomo co w tym patchu jest, zwłaszcza w początkach danego kernela. Dla AMD masz dwa, trzy kernele w AUR, w tym co najmniej jeden dla Ryzen, jednakże krótki przegląd ich configów nie powoduje mego zainteresowania się nimi. Zdecydowanie lepiej go "skroić" samemu. Jak na razie, masz prawdopodobnie problem z firmware (ucode). Reszta w normie, a na brtfs się nie znam i unikam (dla SSD mam u siebie f2fs).


Hardware: AMD: A8-7410 APU with Radeon R5; Arch testing+kde-unstable, kernel linux-pb 5.2, KDE+poprawki
https://deviantart.com/pavbaranov/ https://pavbaranov.blogspot.com https://linux-pavbaranov.blogspot.com

Offline

Stopka

Forum oparte na FluxBB