Nie jesteś zalogowany na forum.

#1 2019-07-04 03:31:03

pasta20
Użytkownik
Data rejestracji: 2019-07-03
Liczba postów: 11

[ROZW.] rpi2 arch linux ca-certificates-utils-20181109-1

Witam wszystkich próbuje zainstalować pakiet jak powyżej i wyrzuca mi błąd.

[[email protected] alarm]# pacman -Syu
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 alarm is up to date
 aur is up to date
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...

Packages (1) ca-certificates-utils-20181109-1

Total Download Size:   0.01 MiB
Total Installed Size:  0.09 MiB
Net Upgrade Size:      0.00 MiB

:: Proceed with installation? [Y/n] y
:: Retrieving packages...
 ca-certificates-utils-20181109-1-any        8.3 KiB   833K/s 00:00 [#####################################] 100%
(1/1) checking keys in keyring                                      [#####################################] 100%
(1/1) checking package integrity                                    [#####################################] 100%
error: ca-certificates-utils: signature from "Arch Linux ARM Build System <[email protected]>" is unknown trust
:: File /var/cache/pacman/pkg/ca-certificates-utils-20181109-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] n
error: failed to commit transaction (invalid or corrupted package (PGP signature))
Errors occurred, no packages were upgraded.

Następny,

[[email protected] alarm]# pacman -S tar
warning: tar-1.32-1 is up to date -- reinstalling
resolving dependencies...
looking for conflicting packages...

Packages (1) tar-1.32-1

Total Download Size:   0.69 MiB
Total Installed Size:  3.09 MiB
Net Upgrade Size:      0.00 MiB

:: Proceed with installation? [Y/n] y
:: Retrieving packages...
 tar-1.32-1-armv7h                         711.3 KiB   647K/s 00:01 [#####################################] 100%
(1/1) checking keys in keyring                                      [#####################################] 100%
(1/1) checking package integrity                                    [#####################################] 100%
error: tar: signature from "Arch Linux ARM Build System <[email protected]>" is unknown trust
:: File /var/cache/pacman/pkg/tar-1.32-1-armv7h.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: failed to commit transaction (invalid or corrupted package (PGP signature))
Errors occurred, no packages were upgraded.

Czy istnieje cod dzięki któremu zrobię całą aktualizację tzn wszystko mi poprawi przeinstaluje lub opcja powrodu do starych bibliotek.
Pozdrawiam.

Dodam ,żę chciałem zainstalować openhab2 próbowałem dodać z tej strony
https://aur.archlinux.org/packages/openhab2/
https://aur.archlinux.org/packages/?K=openhab&SB=p
Skończyło się klęską eh.

[[email protected] alarm]# pacman -S mc
warning: mc-4.8.23-1 is up to date -- reinstalling
resolving dependencies...
looking for conflicting packages...

Packages (1) mc-4.8.23-1

Total Installed Size:  7.18 MiB
Net Upgrade Size:      0.00 MiB

:: Proceed with installation? [Y/n] y
(1/1) checking keys in keyring                                      [#####################################] 100%
(1/1) checking package integrity                                    [#####################################] 100%
error: mc: signature from "Arch Linux ARM Build System <[email protected]>" is unknown trust
:: File /var/cache/pacman/pkg/mc-4.8.23-1-armv7h.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: failed to commit transaction (invalid or corrupted package (PGP signature))
Errors occurred, no packages were upgraded.

Hm wszytko co próbuje zainstalować wywala błąd.

Ostatnio edytowany przez pasta20 (2019-07-04 03:40:21)

Offline

#2 2019-07-04 04:50:13

pavbaranov
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-22
Liczba postów: 1,923
WWW

Odp: [ROZW.] rpi2 arch linux ca-certificates-utils-20181109-1

Hmmm... To jest Arch Linux ARM, jak sądzę. Dla dystrybucji pochodnych mamy specjalne miejsce, przenoszę.
Pokaż zawartość

cat /etc/pacman.conf

Jeśli nic tu nie namieszałeś, to baza keyring w tej dystrybucji jest walnięta i należy to im zgłosić, albo poczekać. Można też się ręcznie pobawić w ominięcie, ale to nie jest najsensowniejsze wyjście.
Jest jeszcze jedna możliwość - kiedy ostatni raz robiłeś aktualizację systemu i czy wykonałeś po niej: https://archlinuxarm.org/forum/viewtopi … =3&t=12797


Hardware: AMD: A8-7410 APU with Radeon R5; Arch testing+kde-unstable, kernel linux-pb 5.2, KDE+poprawki
https://deviantart.com/pavbaranov/ https://pavbaranov.blogspot.com https://linux-pavbaranov.blogspot.com

Offline

#3 2019-07-04 14:15:00

pasta20
Użytkownik
Data rejestracji: 2019-07-03
Liczba postów: 11

Odp: [ROZW.] rpi2 arch linux ca-certificates-utils-20181109-1

/etc/pacman.conf
#
# See the pacman.conf(5) manpage for option and repository directives

#
# GENERAL OPTIONS
#
[options]
# The following paths are commented out with their default values listed.
# If you wish to use different paths, uncomment and update the paths.
#RootDir     = /
#DBPath      = /var/lib/pacman/
#CacheDir    = /var/cache/pacman/pkg/
#LogFile     = /var/log/pacman.log
#GPGDir      = /etc/pacman.d/gnupg/
#HookDir     = /etc/pacman.d/hooks/
HoldPkg     = pacman glibc
#XferCommand = /usr/bin/curl -L -C - -f -o %o %u
#XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u
#CleanMethod = KeepInstalled
#UseDelta    = 0.7
Architecture = armv7h

# Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup
#IgnorePkg   =
#IgnoreGroup =

#NoUpgrade   =
#NoExtract   =

# Misc options
#UseSyslog
#Color
#TotalDownload
CheckSpace
#VerbosePkgLists

# By default, pacman accepts packages signed by keys that its local keyring
# trusts (see pacman-key and its man page), as well as unsigned packages.
SigLevel    = Required DatabaseOptional
LocalFileSigLevel = Optional
#RemoteFileSigLevel = Required

# NOTE: You must run `pacman-key --init` before first using pacman; the local
# keyring can then be populated with the keys of all official Arch Linux ARM
# packagers with `pacman-key --populate archlinuxarm`.

#
# REPOSITORIES
#   - can be defined here or included from another file
#   - pacman will search repositories in the order defined here
#   - local/custom mirrors can be added here or in separate files
#   - repositories listed first will take precedence when packages
#     have identical names, regardless of version number
#   - URLs will have $repo replaced by the name of the current repo
#   - URLs will have $arch replaced by the name of the architecture
#
# Repository entries are of the format:
#       [repo-name]
#       Server = ServerName
#       Include = IncludePath
#
# The header [repo-name] is crucial - it must be present and
# uncommented to enable the repo.
#

# The testing repositories are disabled by default. To enable, uncomment the
# repo name header and Include lines. You can add preferred servers immediately
# after the header, and they will be used before the default mirrors.

[core]
Include = /etc/pacman.d/mirrorlist

[extra]
Include = /etc/pacman.d/mirrorlist

[community]
Include = /etc/pacman.d/mirrorlist

[alarm]
Include = /etc/pacman.d/mirrorlist

[aur]
Include = /etc/pacman.d/mirrorlist

# An example of a custom package repository.  See the pacman manpage for
# tips on creating your own repositories.
#[custom]
#SigLevel = Optional TrustAll
#Server = file:///home/custompkgs

pacman

[[email protected] alarm]# pacman -F
warning: database file for 'core' does not exist (use '-Fy' to download)
warning: database file for 'extra' does not exist (use '-Fy' to download)
warning: database file for 'community' does not exist (use '-Fy' to download)
warning: database file for 'alarm' does not exist (use '-Fy' to download)
warning: database file for 'aur' does not exist (use '-Fy' to download)
[[email protected] alarm]# pacman -Fy
:: Synchronizing package databases...
error: failed retrieving file 'core.files' from mirror.archlinuxarm.org : Could not resolve host: mirror.archlinuxarm.org
error: failed to update core (invalid url for server)
error: failed retrieving file 'extra.files' from mirror.archlinuxarm.org : Could not resolve host: mirror.archlinuxarm.org
error: failed to update extra (invalid url for server)
error: failed retrieving file 'community.files' from mirror.archlinuxarm.org : Could not resolve host: mirror.archlinuxarm.org
error: failed to update community (invalid url for server)
error: failed retrieving file 'alarm.files' from mirror.archlinuxarm.org : Could not resolve host: mirror.archlinuxarm.org
error: failed to update alarm (invalid url for server)
error: failed retrieving file 'aur.files' from mirror.archlinuxarm.org : Could not resolve host: mirror.archlinuxarm.org
error: failed to update aur (invalid url for server)
error: failed to synchronize all databases
[[email protected] alarm]#

Próbowałem na nowo wgrać obraz na kartę i zrobić aktualizację ale dalej coś nie halo ;/
może jakieś przydatne instrukcje :) jak przejść bezboleśnie.
Kilka lat temu jak bawiłem się rpi2 to dwie komendy załatwiły wsio a teraz lipa same problemy nie wiem czemu :(

[[email protected] alarm]# pacman -Sy
:: Synchronizing package databases...
 core                               213.7 KiB   301K/s 00:01 [################################] 100%
 extra                                2.2 MiB   740K/s 00:03 [################################] 100%
 community                            5.1 MiB   709K/s 00:07 [################################] 100%
 alarm                              117.7 KiB   692K/s 00:00 [################################] 100%
 aur                                  5.2 KiB   520K/s 00:00 [################################] 100%
[[email protected] alarm]# pacman -Su
:: Starting full system upgrade...
:: Replace ca-certificates-cacert with core/ca-certificates? [Y/n] y
:: Replace libsystemd with core/systemd-libs? [Y/n] y
resolving dependencies...
looking for conflicting packages...

Packages (158) acl-2.2.53-1  archlinuxarm-keyring-20140119-1  argon2-20171227-3  attr-2.4.48-1
               audit-2.8.5-3  bash-5.0.007-1  bzip2-1.0.7-1  ca-certificates-20181109-1
               ca-certificates-cacert-20140824-4 [removal]  ca-certificates-mozilla-3.44.1-1
               ca-certificates-utils-20181109-1  coreutils-8.31-1  cracklib-2.9.7-1  crda-4.14-2
               cryptsetup-2.1.0-1  curl-7.65.1-3  db-5.3.28-4  dbus-1.12.16-1
               device-mapper-2.02.185-1  dhcpcd-7.2.2-1  dialog-1:1.3_20190211-1  diffutils-3.7-1
               dnssec-anchors-20190629-1  e2fsprogs-1.45.2-1  expat-2.2.7-1  file-5.37-2
               filesystem-2019.05-2  findutils-4.6.0-4.1  firmware-raspberrypi-5-1  gawk-4.2.1-2
               gcc-libs-8.3.0-1  gdbm-1.18.1-2  gettext-0.19.8.1-3  glib2-2.60.4-1  glibc-2.29-1
               gmp-6.1.2-2  gnupg-2.2.16-1  gnutls-3.6.8-1  gpgme-1.13.1-1  grep-3.3-1
               groff-1.22.4-1  gzip-1.10-1  haveged-1.9.4-3  hwids-20190316-1  iana-etc-20190531-1
               icu-64.2-1  inetutils-1.9.4-7  iproute2-5.1.0-1  iptables-1:1.8.3-1
               iputils-20180629.f6aac8d-4  iw-5.0.1-1  jfsutils-1.1.15-6  json-c-0.13.1-2
               kbd-2.0.4-2  keyutils-1.6-1  kmod-26-2  krb5-1.17-1  ldns-1.7.0-4  less-551-1
               libaio-0.3.112-1  libarchive-3.4.0-2  libassuan-2.5.3-1  libcap-2.27-1
               libcap-ng-0.7.9-1  libcroco-0.6.13-1  libedit-20190324_3.1-1  libelf-0.176-1
               libffi-3.2.1-3  libgcrypt-1.8.4-1  libgpg-error-1.36-1  libidn-1.35-1
               libidn2-2.2.0-1  libksba-1.3.5-1  libldap-2.4.47-3  libmnl-1.0.4-2
               libnetfilter_conntrack-1.0.7-1  libnfnetlink-1.0.1-3  libnftnl-1.1.3-1
               libnghttp2-1.36.0-1  libnl-3.4.0-1  libpcap-1.9.0-1  libpipeline-1.5.1-1
               libpsl-0.21.0-1  libsasl-2.1.27-1  libseccomp-2.4.1-2  libsecret-0.18.8-2
               libssh2-1.8.2-1  libsystemd-232-6 [removal]  libtasn1-4.13-1  libtirpc-1.1.4-1
               libunistring-0.9.10-1  libusb-1.0.22-1  libutil-linux-2.34-3  libxml2-2.9.9-2
               licenses-20181104-1  linux-api-headers-5.1-1  linux-firmware-20190618.acb56f2-1
               linux-raspberrypi-4.19.56-2  logrotate-3.15.0-1  lvm2-2.02.185-1  lz4-1:1.9.1-1
               lzo-2.10-2  man-db-2.8.5-2  man-pages-5.01-1  mdadm-4.1-1  mkinitcpio-25-2
               mkinitcpio-busybox-1.30.1-1  mpfr-4.0.2-1  nano-4.3-1  ncurses-6.1-6
               net-tools-1.60.20181103git-1  netctl-1.20-1  nettle-3.4.1-1  npth-1.6-1
               openresolv-3.9.0-2  openssh-8.0p1-1  openssl-1.1.1.c-1  p11-kit-0.23.16.1-1
               pacman-5.1.3-1.1  pacman-mirrorlist-20180903-1  pam-1.3.1-1  pambase-20190105.1-1
               pciutils-3.6.2-1  pcre-8.43-1  pcre2-10.33-1  perl-5.30.0-3  pinentry-1.1.0-4
               popt-1.16-10  procps-ng-3.3.15-1  psmisc-23.2-1  raspberrypi-bootloader-20190702-1
               raspberrypi-bootloader-x-20190702-1  raspberrypi-firmware-20190626-1
               readline-8.0.0-1  reiserfsprogs-3.6.27-2  s-nail-14.9.13-2  sed-4.7-1  shadow-4.6-3
               sqlite-3.28.0-1  sysfsutils-2.1.0-10  systemd-242.32-1  systemd-libs-242.32-1
               systemd-sysvcompat-242.32-1  tar-1.32-1  texinfo-6.6-1
               thin-provisioning-tools-0.8.5-2  tzdata-2019a-1  usbutils-010-1  util-linux-2.34-3
               vi-1:070224-3  which-2.21-3  wireless-regdb-2019.03.01-1  wireless_tools-30.pre9-2
               wpa_supplicant-2:2.8-1  xfsprogs-4.20.0-2  xz-5.2.4-1  zlib-1:1.2.11-3  zstd-1.4.0-1

Total Download Size:    228.19 MiB
Total Installed Size:  1006.29 MiB
Net Upgrade Size:       385.96 MiB

:: Proceed with installation? [Y/n]

:: Retrieving packages...
 linux-api-headers-5.1-1-any        978.6 KiB   384K/s 00:03 [################################] 100%
 tzdata-2019a-1-armv7h              358.9 KiB   551K/s 00:01 [################################] 100%
 iana-etc-20190531-1-any            368.4 KiB   392K/s 00:01 [################################] 100%
 filesystem-2019.05-2-armv7h         29.1 KiB   265K/s 00:00 [################################] 100%
 glibc-2.29-1-armv7h                  8.3 MiB   504K/s 00:17 [################################] 100%
 attr-2.4.48-1-armv7h                64.3 KiB   495K/s 00:00 [################################] 100%
 acl-2.2.53-1-armv7h                128.6 KiB   429K/s 00:00 [################################] 100%
 gcc-libs-8.3.0-1-armv7h             16.2 MiB   828K/s 00:20 [################################] 100%
 ncurses-6.1-6-armv7h              1048.4 KiB   912K/s 00:01 [################################] 100%
 readline-8.0.0-1-armv7h            276.3 KiB   389K/s 00:01 [################################] 100%
 bash-5.0.007-1-armv7h             1484.7 KiB   569K/s 00:03 [################################] 100%
 bzip2-1.0.7-1-armv7h                50.3 KiB   419K/s 00:00 [################################] 100%
 gmp-6.1.2-2-armv7h                 327.9 KiB  1058K/s 00:00 [################################] 100%
 libcap-2.27-1-armv7h                38.6 KiB   771K/s 00:00 [################################] 100%
 gdbm-1.18.1-2-armv7h               151.5 KiB   841K/s 00:00 [################################] 100%
 db-5.3.28-4-armv7h                 918.5 KiB   723K/s 00:01 [################################] 100%
 perl-5.30.0-3-armv7h                13.5 MiB   729K/s 00:19 [################################] 100%
 openssl-1.1.1.c-1-armv7h             3.1 MiB   708K/s 00:05 [################################] 100%
 coreutils-8.31-1-armv7h              2.2 MiB   811K/s 00:03 [################################] 100%
 findutils-4.6.0-4.1-armv7h         409.3 KiB   401K/s 00:01 [################################] 100%
 libtasn1-4.13-1-armv7h             111.0 KiB   336K/s 00:00 [################################] 100%
 libffi-3.2.1-3-armv7h               29.7 KiB   297K/s 00:00 [################################] 100%
 libgpg-error-1.36-1-armv7h         183.2 KiB   481K/s 00:00 [################################] 100%
 libgcrypt-1.8.4-1-armv7h           406.2 KiB   402K/s 00:01 [################################] 100%
 lz4-1:1.9.1-1-armv7h                95.2 KiB   381K/s 00:00 [################################] 100%
 xz-5.2.4-1-armv7h                  222.3 KiB   347K/s 00:01 [################################] 100%
 systemd-libs-242.32-1-armv7h       344.4 KiB   703K/s 00:00 [################################] 100%
 device-mapper-2.02.185-1-armv7h    255.3 KiB   425K/s 00:01 [################################] 100%
 popt-1.16-10-armv7h                 60.1 KiB   334K/s 00:00 [################################] 100%
 libutil-linux-2.34-3-armv7h        323.2 KiB   437K/s 00:01 [################################] 100%
 json-c-0.13.1-2-armv7h              42.3 KiB   470K/s 00:00 [################################] 100%
 argon2-20171227-3-armv7h            32.2 KiB  1073K/s 00:00 [################################] 100%
 cryptsetup-2.1.0-1-armv7h          363.4 KiB   932K/s 00:00 [################################] 100%
 expat-2.2.7-1-armv7h                79.6 KiB   995K/s 00:00 [################################] 100%
 e2fsprogs-1.45.2-1-armv7h         1030.6 KiB   852K/s 00:01 [################################] 100%
 libsasl-2.1.27-1-armv7h            122.0 KiB  1220K/s 00:00 [################################] 100%
 libldap-2.4.47-3-armv7h            251.0 KiB   369K/s 00:01 [################################] 100%
 keyutils-1.6-1-armv7h               81.5 KiB   543K/s 00:00 [################################] 100%
 krb5-1.17-1-armv7h                1088.6 KiB  1158K/s 00:01 [################################] 100%
 libcap-ng-0.7.9-1-armv7h            33.3 KiB   833K/s 00:00 [################################] 100%
 audit-2.8.5-3-armv7h               304.0 KiB  1322K/s 00:00 [################################] 100%
 dbus-1.12.16-1-armv7h              236.2 KiB  1476K/s 00:00 [################################] 100%
 libmnl-1.0.4-2-armv7h                9.3 KiB  44.3K/s 00:00 [################################] 100%
 libnftnl-1.1.3-1-armv7h             44.6 KiB   406K/s 00:00 [################################] 100%
 libnl-3.4.0-1-armv7h               307.2 KiB   991K/s 00:00 [################################] 100%
 libusb-1.0.22-1-armv7h              49.5 KiB  1649K/s 00:00 [################################] 100%
 libpcap-1.9.0-1-armv7h             219.2 KiB  1461K/s 00:00 [################################] 100%
 iptables-1:1.8.3-1-armv7h          359.8 KiB   666K/s 00:01 [################################] 100%
 zlib-1:1.2.11-3-armv7h              75.0 KiB   833K/s 00:00 [################################] 100%
 cracklib-2.9.7-1-armv7h            250.0 KiB  1250K/s 00:00 [################################] 100%
 libtirpc-1.1.4-1-armv7h            164.1 KiB   966K/s 00:00 [################################] 100%
 pambase-20190105.1-1-any             3.1 KiB  0.00B/s 00:00 [################################] 100%
 pam-1.3.1-1-armv7h                 539.1 KiB   556K/s 00:01 [################################] 100%
 kbd-2.0.4-2-armv7h                1117.0 KiB   412K/s 00:03 [################################] 100%
 kmod-26-2-armv7h                   102.0 KiB   182K/s 00:01 [################################] 100%
 hwids-20190316-1-any               366.6 KiB   464K/s 00:01 [################################] 100%
 libunistring-0.9.10-1-armv7h       474.9 KiB   485K/s 00:01 [################################] 100%
 libidn2-2.2.0-1-armv7h             112.6 KiB   662K/s 00:00 [################################] 100%
 libelf-0.176-1-armv7h              332.2 KiB   738K/s 00:00 [################################] 100%
 libseccomp-2.4.1-2-armv7h           66.1 KiB   661K/s 00:00 [################################] 100%
 shadow-4.6-3-armv7h               1057.3 KiB   356K/s 00:03 [################################] 100%
 util-linux-2.34-3-armv7h          1998.1 KiB   666K/s 00:03 [################################] 100%
 pcre2-10.33-1-armv7h               943.9 KiB   559K/s 00:02 [################################] 100%
 systemd-242.32-1-armv7h              4.1 MiB   501K/s 00:08 [################################] 100%
 p11-kit-0.23.16.1-1-armv7h         377.4 KiB   132K/s 00:03 [################################] 100%
 ca-certificates-utils-2018110...     8.3 KiB   833K/s 00:00 [################################] 100%
 ca-certificates-mozilla-3.44....   337.2 KiB  1054K/s 00:00 [################################] 100%
 ca-certificates-20181109-1-any       2.2 KiB   216K/s 00:00 [################################] 100%
 wireless-regdb-2019.03.01-1-any      9.7 KiB  0.00B/s 00:00 [################################] 100%
 iw-5.0.1-1-armv7h                   70.1 KiB   779K/s 00:00 [################################] 100%
 crda-4.14-2-armv7h                  56.9 KiB   632K/s 00:00 [################################] 100%
 libssh2-1.8.2-1-armv7h             170.0 KiB   654K/s 00:00 [################################] 100%
 libpsl-0.21.0-1-armv7h              72.8 KiB   607K/s 00:00 [################################] 100%
 libnghttp2-1.36.0-1-armv7h          75.9 KiB   422K/s 00:00 [################################] 100%
 curl-7.65.1-3-armv7h               933.3 KiB   639K/s 00:01 [################################] 100%
 dhcpcd-7.2.2-1-armv7h              147.6 KiB   205K/s 00:01 [################################] 100%
 dialog-1:1.3_20190211-1-armv7h     162.7 KiB   857K/s 00:00 [################################] 100%
 diffutils-3.7-1-armv7h             306.6 KiB   444K/s 00:01 [################################] 100%
 dnssec-anchors-20190629-1-any        3.3 KiB   331K/s 00:00 [################################] 100%
 file-5.37-2-armv7h                 284.5 KiB   837K/s 00:00 [################################] 100%
 mpfr-4.0.2-1-armv7h                264.7 KiB   945K/s 00:00 [################################] 100%
 gawk-4.2.1-2-armv7h               1006.7 KiB   799K/s 00:01 [################################] 100%
 pcre-8.43-1-armv7h                 859.5 KiB   671K/s 00:01 [################################] 100%
 glib2-2.60.4-1-armv7h                2.2 MiB   601K/s 00:04 [################################] 100%
 icu-64.2-1-armv7h                    8.4 MiB   464K/s 00:19 [################################] 100%
 gettext-0.19.8.1-3-armv7h         1716.2 KiB   538K/s 00:03 [################################] 100%
 npth-1.6-1-armv7h                   12.2 KiB   608K/s 00:00 [################################] 100%
 libksba-1.3.5-1-armv7h              99.4 KiB   994K/s 00:00 [################################] 100%
 libassuan-2.5.3-1-armv7h            79.5 KiB   156K/s 00:01 [################################] 100%
 libsecret-0.18.8-2-armv7h          182.2 KiB   729K/s 00:00 [################################] 100%
 pinentry-1.1.0-4-armv7h             83.5 KiB   759K/s 00:00 [################################] 100%
 nettle-3.4.1-1-armv7h              329.1 KiB   997K/s 00:00 [################################] 100%
 gnutls-3.6.8-1-armv7h                2.4 MiB   782K/s 00:03 [################################] 100%
 sqlite-3.28.0-1-armv7h            1078.0 KiB   539K/s 00:02 [################################] 100%
error: failed retrieving file 'gnupg-2.2.16-1-armv7h.pkg.tar.xz' from mirror.archlinuxarm.org : Operation too slow. Less than 1 bytes/sec transferred the last 10 seconds
warning: failed to retrieve some files
 gpgme-1.13.1-1-armv7h              365.8 KiB   463K/s 00:01 [################################] 100%
 grep-3.3-1-armv7h                  176.4 KiB   735K/s 00:00 [################################] 100%
 groff-1.22.4-1-armv7h             1880.8 KiB   684K/s 00:03 [################################] 100%
 less-551-1-armv7h                   93.1 KiB   931K/s 00:00 [################################] 100%
 gzip-1.10-1-armv7h                  74.6 KiB   829K/s 00:00 [################################] 100%
 inetutils-1.9.4-7-armv7h           260.7 KiB   652K/s 00:00 [################################] 100%
 iproute2-5.1.0-1-armv7h            764.3 KiB   546K/s 00:01 [################################] 100%
 iputils-20180629.f6aac8d-4-armv7h   70.2 KiB   468K/s 00:00 [################################] 100%
 jfsutils-1.1.15-6-armv7h           165.2 KiB   207K/s 00:01 [################################] 100%
 ldns-1.7.0-4-armv7h                412.8 KiB   878K/s 00:00 [################################] 100%
 zstd-1.4.0-1-armv7h                308.5 KiB   268K/s 00:01 [################################] 100%
 libarchive-3.4.0-2-armv7h          427.4 KiB   399K/s 00:01 [################################] 100%
 libedit-20190324_3.1-1-armv7h       82.9 KiB   829K/s 00:00 [################################] 100%
 libidn-1.35-1-armv7h               202.5 KiB   241K/s 00:01 [################################] 100%
 libpipeline-1.5.1-1-armv7h          33.9 KiB   565K/s 00:00 [################################] 100%
 licenses-20181104-1-any             67.3 KiB   129K/s 00:01 [################################] 100%
 linux-firmware-20190618.acb56...    79.9 MiB   740K/s 01:51 [################################] 100%
 mkinitcpio-busybox-1.30.1-1-a...   243.1 KiB  91.7K/s 00:03 [################################] 100%
 mkinitcpio-25-2-any                 40.1 KiB   803K/s 00:00 [################################] 100%
 linux-raspberrypi-4.19.56-2-a...    25.9 MiB   636K/s 00:42 [################################] 100%
 logrotate-3.15.0-1-armv7h           39.0 KiB   651K/s 00:00 [################################] 100%
 thin-provisioning-tools-0.8.5...   326.4 KiB   398K/s 00:01 [################################] 100%
 lvm2-2.02.185-1-armv7h            1210.0 KiB   526K/s 00:02 [################################] 100%
 lzo-2.10-2-armv7h                   74.2 KiB   825K/s 00:00 [################################] 100%
 man-db-2.8.5-2-armv7h              937.0 KiB  1053K/s 00:01 [################################] 100%
 man-pages-5.01-1-any                 5.8 MiB   526K/s 00:11 [################################] 100%
 mdadm-4.1-1-armv7h                 310.6 KiB   971K/s 00:00 [################################] 100%
 nano-4.3-1-armv7h                  461.3 KiB   536K/s 00:01 [################################] 100%
 net-tools-1.60.20181103git-1-...   111.1 KiB   793K/s 00:00 [################################] 100%
 openresolv-3.9.0-2-any              21.5 KiB   536K/s 00:00 [################################] 100%
 netctl-1.20-1-any                   40.1 KiB   446K/s 00:00 [################################] 100%
 openssh-8.0p1-1-armv7h             622.6 KiB   669K/s 00:01 [################################] 100%
 pacman-mirrorlist-20180903-1-any     2.6 KiB  0.00B/s 00:00 [################################] 100%
 archlinuxarm-keyring-20140119...    12.2 KiB   609K/s 00:00 [################################] 100%
 pacman-5.1.3-1.1-armv7h            733.4 KiB  1079K/s 00:01 [################################] 100%
 pciutils-3.6.2-1-armv7h             76.4 KiB   764K/s 00:00 [################################] 100%
 procps-ng-3.3.15-1-armv7h          327.7 KiB   443K/s 00:01 [################################] 100%
 psmisc-23.2-1-armv7h               103.6 KiB   648K/s 00:00 [################################] 100%
 reiserfsprogs-3.6.27-2-armv7h      188.9 KiB   700K/s 00:00 [################################] 100%
 s-nail-14.9.13-2-armv7h            447.0 KiB   392K/s 00:01 [################################] 100%
 sed-4.7-1-armv7h                   205.5 KiB   326K/s 00:01 [################################] 100%
 sysfsutils-2.1.0-10-armv7h          27.9 KiB  63.4K/s 00:00 [################################] 100%
 systemd-sysvcompat-242.32-1-a...     7.6 KiB   382K/s 00:00 [################################] 100%
 tar-1.32-1-armv7h                  711.3 KiB   588K/s 00:01 [################################] 100%
 texinfo-6.6-1-armv7h              1264.7 KiB   415K/s 00:03 [################################] 100%
 usbutils-010-1-armv7h               62.9 KiB   484K/s 00:00 [################################] 100%
 vi-1:070224-3-armv7h               139.4 KiB   996K/s 00:00 [################################] 100%
 which-2.21-3-armv7h                 14.4 KiB   480K/s 00:00 [################################] 100%
 wireless_tools-30.pre9-2-armv7h    122.7 KiB   767K/s 00:00 [################################] 100%
 wpa_supplicant-2:2.8-1-armv7h      759.9 KiB   745K/s 00:01 [################################] 100%
 xfsprogs-4.20.0-2-armv7h           817.9 KiB  1010K/s 00:01 [################################] 100%
 libnfnetlink-1.0.1-3-armv7h         15.4 KiB   513K/s 00:00 [################################] 100%
 libnetfilter_conntrack-1.0.7-...    38.8 KiB   777K/s 00:00 [################################] 100%
 libxml2-2.9.9-2-armv7h            1148.3 KiB   614K/s 00:02 [################################] 100%
 libcroco-0.6.13-1-armv7h           133.4 KiB   953K/s 00:00 [################################] 100%
 haveged-1.9.4-3-armv7h              41.8 KiB   697K/s 00:00 [################################] 100%
 libaio-0.3.112-1-armv7h              6.1 KiB  0.00B/s 00:00 [################################] 100%
 firmware-raspberrypi-5-1-any       556.6 KiB   618K/s 00:01 [################################] 100%
 raspberrypi-bootloader-201907...     4.8 MiB  1074K/s 00:05 [################################] 100%
 raspberrypi-bootloader-x-2019...  1788.2 KiB   592K/s 00:03 [################################] 100%
 raspberrypi-firmware-20190626...  1446.5 KiB   753K/s 00:02 [################################] 100%
error: failed to commit transaction (unexpected error)
Errors occurred, no packages were upgraded.

Eh a teraz nie można aktualizacji zrobić reszty bibliotek

[[email protected] alarm]# pacman -Syu
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 alarm is up to date
 aur is up to date
:: Starting full system upgrade...
:: Replace ca-certificates-cacert with core/ca-certificates? [Y/n] y
:: Replace libsystemd with core/systemd-libs? [Y/n] y
resolving dependencies...
looking for conflicting packages...

Packages (158) acl-2.2.53-1  archlinuxarm-keyring-20140119-1  argon2-20171227-3  attr-2.4.48-1
               audit-2.8.5-3  bash-5.0.007-1  bzip2-1.0.7-1  ca-certificates-20181109-1
               ca-certificates-cacert-20140824-4 [removal]  ca-certificates-mozilla-3.44.1-1
               ca-certificates-utils-20181109-1  coreutils-8.31-1  cracklib-2.9.7-1  crda-4.14-2
               cryptsetup-2.1.0-1  curl-7.65.1-3  db-5.3.28-4  dbus-1.12.16-1
               device-mapper-2.02.185-1  dhcpcd-7.2.2-1  dialog-1:1.3_20190211-1  diffutils-3.7-1
               dnssec-anchors-20190629-1  e2fsprogs-1.45.2-1  expat-2.2.7-1  file-5.37-2
               filesystem-2019.05-2  findutils-4.6.0-4.1  firmware-raspberrypi-5-1  gawk-4.2.1-2
               gcc-libs-8.3.0-1  gdbm-1.18.1-2  gettext-0.19.8.1-3  glib2-2.60.4-1  glibc-2.29-1
               gmp-6.1.2-2  gnupg-2.2.16-1  gnutls-3.6.8-1  gpgme-1.13.1-1  grep-3.3-1
               groff-1.22.4-1  gzip-1.10-1  haveged-1.9.4-3  hwids-20190316-1  iana-etc-20190531-1
               icu-64.2-1  inetutils-1.9.4-7  iproute2-5.1.0-1  iptables-1:1.8.3-1
               iputils-20180629.f6aac8d-4  iw-5.0.1-1  jfsutils-1.1.15-6  json-c-0.13.1-2
               kbd-2.0.4-2  keyutils-1.6-1  kmod-26-2  krb5-1.17-1  ldns-1.7.0-4  less-551-1
               libaio-0.3.112-1  libarchive-3.4.0-2  libassuan-2.5.3-1  libcap-2.27-1
               libcap-ng-0.7.9-1  libcroco-0.6.13-1  libedit-20190324_3.1-1  libelf-0.176-1
               libffi-3.2.1-3  libgcrypt-1.8.4-1  libgpg-error-1.36-1  libidn-1.35-1
               libidn2-2.2.0-1  libksba-1.3.5-1  libldap-2.4.47-3  libmnl-1.0.4-2
               libnetfilter_conntrack-1.0.7-1  libnfnetlink-1.0.1-3  libnftnl-1.1.3-1
               libnghttp2-1.36.0-1  libnl-3.4.0-1  libpcap-1.9.0-1  libpipeline-1.5.1-1
               libpsl-0.21.0-1  libsasl-2.1.27-1  libseccomp-2.4.1-2  libsecret-0.18.8-2
               libssh2-1.8.2-1  libsystemd-232-6 [removal]  libtasn1-4.13-1  libtirpc-1.1.4-1
               libunistring-0.9.10-1  libusb-1.0.22-1  libutil-linux-2.34-3  libxml2-2.9.9-2
               licenses-20181104-1  linux-api-headers-5.1-1  linux-firmware-20190618.acb56f2-1
               linux-raspberrypi-4.19.56-2  logrotate-3.15.0-1  lvm2-2.02.185-1  lz4-1:1.9.1-1
               lzo-2.10-2  man-db-2.8.5-2  man-pages-5.01-1  mdadm-4.1-1  mkinitcpio-25-2
               mkinitcpio-busybox-1.30.1-1  mpfr-4.0.2-1  nano-4.3-1  ncurses-6.1-6
               net-tools-1.60.20181103git-1  netctl-1.20-1  nettle-3.4.1-1  npth-1.6-1
               openresolv-3.9.0-2  openssh-8.0p1-1  openssl-1.1.1.c-1  p11-kit-0.23.16.1-1
               pacman-5.1.3-1.1  pacman-mirrorlist-20180903-1  pam-1.3.1-1  pambase-20190105.1-1
               pciutils-3.6.2-1  pcre-8.43-1  pcre2-10.33-1  perl-5.30.0-3  pinentry-1.1.0-4
               popt-1.16-10  procps-ng-3.3.15-1  psmisc-23.2-1  raspberrypi-bootloader-20190702-1
               raspberrypi-bootloader-x-20190702-1  raspberrypi-firmware-20190626-1
               readline-8.0.0-1  reiserfsprogs-3.6.27-2  s-nail-14.9.13-2  sed-4.7-1  shadow-4.6-3
               sqlite-3.28.0-1  sysfsutils-2.1.0-10  systemd-242.32-1  systemd-libs-242.32-1
               systemd-sysvcompat-242.32-1  tar-1.32-1  texinfo-6.6-1
               thin-provisioning-tools-0.8.5-2  tzdata-2019b-1  usbutils-010-1  util-linux-2.34-3
               vi-1:070224-3  which-2.21-3  wireless-regdb-2019.03.01-1  wireless_tools-30.pre9-2
               wpa_supplicant-2:2.8-1  xfsprogs-4.20.0-2  xz-5.2.4-1  zlib-1:1.2.11-3  zstd-1.4.0-1

Total Installed Size:  1006.28 MiB
Net Upgrade Size:       385.94 MiB

:: Proceed with installation? [Y/n] y
(156/156) checking keys in keyring                           [################################] 100%
(156/156) checking package integrity                         [################################] 100%
(156/156) loading package files                              [################################] 100%
(156/156) checking for file conflicts                        [################################] 100%
error: failed to commit transaction (conflicting files)
ca-certificates-utils: /etc/ssl/certs/ca-certificates.crt exists in filesystem
Errors occurred, no packages were upgraded.

Ostatnio edytowany przez pasta20 (2019-07-04 15:03:37)

Offline

#4 2019-07-04 17:11:18

robson75
Użytkownik
Lokalizacja: Szczecin
Data rejestracji: 2018-10-15
Liczba postów: 61

Odp: [ROZW.] rpi2 arch linux ca-certificates-utils-20181109-1

Nie wiem po Ci potrzebne te "repa"

[alarm]
Include = /etc/pacman.d/mirrorlist

[aur]
Include = /etc/pacman.d/mirrorlist

Ja bym je usunął z pacman.conf, albo przynajmniej za#ował.


Arch Linux Xfce+compiz - 64Bit Linux User #621110

Offline

#5 2019-07-04 18:04:48

pasta20
Użytkownik
Data rejestracji: 2019-07-03
Liczba postów: 11

Odp: [ROZW.] rpi2 arch linux ca-certificates-utils-20181109-1

Ok udało się jakoś ożywić :) kilka razy aktualizacja bazy później plików pomogła. Eh następny problem to nie wiem jak ruszyć aby zainstalować apkę ;/ Czy można prosić jakąś podpowiedz co i jak powoli robić.

Offline

#6 2019-07-05 05:34:15

pavbaranov
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-22
Liczba postów: 1,923
WWW

Odp: [ROZW.] rpi2 arch linux ca-certificates-utils-20181109-1

Załóż wątek i opisz o co chodzi, bowiem "nie wiem jak zainstalować apkę" znaczy tyle co nic.

PS: Masz starą listę mirrorów - pobierz nowe, o jeden mniej problem z aktualizacją będzie.
W przypadku tego typu błędów:

error: failed to commit transaction (conflicting files)
ca-certificates-utils: /etc/ssl/certs/ca-certificates.crt exists in filesystem

sygnalizuje Ci to, że jakaś paczka, która ma być zainstalowana dostarcza jakiś plik (tu ca-certificates.crt), który jest już w systemie. W takich przypadkach niekiedy są informacje na stronach dystrybucji co należy robić, a typowa reakcja rozpoczyna się od sprawdzenia jaka paczka dostarczyła konfliktujący plik. Zerknij sobie np. na mój blog.
Jeśli chodzi o paczki pochodzące z repozytoriów, które krzyczą w ten sposób:

error: ca-certificates-utils: signature from "Arch Linux ARM Build System <[email protected]xarm.org>" is unknown trust

istnieje również możliwość, że masz w systemie stary, albo w ogóle nie masz (a to oznacza wadliwą instalację) plik, który w nazwie ma keyrings, w przypadku Archa jest to archlinux-keyrings. Jak ten plik nazywa się w ArchlinuxARM - nie wiem - sam musisz znaleźć.

PS2: Za diabła nie wiem w jaki sposób opisane przez Ciebie błędy udało się naprawić jedynie poprzez "kilkakrotną aktualizację bazy i instalację paczek", albowiem... przy opisanych błędach to się po prostu udać nie może :)


Hardware: AMD: A8-7410 APU with Radeon R5; Arch testing+kde-unstable, kernel linux-pb 5.2, KDE+poprawki
https://deviantart.com/pavbaranov/ https://pavbaranov.blogspot.com https://linux-pavbaranov.blogspot.com

Offline

Stopka

Forum oparte na FluxBB