Nie jesteś zalogowany na forum.

#1 2019-06-24 08:33:28

dudik24
Użytkownik
Data rejestracji: 2015-12-07
Liczba postów: 64

Opóźniony start XFCE [SOLVED]

Podczas startu systemu sytuacja wygląda tak  : startuje grub, uruchamia się arch, pokazują się kolejne uruchamiane usługi po czym ekran jest czarny przez
około 40 sekund, i wreszcie startuje XFCE.
Na starym komputerze XFCE startowało natychmiast więc wnioskuję że jest gdzieś parametr opisuəacy to opóźnienie, ale w sieci nic nie znalazłem na ten temat.
Gdzie trzeba pogrzebać?

Ostatnio edytowany przez dudik24 (2019-06-25 14:42:02)

Offline

#2 2019-06-24 11:20:08

pavbaranov
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-22
Liczba postów: 2,056
WWW

Odp: Opóźniony start XFCE [SOLVED]

W pierwszej kolejności sprawdź sobie:

systemd-analyze blame

Hardware: AMD: A8-7410 APU with Radeon R5; Arch testing+kde-unstable, kernel linux-pb, KDE+poprawki, kf5.65rc; kernel własny zawsze z najnowszej linii
https://deviantart.com/pavbaranov/ https://pavbaranov.blogspot.com https://linux-pavbaranov.blogspot.com

Offline

#3 2019-06-24 11:33:39

robson75
Użytkownik
Lokalizacja: Szczecin
Data rejestracji: 2018-10-15
Liczba postów: 91

Odp: Opóźniony start XFCE [SOLVED]

Jest czarny ekran, bo trzeba wejść w sesja i uruchamianie, przejść do zakładki ekran powitalny i zaznaczyć coś żeby było widoczne podczas startu Xfce. https://i.postimg.cc/j2G2qtNK/Przechwyc … -28-07.png


Arch Linux Xfce+compiz - 64Bit Linux User #621110
https://www.anarchylinux.org/

Offline

#4 2019-06-24 11:48:50

dudik24
Użytkownik
Data rejestracji: 2015-12-07
Liczba postów: 64

Odp: Opóźniony start XFCE [SOLVED]

<pre>systemd-analyze blame
           699ms lvm2-monitor.service
           686ms dev-sda3.device
           596ms udisks2.service
           579ms lightdm.service
           474ms systemd-logind.service
           433ms systemd-journal-flush.service
           319ms systemd-udevd.service
           288ms systemd-journald.service
           283ms downloads.mount
           224ms mnt-sda02.mount
           205ms ldconfig.service
           144ms accounts-daemon.service
           123ms upower.service
           111ms polkit.service
           107ms [email protected]
            85ms systemd-sysusers.service
            85ms NetworkManager.service
            81ms systemd-udev-trigger.service
            37ms systemd-binfmt.service
            35ms systemd-tmpfiles-setup.service
            25ms systemd-tmpfiles-setup-dev.service
            20ms systemd-journal-catalog-update.service
            15ms dev-mqueue.mount
            15ms sys-kernel-debug.mount
            14ms dev-hugepages.mount
            14ms [email protected]
            14ms kmod-static-nodes.service
            13ms systemd-update-utmp.service
            13ms systemd-update-done.service
            13ms systemd-random-seed.service
            13ms proc-sys-fs-binfmt_misc.mount
            12ms systemd-remount-fs.service
            10ms systemd-sysctl.service
             8ms systemd-user-sessions.service
             7ms rtkit-daemon.service
             7ms systemd-modules-load.service
             7ms tmp.mount
             6ms sys-fs-fuse-connections.mount
             3ms sys-kernel-config.mount
</pre>

Offline

#5 2019-06-24 11:50:29

dudik24
Użytkownik
Data rejestracji: 2015-12-07
Liczba postów: 64

Odp: Opóźniony start XFCE [SOLVED]

robson75 napisał/a:

Jest czarny ekran, bo trzeba wejść w sesja i uruchamianie, przejść do zakładki ekran powitalny i zaznaczyć coś żeby było widoczne podczas startu Xfce. https://i.postimg.cc/j2G2qtNK/Przechwyc … -28-07.png

Tak mam to ustawione. Obrazek startuje po 40 sek.

Offline

#6 2019-06-24 12:00:15

robson75
Użytkownik
Lokalizacja: Szczecin
Data rejestracji: 2018-10-15
Liczba postów: 91

Odp: Opóźniony start XFCE [SOLVED]

W takim razie przeładuj ustawienia Xfce

xfsettingsd --replace

jako zwykły użytkownik.


Arch Linux Xfce+compiz - 64Bit Linux User #621110
https://www.anarchylinux.org/

Offline

#7 2019-06-24 12:10:36

robson75
Użytkownik
Lokalizacja: Szczecin
Data rejestracji: 2018-10-15
Liczba postów: 91

Odp: Opóźniony start XFCE [SOLVED]

U mnie są uruchamiane te oto usługi

          5.539s lvm2-monitor.service
          4.753s ModemManager.service
          4.480s dev-sda2.device
          2.445s polkit.service
          2.136s NetworkManager.service
          1.440s iptables.service
          1.440s cpupower.service
          1.409s systemd-logind.service
          1.392s lightdm.service
          1.077s upower.service
          1.057s [email protected]\x2duuid-EF55\x2d7A40.service
          1.036s systemd-modules-load.service
           878ms systemd-tmpfiles-setup-dev.service
           734ms udisks2.service
           633ms systemd-udevd.service
           515ms systemd-journal-flush.service
           511ms systemd-journald.service
           450ms accounts-daemon.service
           328ms systemd-timesyncd.service
           313ms [email protected]
           278ms systemd-tmpfiles-setup.service
           260ms systemd-udev-trigger.service
           244ms rtkit-daemon.service
           243ms dev-disk-by\x2duuid-5f7590ee\x2d64b9\x2d4ed0\x2d802f\x2d08a3fb>
           228ms systemd-random-seed.service
           218ms boot.mount
           208ms kmod-static-nodes.service
           132ms systemd-update-utmp.service
            98ms haveged.service
            87ms systemd-tmpfiles-clean.service
            78ms systemd-binfmt.service
            72ms systemd-user-sessions.service
            71ms systemd-sysctl.service
            63ms systemd-remount-fs.service
            45ms dev-hugepages.mount
            26ms alsa-restore.service
            23ms sys-kernel-debug.mount
            20ms [email protected]
            19ms dev-mqueue.mount
            19ms proc-sys-fs-binfmt_misc.mount
            12ms tmp.mount
             6ms sys-kernel-config.mount
             4ms sys-fs-fuse-connections.mount

A system startuje

Startup finished in 4.416s (kernel) + 14.457s (userspace) = 18.874s 
graphical.target reached after 14.456s in userspace

Ostatnio edytowany przez robson75 (2019-06-24 12:24:35)


Arch Linux Xfce+compiz - 64Bit Linux User #621110
https://www.anarchylinux.org/

Offline

#8 2019-06-24 12:35:30

dudik24
Użytkownik
Data rejestracji: 2015-12-07
Liczba postów: 64

Odp: Opóźniony start XFCE [SOLVED]

robson75 napisał/a:

W takim razie przeładuj ustawienia Xfce

xfsettingsd --replace

jako zwykły użytkownik.


Bez zmian

Offline

#9 2019-06-24 12:46:36

robson75
Użytkownik
Lokalizacja: Szczecin
Data rejestracji: 2018-10-15
Liczba postów: 91

Odp: Opóźniony start XFCE [SOLVED]

A wpisz w terminalu

reboot

Przypomniało mi się że gdy wywołam okno zakończ sesje, to u mnie Xfce też długo się uruchamia. Dlatego gdy chcę system zrestartować to wpisuje reboot, a gdy chcę go wyłączyć to na klawiaturze wciskam klawisz power.
Proponuje ustawić tak jak na screenie
https://i.postimg.cc/FKTnsfMQ/Przechwyc … -51-15.png

Ostatnio edytowany przez robson75 (2019-06-24 12:56:05)


Arch Linux Xfce+compiz - 64Bit Linux User #621110
https://www.anarchylinux.org/

Offline

#10 2019-06-24 13:15:25

dudik24
Użytkownik
Data rejestracji: 2015-12-07
Liczba postów: 64

Odp: Opóźniony start XFCE [SOLVED]

robson75 napisał/a:

A wpisz w terminalu

reboot

Przypomniało mi się że gdy wywołam okno zakończ sesje, to u mnie Xfce też długo się uruchamia. Dlatego gdy chcę system zrestartować to wpisuje reboot, a gdy chcę go wyłączyć to na klawiaturze wciskam klawisz power.
Proponuje ustawić tak jak na screenie
https://i.postimg.cc/FKTnsfMQ/Przechwyc … -51-15.png

Niestety, bez zmian

Offline

#11 2019-06-24 13:27:04

robson75
Użytkownik
Lokalizacja: Szczecin
Data rejestracji: 2018-10-15
Liczba postów: 91

Odp: Opóźniony start XFCE [SOLVED]

Ostatnia rzecz jaka mi przychodzi do głowy, wejdź do Thunar-a otwórz ukryte pliki i usuń katalog .cache, następnie w terminalu

reboot

Arch Linux Xfce+compiz - 64Bit Linux User #621110
https://www.anarchylinux.org/

Offline

#12 2019-06-24 13:41:56

dudik24
Użytkownik
Data rejestracji: 2015-12-07
Liczba postów: 64

Odp: Opóźniony start XFCE [SOLVED]

robson75 napisał/a:

Ostatnia rzecz jaka mi przychodzi do głowy, wejdź do Thunar-a otwórz ukryte pliki i usuń katalog .cache, następnie w terminalu

reboot

Również bez zmian

Offline

#13 2019-06-24 13:50:42

robson75
Użytkownik
Lokalizacja: Szczecin
Data rejestracji: 2018-10-15
Liczba postów: 91

Odp: Opóźniony start XFCE [SOLVED]

A powiedz mi czy masz jakieś dodatkowe usługi uruchamiane podczas startu systemu?
https://i.postimg.cc/fyqH8PhF/Przechwyc … -45-32.png
Czy tylko te podstawowe.
https://i.postimg.cc/dVsfJG54/Przechwyc … -52-32.png
Jeszcze podaj wynik

journalctl -b

Ostatnio edytowany przez robson75 (2019-06-24 14:57:50)


Arch Linux Xfce+compiz - 64Bit Linux User #621110
https://www.anarchylinux.org/

Offline

#14 2019-06-24 14:16:31

dudik24
Użytkownik
Data rejestracji: 2015-12-07
Liczba postów: 64

Odp: Opóźniony start XFCE [SOLVED]

Standardowe + virtualbox

Offline

#15 2019-06-24 14:26:33

dudik24
Użytkownik
Data rejestracji: 2015-12-07
Liczba postów: 64

Odp: Opóźniony start XFCE [SOLVED]

journalctl -b
Hint: You are currently not seeing messages from other users and the system.
      Users in groups 'adm', 'systemd-journal', 'wheel' can see all messages.
      Pass -q to turn off this notice.
-- Logs begin at Tue 2019-06-18 23:52:01 CEST, end at Mon 2019-06-24 17:23:32 CEST. --
cze 24 17:23:24 tat systemd[591]: Listening on GnuPG cryptographic agent and passphrase cache.
cze 24 17:23:24 tat systemd[591]: Listening on p11-kit server.
cze 24 17:23:24 tat systemd[591]: Listening on Sound System.
cze 24 17:23:24 tat systemd[591]: Listening on Multimedia System.
cze 24 17:23:24 tat systemd[591]: Listening on GnuPG network certificate management daemon.
cze 24 17:23:24 tat systemd[591]: Reached target Timers.
cze 24 17:23:24 tat systemd[591]: Listening on GnuPG cryptographic agent and passphrase cache (restricted).
cze 24 17:23:24 tat systemd[591]: Starting D-Bus User Message Bus Socket.
cze 24 17:23:24 tat systemd[591]: Listening on GnuPG cryptographic agent (ssh-agent emulation).
cze 24 17:23:24 tat systemd[591]: Reached target Paths.
cze 24 17:23:24 tat systemd[591]: Listening on GnuPG cryptographic agent and passphrase cache (access for web browsers).
cze 24 17:23:24 tat systemd[591]: Listening on D-Bus User Message Bus Socket.
cze 24 17:23:24 tat systemd[591]: Reached target Sockets.
cze 24 17:23:24 tat systemd[591]: Reached target Basic System.
cze 24 17:23:24 tat systemd[591]: Reached target Main User Target.
cze 24 17:23:24 tat systemd[591]: Startup finished in 84ms.
cze 24 17:23:25 tat systemd[591]: Started D-Bus User Message Bus.
cze 24 17:23:25 tat dbus-daemon[608]: [session uid=1000 pid=608] Activating service name='org.xfce.Xfconf' requested by ':1.3' (uid=1000 pid>
cze 24 17:23:25 tat dbus-daemon[608]: [session uid=1000 pid=608] Successfully activated service 'org.xfce.Xfconf'
cze 24 17:23:25 tat systemd[591]: Started GnuPG cryptographic agent and passphrase cache.
cze 24 17:23:25 tat gpg-agent[624]: gpg-agent (GnuPG) 2.2.16 starting in supervised mode.
cze 24 17:23:25 tat gpg-agent[624]: using fd 3 for extra socket (/run/user/1000/gnupg/S.gpg-agent.extra)
cze 24 17:23:25 tat gpg-agent[624]: using fd 4 for browser socket (/run/user/1000/gnupg/S.gpg-agent.browser)
cze 24 17:23:25 tat gpg-agent[624]: using fd 5 for ssh socket (/run/user/1000/gnupg/S.gpg-agent.ssh)
cze 24 17:23:25 tat gpg-agent[624]: using fd 6 for std socket (/run/user/1000/gnupg/S.gpg-agent)
cze 24 17:23:25 tat gpg-agent[624]: listening on: std=6 extra=3 browser=4 ssh=5
cze 24 17:23:25 tat systemd[591]: Starting Sound Service...
cze 24 17:23:26 tat systemd[591]: Started Sound Service.
cze 24 17:23:26 tat dbus-daemon[608]: [session uid=1000 pid=608] Activating via systemd: service name='org.gtk.vfs.Daemon' unit='gvfs-daemon>
cze 24 17:23:26 tat systemd[591]: Starting Virtual filesystem service...
cze 24 17:23:26 tat dbus-daemon[608]: [session uid=1000 pid=608] Successfully activated service 'org.gtk.vfs.Daemon'
cze 24 17:23:26 tat systemd[591]: Started Virtual filesystem service.
cze 24 17:23:26 tat dbus-daemon[608]: [session uid=1000 pid=608] Activating via systemd: service name='org.a11y.Bus' unit='at-spi-dbus-bus.s>
cze 24 17:23:26 tat systemd[591]: Starting Accessibility services bus...
cze 24 17:23:26 tat dbus-daemon[608]: [session uid=1000 pid=608] Successfully activated service 'org.a11y.Bus'
cze 24 17:23:26 tat systemd[591]: Started Accessibility services bus.
cze 24 17:23:26 tat at-spi-bus-launcher[670]: dbus-daemon[676]: Activating service name='org.a11y.atspi.Registry' requested by ':1.0' (uid=1>
cze 24 17:23:26 tat at-spi-bus-launcher[670]: dbus-daemon[676]: Successfully activated service 'org.a11y.atspi.Registry'
cze 24 17:23:26 tat at-spi-bus-launcher[670]: SpiRegistry daemon is running with well-known name - org.a11y.atspi.Registry
cze 24 17:23:26 tat dbus-daemon[608]: [session uid=1000 pid=608] Activating service name='org.freedesktop.thumbnails.Thumbnailer1' requested>
cze 24 17:23:26 tat tumblerd[689]: Failed to load plugin "tumbler-raw-thumbnailer.so": libopenrawgnome.so.7: cannot open shared object file:>
cze 24 17:23:26 tat tumblerd[689]: Failed to load plugin "tumbler-poppler-thumbnailer.so": libpoppler-glib.so.8: cannot open shared object f>
cze 24 17:23:26 tat tumblerd[689]: Failed to load plugin "tumbler-odf-thumbnailer.so": libgsf-1.so.114: cannot open shared object file: No s>
cze 24 17:23:26 tat tumblerd[689]: Failed to load plugin "tumbler-ffmpeg-thumbnailer.so": libffmpegthumbnailer.so.4: cannot open shared obje>
lines 1-45

Offline

#16 2019-06-24 14:36:23

robson75
Użytkownik
Lokalizacja: Szczecin
Data rejestracji: 2018-10-15
Liczba postów: 91

Odp: Opóźniony start XFCE [SOLVED]

W takim razie proponuje doinstalować następujące paczki
accountsservice
ffmpegthumbnailer
libopenraw
poppler-glib
libgsf

Ostatnio edytowany przez robson75 (2019-06-24 14:51:12)


Arch Linux Xfce+compiz - 64Bit Linux User #621110
https://www.anarchylinux.org/

Offline

#17 2019-06-24 15:11:20

dudik24
Użytkownik
Data rejestracji: 2015-12-07
Liczba postów: 64

Odp: Opóźniony start XFCE [SOLVED]

robson75 napisał/a:

W takim razie proponuje doinstalować następujące paczki
accountsservice
ffmpegthumbnailer
libopenraw
poppler-glib
libgsf


Doinstalowałem.  Błędy zniknęły. Końcówka po journalctl -b wygląda teraz tak

cze 24 18:04:21 tat at-spi-bus-launcher[634]: SpiRegistry daemon is running with well-known name - org.a11y.atspi.Registry
cze 24 18:04:21 tat dbus-daemon[573]: [session uid=1000 pid=573] Activating service name='org.freedesktop.thumbnails.Thumbnailer1' requested by ':1.21' (uid=1000 pid=643 comm="xfd>
cze 24 18:04:22 tat dbus-daemon[573]: [session uid=1000 pid=573] Activating via systemd: service name='org.freedesktop.Notifications' unit='xfce4-notifyd.service' requested by ':1>
cze 24 18:04:22 tat systemd[548]: Starting XFCE notifications service...
cze 24 18:04:22 tat dbus-daemon[573]: [session uid=1000 pid=573] Successfully activated service 'org.freedesktop.Notifications'
cze 24 18:04:22 tat systemd[548]: Started XFCE notifications service.
lines 1-45

Ale niestety start jak trwał tak trwa zbyt długo.

Offline

#18 2019-06-24 15:35:30

robson75
Użytkownik
Lokalizacja: Szczecin
Data rejestracji: 2018-10-15
Liczba postów: 91

Odp: Opóźniony start XFCE [SOLVED]

Zauważyłem również że masz źle ustawiony czas, aktywuj tą usługę

systemctl enable systemd-timesyncd.service
systemctl start systemd-timesyncd.service

Arch Linux Xfce+compiz - 64Bit Linux User #621110
https://www.anarchylinux.org/

Offline

#19 2019-06-24 16:59:35

robson75
Użytkownik
Lokalizacja: Szczecin
Data rejestracji: 2018-10-15
Liczba postów: 91

Odp: Opóźniony start XFCE [SOLVED]

Nie wiem czy to coś da, ale warto spróbować, na pewno masz zainstalowaną paczkę llvm-libs, to proponuje doinstalować jeszcze samo llvm, które to zresztą jest opcjonalną zależnością llvm-libs.

EDIT
Zauważyłem u siebie dwa wpisy w systemd-analyze blame a których u Ciebie brak

1.057s [email protected]\x2duuid-EF55\x2d7A40.service
243ms dev-disk-by\x2duuid-5f7590ee\x2d64b9\x2d4ed0\x2d802f\x2d08a3fb>

Może warto pójść tym tropem.

Ostatnio edytowany przez robson75 (2019-06-24 17:17:25)


Arch Linux Xfce+compiz - 64Bit Linux User #621110
https://www.anarchylinux.org/

Offline

#20 2019-06-24 23:01:22

pavbaranov
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-22
Liczba postów: 2,056
WWW

Odp: Opóźniony start XFCE [SOLVED]

To jeszcze poproszę:

systemd-analyze

oraz

systemd-analyze critical-chain

lub

systemd-analyze plot > critical.svg

i gdzieś wrzucić obrazek.


Hardware: AMD: A8-7410 APU with Radeon R5; Arch testing+kde-unstable, kernel linux-pb, KDE+poprawki, kf5.65rc; kernel własny zawsze z najnowszej linii
https://deviantart.com/pavbaranov/ https://pavbaranov.blogspot.com https://linux-pavbaranov.blogspot.com

Offline

#21 2019-06-25 13:29:17

dudik24
Użytkownik
Data rejestracji: 2015-12-07
Liczba postów: 64

Odp: Opóźniony start XFCE [SOLVED]

$ systemd-analyze
Startup finished in 2.969s (kernel) + 2.558s (userspace) = 5.528s
graphical.target reached after 2.557s in userspace

systemd-analyze critical-chain
The time when unit became active or started is printed after the "@" character.
The time the unit took to start is printed after the "+" character.

graphical.target @2.557s
└─lightdm.service @1.791s +763ms
  └─systemd-user-sessions.service @1.782s +7ms
    └─nss-user-lookup.target @2.339s

systemd-analyze plot > critical.svg
i gdzieś wrzucić obrazek.

https://www.easypaste.org/file/gVZznTkD … vg?lang=pl

Nie wiedziałem gdzie to wrzucić. Tam chcą opłat za ściąganie, ale tylko z dużą szybkością.

Offline

#22 2019-06-25 14:11:02

robson75
Użytkownik
Lokalizacja: Szczecin
Data rejestracji: 2018-10-15
Liczba postów: 91

Odp: Opóźniony start XFCE [SOLVED]

Proponuje ten hosting zdjęć https://postimages.org/, skopiować bezpośredni odnośnik i wkleić na forum jako url.


Arch Linux Xfce+compiz - 64Bit Linux User #621110
https://www.anarchylinux.org/

Offline

#23 2019-06-25 14:41:33

dudik24
Użytkownik
Data rejestracji: 2015-12-07
Liczba postów: 64

Odp: Opóźniony start XFCE [SOLVED]

Zauważyłem, że jak wyłączyłem autozapis sesji przy wylogowaniu to po kilku restartach sytuacja się naprawiła.
Nie było żadnych działań z mojej strony i nie wiem co zadziałało. Tak więc problem uważam za rozwiązany, chociaż nie wiem dlaczego.
Dla potomności chyba nic ciekawego z tego wątku nie będzie

Offline

#24 2019-06-25 14:49:54

pavbaranov
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-22
Liczba postów: 2,056
WWW

Odp: Opóźniony start XFCE [SOLVED]

Ok. Wszystko wygląda na to, że... jest ok. System startuje Ci bardzo szybko, włącznie z podnoszeniem XFCE. Obecnie nie ma problemów z... Z niczym. Kwestia owych 40 sek, to najprawdopodobniej "przywracanie sesji", które trwa niezależnie od środowiska, zresztą sam to zauważyłeś. Po prostu coś - za coś. Rozumiem, że kwestia wyrugowania autozapisu pomogła i temat - jak oznaczyłeś - jest rozwiązany. Zamykam. Jeśli jednak to nie jest to, to poproszę o PW i wówczas otworzę.


Hardware: AMD: A8-7410 APU with Radeon R5; Arch testing+kde-unstable, kernel linux-pb, KDE+poprawki, kf5.65rc; kernel własny zawsze z najnowszej linii
https://deviantart.com/pavbaranov/ https://pavbaranov.blogspot.com https://linux-pavbaranov.blogspot.com

Offline

Stopka

Forum oparte na FluxBB