Nie jesteś zalogowany na forum.

#26 2019-05-18 14:21:54

marcin82
Moderator
Lokalizacja: Sosnowiec
Data rejestracji: 2015-08-20
Liczba postów: 175

Odp: Problem z hasłem root-a - Rozwiązany

Dobra, sprawdziłem. Instalator pyta o hasło roota, ale kijowo ustawia powłokę logowania użytkownika root i stąd całe zamieszanie. Być może przez to sudo też nie działa jak powinno, stąd brak respektowania zmian / edycji plików powyżej /home, w tym /etc/default/grub, itd.

Emulator terminala chciał uruchomić wobec tego katalog /usr/bin zamiast prawidłowo wskazanej powłoki logowania (w bash zmienna $SHELL).

Nie cierpię tego, nie chcem, ale muszem :D Normalnie do tego służy polecenie chsh, ale tak będzie prościej dla ciebie:

sudo nano /etc/passwd

Zmieniasz w linii użytkownika root - pierwsza linia:

root:x:0:0::/root:/usr/bin -> root:x:0:0::/root:/bin/bash

Zapisujesz zmiany i działa.

Jeśli to nie problem to zgloś autorowi tego instalatora na czym polega problem.

Druga sprawa ... wynajdujecie jakieś dziwne magiczne ułatwiacze i tak to się kończy. Postawiłbyś raz metodą polecaną i masz spokój - bez dziwnych błędów i dodatkowych repozytoriów, metapakietów i właśnie - przypuszczalnie - jakich jeszcze niespodzianek w plikach konfiguracyjnych?


marcin82

Offline

#27 2019-05-18 15:07:02

Kx_liner
Użytkownik
Lokalizacja: Pod lasem
Data rejestracji: 2015-10-25
Liczba postów: 201
WWW

Odp: Problem z hasłem root-a - Rozwiązany

pavbaranov napisał/a:

Od słów "Tutaj występuje..." treść Twojego wpisu jest kompletnie nieczytelna.
1. Co chcesz wykonać?
2. Co to ma wspólnego z brakiem możliwości zalogowania się na koncie roota przez polecenie su? Jeśli nic, bo su dizała obecnie prawidłowo, oznacz wątek jako rozwiązany i załóż nowy, odpowiadający Twojemu problemowi, który staraj się jak najdokładniej opisać. Nikt z nas nie ma prawa poświęcać Ci uwagi tylko i wyłącznie dlatego, że podasz część informacji i po kilka godzin osoby, które chcą Ci pomóc zastanawiają się o co chodzi.

Podałem wszystko wyczerpująco. Wystarczy kliknąć link i zobaczyć fragment zrzutu mojego ekranu, a potem zapoznać się z Ubunto-podobnymi. W Ubuntu nie ma roota, tylko sudo (jeśli dobrze pamiętam)
Po reinstalacji systemu i dodaniu hasła roota innego niż moje hasło, problem nadal występuje.

Nie podawałem części informacji, tylko pełną informację.

pavbaranov napisał/a:

Nikt z nas nie ma prawa poświęcać Ci uwagi tylko i wyłącznie dlatego, że podasz część informacji i po kilka godzin osoby, które chcą Ci pomóc zastanawiają się o co chodzi.

Przepraszam. Kto ustanowił takie prawo Panie Mecenasie?


Używam Linux Xfce+compiz  + Lenovo ThinkPad T520 Intel Core i5

Offline

#28 2019-05-18 15:15:14

pavbaranov
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-22
Liczba postów: 1,869
WWW

Odp: Problem z hasłem root-a - Rozwiązany

Nie będę wchodził w polemikę, ale to prawo ustanowiły lata używania forów/usenetu.


Hardware: AMD: A8-7410 APU with Radeon R5
software (podaję wyłącznie odrębności): Arch testing+kde-unstable, kernel linux-pb (5.1.10 m.in. AMD Jaguar, BMQ, UKSM), amdgpu (dla CIK), KDE

Offline

Stopka

Forum oparte na FluxBB