Nie jesteś zalogowany na forum.

#1 2019-02-03 12:53:46

robson75
Użytkownik
Lokalizacja: Szczecin
Data rejestracji: 2018-10-15
Liczba postów: 28

Wadliwa instalacja paczki 4k-ffmpeg z 4kvideodownloader-ffmpeg z POLAU

Paweł jeszcze raz wielkie dzięki za stworzenie PKGBUILD-u 4Kvideodownloader-a, ale jest jedno ale. Podczas budowy i instalacji wyskakuje taki oto błąd.

[[email protected]:aur-rebased-master/4kvideodownloader-ffmpeg]$ makepkg -si
==> Tworzenie pakietu: 4kvideodownloader-ffmpeg 4.5.0.2482-1 (nie, 3 lut 2019, 12:43:58)
==> Sprawdzanie zależności potrzebnych do uruchomienia...
==> Sprawdzanie zależności potrzebnych do budowy...
==> Pobieranie źródeł...
  -> Pobieranie 4kvideodownloader_4.5.0.2482_amd64.tar.bz2...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 25.7M  100 25.7M    0     0  4294k      0  0:00:06  0:00:06 --:--:-- 4899k
  -> Znaleziono 4kvideodownloader.desktop
  -> Znaleziono 4kvideodownloader.png
==> Sprawdzanie plików source za pomocą sha256sums...
    4kvideodownloader_4.5.0.2482_amd64.tar.bz2 ... Zgadza się
    4kvideodownloader.desktop ... Zgadza się
    4kvideodownloader.png ... Zgadza się
==> Rozpakowywanie źródeł...
  -> Rozpakowywanie 4kvideodownloader_4.5.0.2482_amd64.tar.bz2 za pomocą bsdtar
==> Rozpoczynanie prepare()...
==> Wchodzenie do środowiska fakeroot...
==> Rozpoczynanie package_4kvideodownloader()...
==> Sprzątanie instalacji...
  -> Usuwanie libtool plików...
  -> Usuwanie niechcianych plików...
  -> Usuwanie statycznych plików bibliotek
  -> Wyrzucanie niepotrzebnych symboli z plików binarnych i bibliotek
  -> Kompresowanie stron man oraz info...
==> Sprawdzanie problemów z pakietami...
==> Tworzenie pakietu "4kvideodownloader"...
  -> Generowanie pliku .PKGINFO...
  -> Generowanie pliku .BUILDINFO...
  -> Generowanie pliku .MTREE...
  -> Kompresowanie pakietu...
==> Rozpoczynanie package_4k-ffmpeg()...
==> Sprzątanie instalacji...
  -> Usuwanie libtool plików...
  -> Usuwanie niechcianych plików...
  -> Usuwanie statycznych plików bibliotek
  -> Wyrzucanie niepotrzebnych symboli z plików binarnych i bibliotek
  -> Kompresowanie stron man oraz info...
==> Sprawdzanie problemów z pakietami...
==> Tworzenie pakietu "4k-ffmpeg"...
  -> Generowanie pliku .PKGINFO...
  -> Generowanie pliku .BUILDINFO...
  -> Generowanie pliku .MTREE...
  -> Kompresowanie pakietu...
==> Opuszczanie środowiska fakeroot.
==> Ukończono tworzenie: 4kvideodownloader-ffmpeg 4.5.0.2482-1 (nie, 3 lut 2019, 12:44:22)
==> Instalowanie grupy pakietów 4kvideodownloader-ffmpeg za pomocą pacman -U...
[sudo] hasło użytkownika robson: 
wczytywanie pakietów…
błąd:  '/home/robson/Pobrane/aur-rebased-master/4kvideodownloader-ffmpeg/4k-ffmpeg-4.5.0.2482-1-x86_64.pkg.tar.xz': nie udało się znaleźć bądź odczytać pakietu
==> OSTRZEŻENIE: Nie udało się zainstalować zbudowanych pakietu(ów).

Paczki jak najbardziej się budują prawidłowo, tylko jest problem z instalacją.
Ja np. zainstalowałem te paczki przez

pacman -U

W sumie dla mnie to nie jest żaden problem, ale jak przykładowo taki newbie zacznie budować z tego PKGBUILD-u...

Ostatnio edytowany przez robson75 (2019-02-03 15:38:35)


Arch Linux Xfce+compiz - 64Bit Linux User #621110
PC: HP Compaq 6200 Pro MT / CPU: Intel Core 4x i3-2100 CPU @ 3.10GHz / GPU: Intel HD Graphics 2000 / RAM: 8 GB / Dysk: HDD 1 TB

Offline

#2 2019-02-03 19:08:59

pavbaranov
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-22
Liczba postów: 1,862
WWW

Odp: Wadliwa instalacja paczki 4k-ffmpeg z 4kvideodownloader-ffmpeg z POLAU

Thx - wiem, o co chodzi. Poprawię w wolnej chwili. Niestety jestem lekko "zalatany" ostatnio.

Ogólne info. Paczka tworzy dwa pliki o innej wersji (pkgver), a polecenie makepkg -i próbuje zainstalować obie paczki w tej samej wersji. Tymczasowo proponuję instalację przez:

sudo pacman -U *.pkg.tar

(chyba, że ktoś ma kompresję paczek włączoną, wówczas musi to polecenie dostosować do formatu plików, jakie tworzy makepkg)


Hardware: AMD: A8-7410 APU with Radeon R5
software (podaję wyłącznie odrębności): Arch testing+kde-unstable, kernel linux-pb (5.1.10 m.in. AMD Jaguar, BMQ, UKSM), amdgpu (dla CIK), KDE

Offline

Stopka

Forum oparte na FluxBB