Nie jesteś zalogowany na forum.

#1 2018-12-18 22:28:08

Martina Neumayer
Użytkownik
Lokalizacja: München
Data rejestracji: 2018-11-20
Liczba postów: 9

[solved] Update kernela powyżej 4.18.16 = całkowity brak sieci

Siemanko..
No to teraz moja kolej z moim problemem..

Sprawa taka..
Gdy zrobię update kernela do czegokolwiek powyżej wersji 4.18.16, to  w momencie restartu maszyny, wywala mi całkowicie sieć.
Nie działa nic kompletnie w temacie "networking". Ani lan, ani wifi, ani żadne połączenia lte, vpn i cała reszta. Po prostu sieć leży i kwiczy.

W logach nie ma niczego, co mogłoby jakoś mnie naprowadzić na pomysł co powoduje ów problem i jak go naprawić.
A przynajmniej ja tego jakoś nie widzę.
Po przywróceniu kernela do wersji 4.18.16 z paczek lokalnych i restarcie, wszystko wraca do normy i sieć działa bez problemów.
Próbowałam już zmian apek do zarządzania siecią.. np. wicd i inne, ale też niczego to nie dało, więc wróciłam do NetworkManager'a.

Zrzut z dmesg:
https://pastebin.com/raw/twXVTrBL

Dane systemu i maszyny:
https://pastebin.com/raw/PWa3apun

Jeśli mam zapodać coś jeszcze, to mi napiszcie, a wrzucę.

Dzięki za wszelkie wskazówki.
Mati.

Ps. inxi jedną rzecz podaje nieco błędnie.. mianowicie ja nie mam mate jako DE, a jedynie używam filemanagera Caja, więc dlatego tak wyświetla.
U mnie za DE robi Compiz w trybie stand-alone. Ale to chyba raczej nie ma nic do istoty sprawy?

Edit:
Ooookay.. problem rozwiązałam.. dzięki chłopakom na naszym irc'owym kanale naszło mnie kilka pomysłów, z których parę dało dobre efekty.

Kwestia taka.. co się okazało.. mądrale devowe jakieś "mądre inaczej" wpadły na genialny wprost pomysł i wykopały z kernela dotychczasowy driver
obsługujący moją kartę. A, że on obsługuje również i inne z serii np. RT 8168. 8169 oraz 8111, to się wzięło i wsio po prostu yebuo na pysk z dość prozaicznego powodu,
mianowicie takiego, że od wersji 4.19.x kernel potrzebuje zewnętrznie, ręcznie instalowanego sterownika, a także potrzeba dwu paczek, których wcześniej nie było
potrzeby mieć no i ja ich właśnie też nie miałam. No, ale o tym ów zasmarkaniec pan dev nigdzie nie raczył urwaszzz jego mać słowa złamanego złamas jeden napisać.

Żeby to ogarnąć trzeba jeszcze na jajku v.4.18.x doinstalować sobie paczki: dkms, acpi_call-dkms, oraz paczkę drivera karty sieciowej: r8168  8.046.00-30
I po poprawnej instalacji, po reboocie sieć znów ładnie wstaje i ślicznie działa ;)
Zarówno połączenie przez LAN, jak i przez wifi.. co dziwne, bo to u mnie są dwie różne karty sieciowe. No, ale nie istotne.. ważne, że już działa elegancko.

Dziękówka chłopaki :*

Ostatnio edytowany przez Martina Neumayer (2018-12-18 23:55:58)


Arch Linux group by Mati on MeWe:
https://mewe.com/join/archlinux

Offline

Stopka

Forum oparte na FluxBB