Nie jesteś zalogowany na forum.

#1 2018-05-17 14:19:50

nycko
Użytkownik
Data rejestracji: 2015-10-31
Liczba postów: 32
WWW

optirun nie działa z xorg-server 1.20.0 i nvidia 390.48

W obecnej chwili przy zestawie:
- xorg-server 1.20.0
- nvidia-390xx 390.48-3
- bumblebee 3.2.1-17

uruchamiając program przy użyciu 'optirun' najprawdopodobniej trafi się na taki oto błąd:

[ERROR]Cannot access secondary GPU - error: [XORG] (EE) NVIDIA: Use the -ignoreABI option to override this check.

Rozwiązaniem jest tymczasowo dopisanie sekcji ServerFlags do pliku:

/etc/bumblebee/xorg.conf.nvidia

Section "ServerFlags"
 Option "IgnoreABI" "1"
EndSection

W momencie wydania sterowników nvidia 390 obsługującej nowe ABI X-ów, sekcję powyższą będzie można usunąć. Ewentualnie można wstrzymać się z aktualizacją xorg-server do momentu wydania poprawionych sterowników.

PS. Powinno zadziałać również, jeśli karta NVidii jest jedyną w systemie. Sekcję 'ServerFlags' należy wtedy dodać do pliku odpowiedniego dla naszych ustawień.

Offline

#2 2018-05-18 12:57:21

pavbaranov
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-22
Liczba postów: 1,653
WWW

Odp: optirun nie działa z xorg-server 1.20.0 i nvidia 390.48

Gdyby ktoś był jezcze zainteresowany "rozwojemy wypadków miłosnych z NVidia": https://bbs.archlinux.org/viewtopic.php?id=237045 - śledźcie, bo pewnie się będą pojawiać tu jakieś informacje.


Hardware: AMD: A8-7410 APU with Radeon R5
Software (podaję wyłącznie odrębności): Arch testing+kde-unstable, kernel linux-pb (4.19.8 m.in. PDS, UKSM, BFQ-MQ/SQ), amdgpu (dla CIK), KDE, patche z POLAUR

Offline

#3 2018-05-18 15:58:08

nycko
Użytkownik
Data rejestracji: 2015-10-31
Liczba postów: 32
WWW

Odp: optirun nie działa z xorg-server 1.20.0 i nvidia 390.48

Wygląda na to, że nvidia-390xx 390.59-1 naprawia to, co zostało zepsute.

Offline

Stopka

Napędzają nas PacmanVPS i MegiTeam

Forum oparte na FluxBB