Nie jesteś zalogowany na forum.

#1 2016-12-17 20:54:50

Kx_liner
Użytkownik
Data rejestracji: 2015-10-25
Liczba postów: 152

Problem z aktualizacją systemu (rozwiązany)

:: Rozpoczynanie pełnej aktualizacji systemu…
:: Zastąpić kdebase-kdialog przez extra/kdialog? [T/n] t
:: Zastąpić kdebase-kfind przez extra/kfind? [T/n] t
:: Zastąpić kdegraphics-okular przez extra/okular? [T/n] t
rozwiązywanie zależności…
szukanie sprzecznych pakietów...
błąd:  nie udało się przygotować transakcji (nie udało się rozwiązać zależności)
:: kde-servicemenus-rootactions: usuwanie kdebase-kdialog zależność przerw 'kdebase-kdialog'

Czy ktoś wie co z tym zrobić?

Ostatnio edytowany przez Kx_liner (2016-12-17 22:08:38)


Używam środowiska Plazma + Lenovo ThinkPad T520 Intel Core i5

Offline

#2 2016-12-17 21:19:45

sir_lucjan
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-20
Liczba postów: 839

Odp: Problem z aktualizacją systemu (rozwiązany)

Usuń kde-servicemenus-rootactions, zaktualizuj system i zainstaluj ponownie.


Dell Inspiron 15-3542 (3542-2538) || Arch Linux || [linux-lucjan-git]
[AUR]  [GitHub]  [GitLab]

Offline

#3 2016-12-17 21:22:31

Kx_liner
Użytkownik
Data rejestracji: 2015-10-25
Liczba postów: 152

Odp: Problem z aktualizacją systemu (rozwiązany)

To nie jest takie proste:

# pacman -R kde-servicemenus-rootactions
sprawdzanie zależności…
błąd:  nie udało się przygotować transakcji (nie udało się rozwiązać zależności)
:: antergos-kde-setup: usuwanie kde-servicemenus-rootactions zależność przerw 'kde-servicemenus-rootactions'

Używam środowiska Plazma + Lenovo ThinkPad T520 Intel Core i5

Offline

#4 2016-12-17 21:28:01

sir_lucjan
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-20
Liczba postów: 839

Odp: Problem z aktualizacją systemu (rozwiązany)

W takim razie najpierw wykonaj:

yaourt -S kde-servicemenus-rootactions

Bo widzę, że dzisiaj arojas zmienił zależności w AUR.


Dell Inspiron 15-3542 (3542-2538) || Arch Linux || [linux-lucjan-git]
[AUR]  [GitHub]  [GitLab]

Offline

#5 2016-12-17 21:31:03

Kx_liner
Użytkownik
Data rejestracji: 2015-10-25
Liczba postów: 152

Odp: Problem z aktualizacją systemu (rozwiązany)

Zrobiłem jak napisałeś ale nadal jest to samo.


Używam środowiska Plazma + Lenovo ThinkPad T520 Intel Core i5

Offline

#6 2016-12-17 21:35:01

sir_lucjan
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-20
Liczba postów: 839

Odp: Problem z aktualizacją systemu (rozwiązany)

Gdy dasz:

yaourt -S aur/kde-servicemenus-rootactions

Dell Inspiron 15-3542 (3542-2538) || Arch Linux || [linux-lucjan-git]
[AUR]  [GitHub]  [GitLab]

Offline

#7 2016-12-17 21:39:51

Kx_liner
Użytkownik
Data rejestracji: 2015-10-25
Liczba postów: 152

Odp: Problem z aktualizacją systemu (rozwiązany)

Znowu kiszka ;(

rozwiązywanie zależności…
szukanie sprzecznych pakietów...
:: kdialog konfliktuje z kdebase-kdialog. Usunąć kdebase-kdialog? [t/N] t
błąd:  nie udało się przygotować transakcji (nie udało się rozwiązać zależności)
:: antergos-kde-setup: usuwanie kdebase-kdialog zależność przerw 'kdebase-kdialog'
:: kde-servicemenus-rootactions: usuwanie kdebase-kdialog zależność przerw 'kdebase-kdialog'

Używam środowiska Plazma + Lenovo ThinkPad T520 Intel Core i5

Offline

#8 2016-12-17 21:45:00

sir_lucjan
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-20
Liczba postów: 839

Odp: Problem z aktualizacją systemu (rozwiązany)

Pokaż w takim razie co pokaże:

pacman -Rcns antergos-kde-setup

Dell Inspiron 15-3542 (3542-2538) || Arch Linux || [linux-lucjan-git]
[AUR]  [GitHub]  [GitLab]

Offline

#9 2016-12-17 21:47:06

Kx_liner
Użytkownik
Data rejestracji: 2015-10-25
Liczba postów: 152

Odp: Problem z aktualizacją systemu (rozwiązany)

$ sudo pacman -Rcns antergos-kde-setup
[sudo] hasło użytkownika wojtek: 
sprawdzanie zależności…
:: kdebase-runtime opcjonalnie wymaga khelpcenter: to display applications documentation
:: kio opcjonalnie wymaga kio-extras: extra protocols support (sftp, fish and more)
:: kwallet opcjonalnie wymaga kwalletmanager: Configuration GUI
:: smtube opcjonalnie wymaga vlc: play videos with VLC
:: xdg-utils opcjonalnie wymaga kde-cli-tools: for KDE Plasma5 support in xdg-open

Pakiety (171) accounts-qml-module-0.7-1  ark-16.08.3-1  aspell-en-2016.06.26-1  baloo-5.28.0-1  baloo-widgets-16.08.3-1  breeze-5.8.4-1  breeze-gtk-5.8.4-1
              breeze-icons-5.28.0-1  breeze-kde4-5.8.4-1  cdrdao-1.2.3-9  cdrkit-1.1.11-3  chmlib-0.40-4  clementine-1.3.1-5  cln-1.3.4-3  convertlit-1.8-7
              crypto++-5.6.5-2  dcadec-0.2.0-1  djvulibre-3.5.27-3  dolphin-16.08.3-1  dolphin-plugins-16.08.3-1  dvd+rw-tools-7.1-7  ebook-tools-0.2.2-3
              ffmpeg2.8-2.8.9-1  ffmpegthumbs-16.08.3-1  frameworkintegration-5.28.0-1  grantlee-5.1.0-1  gwenview-16.08.3-1  k3b-1:2.0.3a-7
              kaccounts-integration-16.08.3-1  kactivities-5.28.0-1  kactivities-stats-5.28.0-1  kactivitymanagerd-5.8.4-1  kate-16.08.3-1  kcalc-16.08.3-1
              kde-cli-tools-5.8.4-1  kde-gtk-config-5.8.4-1  kde-servicemenus-rootactions-2.8.7-1  kdebase-kdepasswd-16.08.3-1  kdebase-kdialog-16.08.3-1
              kdebase-kfind-16.08.3-1  kdebase-lib-16.08.3-1  kdeconnect-1.0.2-1  kdecoration-5.8.4-1  kdegraphics-okular-16.08.3-2
              kdegraphics-thumbnailers-16.08.3-1  kdenetwork-kopete-16.08.3-3  kdepimlibs4-4.14.10-11  kdesu-5.28.0-1  kdesudo-3.4.2.4-1
              kdeutils-sweeper-16.08.3-1  kdoctools-5.28.0-1  kfaenza-icon-theme-0.8.9-5  kfilemetadata-5.28.0-1  khelpcenter-16.08.3-1  kholidays-16.08.3-1
              khotkeys-5.8.4-1  khtml-5.28.0-1  kidletime-5.28.0-1  kinfocenter-5.8.4-1  kio-extras-16.08.3-1  kipi-plugins-5.3.0-5  kjs-5.28.0-1
              kjsembed-5.28.0-1  kmenuedit-5.8.4-1  kpeople-5.28.0-1  krunner-5.28.0-1  kscreen-5.8.4-1  kscreenlocker-5.8.4-1  ksshaskpass-5.8.4-1
              ksysguard-5.8.4-1  ktexteditor-5.28.0-1  kuiserver-5.8.4-1  kwallet-pam-5.8.4-1  kwalletmanager-16.08.3-1  kwayland-5.28.0-1
              kwayland-integration-5.8.4-1  kwin-5.8.4-1  kwrited-5.8.4-1  libaccounts-glib-1.23-1  libaccounts-qt-1.15-1  libakonadi-qt4-1.13.0-11
              libao-1.2.0-1  libdmtx-0.7.4-5  libdvbpsi-1:1.3.0-1  libebml-1.3.4-1  libechonest-2.3.1-1  libfakekey-0.1-7  libgit2-1:0.24.3-1
              libgpod-0.8.3-4  libkate-0.4.1-5  libkcddb4-16.08.3-1  libkdcraw-16.08.3-1  libkexiv2-16.08.3-1  libkexiv2_4-15.08.3-2  libkipi-16.08.3-1
              libkscreen-5.8.4-1  libkscreen4-1.0.5-2  libksysguard-5.8.4-1  liblastfm-1.0.9-2  libmatroska-1.4.5-1  libmtp-1.1.12-1  libmusicbrainz5-5.1.0-2
              libotr-4.1.1-1  libpwquality-1.3.0-1  libqalculate-0.9.10-2  libraw-0.17.2-3  libspectre-0.2.8-1  libtar-1.2.20-2  libtiger-0.3.4-4
              libupnp-1.6.20-1  libxres-1.0.7-1  libzip-1.1.3-1  lmdb-0.9.18-2  lua-5.3.3-2  milou-5.8.4-1  mobile-broadband-provider-info-20151214-1
              modemmanager-qt-5.28.0-1  mutagen-1.35.1-1  networkmanager-qt-5.28.0-1  nm-connection-editor-1.4.2-1  openjpeg-1.5.2-1  openslp-2.0.0-1
              oxygen-5.8.4-1  plasma-desktop-5.8.4-1  plasma-framework-5.28.0-1  plasma-integration-5.8.4-1  plasma-nm-5.8.4-1  plasma-pa-5.8.4-1
              plasma-workspace-5.8.4-1  plasma-workspace-wallpapers-5.8.4-1  polkit-kde-agent-5.8.4-1  poppler-qt4-0.50.0-1  poppler-qt5-0.50.0-1
              powerdevil-5.8.4-1  prison-5.28.git20161116-1  protobuf-3.0.2-2  pulseaudio-gconf-9.0-1  purpose-1.1-2  qca-qt5-2.1.1-6  qimageblitz-0.0.6-5
              qjson-0.8.1-5  qrencode-3.4.4-1  qt5-graphicaleffects-5.7.0-1  qt5-multimedia-5.7.0-1  qt5-quickcontrols-5.7.0-1  qt5-tools-5.7.0-2
              qtcurve-gtk2-1.8.18.git20151017-1  qtcurve-qt4-1.8.18.git20151017-1  qtcurve-qt5-1.8.18.git20151017-1  qtcurve-utils-1.8.18.git20151017-1
              sdl_image-1.2.12-3  sg3_utils-1.42-1  signon-kwallet-extension-16.08.3-1  signon-plugin-oauth2-0.24-1  signon-ui-0.17+15.10.20150810-2
              signond-8.59-1  socat-1.7.3.1-3  spectacle-16.08.3-1  systemsettings-5.8.4-1  threadweaver-5.28.0-1  transmission-qt-2.92-5  ttf-hack-2.020-1
              user-manager-5.8.4-2  vlc-2.2.4-5  xapian-core-1:1.2.24-1  xcb-util-cursor-0.1.3-1  xcb-util-renderutil-0.3.9-1  xdg-user-dirs-0.15-4
              xorg-xmessage-1.0.4-2  zvbi-0.2.35-1  antergos-kde-setup-0.1.7-1

Odzyskane miejsce na dysku:  765,47 MiB

i... po ptokach ;)


Używam środowiska Plazma + Lenovo ThinkPad T520 Intel Core i5

Offline

#10 2016-12-17 21:49:58

sir_lucjan
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-20
Liczba postów: 839

Odp: Problem z aktualizacją systemu (rozwiązany)

pacman -Rns antergos-kde-setup

To mniej inwazyjna komenda.


Dell Inspiron 15-3542 (3542-2538) || Arch Linux || [linux-lucjan-git]
[AUR]  [GitHub]  [GitLab]

Offline

#11 2016-12-17 21:54:34

Kx_liner
Użytkownik
Data rejestracji: 2015-10-25
Liczba postów: 152

Odp: Problem z aktualizacją systemu (rozwiązany)

Zrobiłem już

pacman -R antergos-kde-setup

i udało się. ale nic to nie dało. Próbowałem

pacman -S antergos-kde-setup

ale już się nie dało przywrócić.

$ sudo pacman -S antergos-kde-setup
rozwiązywanie zależności…
szukanie sprzecznych pakietów...
:: kdialog konfliktuje z kdebase-kdialog. Usunąć kdebase-kdialog? [t/N] t
:: kfind konfliktuje z kdebase-kfind. Usunąć kdebase-kfind? [t/N] t
:: okular konfliktuje z kdegraphics-okular. Usunąć kdegraphics-okular? [t/N] t
błąd:  nie udało się przygotować transakcji (nie udało się rozwiązać zależności)
:: kde-servicemenus-rootactions: usuwanie kdebase-kdialog zależność przerw 'kdebase-kdialog'

Używam środowiska Plazma + Lenovo ThinkPad T520 Intel Core i5

Offline

#12 2016-12-17 21:58:12

sir_lucjan
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-20
Liczba postów: 839

Odp: Problem z aktualizacją systemu (rozwiązany)

W takim razie usuń jeszcze kde-servicemenus-rootactions i zaktualizuj system. Możesz też poczekać kilka dni aż developerzy Antegrosa raczą naprawić zależności bo "wina" leży wyłącznie po ich stronie.


Dell Inspiron 15-3542 (3542-2538) || Arch Linux || [linux-lucjan-git]
[AUR]  [GitHub]  [GitLab]

Offline

#13 2016-12-17 22:02:09

Kx_liner
Użytkownik
Data rejestracji: 2015-10-25
Liczba postów: 152

Odp: Problem z aktualizacją systemu (rozwiązany)

Teraz poszło bez problemu :)
A ten pakiet  kde-servicemenus-rootactions nie jest czymś istotnym?


Używam środowiska Plazma + Lenovo ThinkPad T520 Intel Core i5

Offline

#14 2016-12-17 22:03:54

sir_lucjan
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-20
Liczba postów: 839

Odp: Problem z aktualizacją systemu (rozwiązany)

Jest w AUR więc dla działania systemu niezbędny nie jest.

W tym momencie możesz wykonać:

yaourt -S aur/kde-servicemenus-rootactions

W AUR ma prawidłowo dodane zależności.


Dell Inspiron 15-3542 (3542-2538) || Arch Linux || [linux-lucjan-git]
[AUR]  [GitHub]  [GitLab]

Offline

#15 2016-12-17 22:08:05

Kx_liner
Użytkownik
Data rejestracji: 2015-10-25
Liczba postów: 152

Odp: Problem z aktualizacją systemu (rozwiązany)

Teraz wszystko jest OK!
Dzięki :)


Używam środowiska Plazma + Lenovo ThinkPad T520 Intel Core i5

Offline

#16 2016-12-17 22:09:42

sir_lucjan
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-20
Liczba postów: 839

Odp: Problem z aktualizacją systemu (rozwiązany)

To wynikało tylko i wyłącznie z tego, że developerzy Antegrosa nie zadbali by na czas poprawić zależności. Zapewne za kilka dni wszystko poszłoby bez problemu.


Dell Inspiron 15-3542 (3542-2538) || Arch Linux || [linux-lucjan-git]
[AUR]  [GitHub]  [GitLab]

Offline

#17 2016-12-17 22:11:36

Kx_liner
Użytkownik
Data rejestracji: 2015-10-25
Liczba postów: 152

Odp: Problem z aktualizacją systemu (rozwiązany)

Aktualizacja dzisiaj, a zależności poprawione na kilka dni - paradoks :)


Używam środowiska Plazma + Lenovo ThinkPad T520 Intel Core i5

Offline

#18 2016-12-17 22:25:49

sir_lucjan
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-20
Liczba postów: 839

Odp: Problem z aktualizacją systemu (rozwiązany)

Aktualizacja odbyła się z repozytoriów Arch Linux, pakiety które psuły zależności pochodziły z repozytoriów Antegrosa.


Dell Inspiron 15-3542 (3542-2538) || Arch Linux || [linux-lucjan-git]
[AUR]  [GitHub]  [GitLab]

Offline

Stopka

Napędzają nas PacmanVPS i MegiTeam

Forum oparte na FluxBB