Nie jesteś zalogowany na forum.

#1 2016-10-29 22:24:45

Bakr
Użytkownik
Data rejestracji: 2016-10-29
Liczba postów: 44

Instalacja Packet Tracer

Witam,

W jaki sposób zainstalować Packet Tracer na Archu?
Próbowałem z AUR, ale pojawia się błąd o braku zmiennych środowiskowych.

Offline

#2 2016-10-29 22:42:03

sir_lucjan
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-20
Liczba postów: 839

Odp: Instalacja Packet Tracer

Pokaż dokładny komunikat błędu.


Dell Inspiron 15-3542 (3542-2538) || Arch Linux || [linux-lucjan-git]
[AUR]  [GitHub]  [GitLab]

Offline

#3 2016-10-29 23:29:12

Bakr
Użytkownik
Data rejestracji: 2016-10-29
Liczba postów: 44

Odp: Instalacja Packet Tracer

Tak wygląda przebieg instalacji:


yaourt packettracer
1 aur/packettracer 7.0-2 (72) (3,05)
    Network design and emulation software for Cisco's Networking Academy 
    instructors and students.
2 aur/packettracer61 6.1.1-1 (1) (0,13)
    Network design and emulation software for Cisco's Networking Academy 
    instructors and students.
3 aur/packettracer62 6.2-2 (1) (0,13)
    Network design and emulation software for Cisco's Networking Academy 
    instructors and students.
==> Podaj numer pakietów do zainstalowania (np. 1 2 3 lub 1-3)
==> ----------------------------------------------------------
==> 1


==> Pobieranie PKGBUILD packettracer z AUR...
x .SRCINFO
x PKGBUILD
x linguist
x packettracer
x packettracer.sh
x pt.install
aissarmurad commented on 2016-08-23 16:57			 
I managed to install after move the file 'PacketTracer70_64bit_linux.tar.gz' to '/tmp/yaourt-tmp-${USER}/aur-packettracer/' with 'sudo mv PacketTracer70_64bit_linux.tar.gz /tmp/yaourt-tmp-${USER}/aur-packettracer/'

Please.. FIX the package to move tar.gz file in current work directory to correct path.

runnytu commented on 2016-08-23 20:06			 
@aissarmurad, your directory isn't the correct path, everyone may change it to any path, for example to make a kernel that isn't possible in /tmp because of limitations of space, could change in /home or any other path in pacman's config file, then there's nothing to fix, everyone must move the tar.gz to your own working directory.

kuplerei commented on 2016-09-22 20:56			 
The latest download is not compatible with this package.
You can use updpkgsums to fix it.

Louis commented on 2016-09-23 12:06			 
To be able to build this I had to change "local\/PacketTracer7" to "local\/PacketTracer6" so the proper string would be replaced in the .desktop-file.

runnytu commented on 2016-09-23 21:59			 
Hello, Bump to new version packettracer 7.0-2.

packettracer 7.0-2  (2016-09-23 21:57)
(Niewspierany pakiet: potencjalnie niebezpieczny!)
==> Edytować PKGBUILD? [T/n] ("P", aby przerwać)
==> --------------------------------------------
==> t

Proszę dodać $VISUAL do swoich zmiennych środowiskowych
na przykład:
export VISUAL="vim" (w ~/.bashrc)
(zastąp vim swoim ulubionym edytorem)

==> Edytuj PKGBUILD używając: vim

/usr/lib/yaourt/util.sh: linia 227: vim: nie znaleziono polecenia
==> Zależności packettracer:
 - lib32-openssl (już zainstalowany)
 - lib32-qt4 (już zainstalowany)
 - lib32-libpng (już zainstalowany)
 - gcc-multilib (już zainstalowany) [makedepend]


==> Edytować pt.install? [T/n] ("P", aby przerwać)
==> ----------------------------------------------
==> t

/usr/lib/yaourt/util.sh: linia 227: vim: nie znaleziono polecenia
==> Kontynuować budowanie packettracer?[T/n]
==> ----------------------------------------
==> t

==> Budowanie i instalowanie pakietu
==> Tworzę pakiet: packettracer 7.0-2 (nie, 30 paź 2016, 00:27:32 CEST)
==> Sprawdzanie zależności potrzebnych do uruchomienia...
==> Sprawdzanie zależności potrzebnych do budowy...
==> Pobieranie źródeł...
  -> Znaleziono packettracer
  -> Znaleziono linguist
  -> Znaleziono packettracer.sh
==> BŁĄD: PacketTracer70_64bit_linux.tar.gz nie jest URL i nie znalazłem go w katalgu źródłowym.
==> BŁĄD:Makepkg nie był w stanie zbudować packettracer.
==> Powtórzyć budowanie packettracer?[t/N]
==> --------------------------------------

Offline

#4 2016-10-29 23:39:57

sir_lucjan
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-20
Liczba postów: 839

Odp: Instalacja Packet Tracer

Używaj znaczników code, jeśli możesz. Cóż, wygląda na to, że PKGBUILD jest wadliwie napisany i nie dostarcza źródeł.

Tak więc zrobimy to inaczej.

Pobierz źródła stąd: https://drive.google.com/file/d/0B7zGwz … E3ck0/view

cd ~/Pobrane
yaourt -G packettracer

Tutaj wklejasz źródła - do folderu packettracer.

cd packettracer
makepkg -srci

Powinno pomóc.


Dell Inspiron 15-3542 (3542-2538) || Arch Linux || [linux-lucjan-git]
[AUR]  [GitHub]  [GitLab]

Offline

#5 2016-10-30 15:05:24

Bakr
Użytkownik
Data rejestracji: 2016-10-29
Liczba postów: 44

Odp: Instalacja Packet Tracer

Niestety nadal nic.

Offline

#6 2016-10-30 19:02:44

pavbaranov
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-22
Liczba postów: 1,661
WWW

Odp: Instalacja Packet Tracer

Niestety nic to nie mówi. Packettracer nie oferuje (przynajmniej w prosty sposób) paczki. W związku z tym musisz umieścić paczkę w katalogu, w którym istnieje PKGBUILD. Dopiero potem wydać to co pisze Lucek.
A co to znaczy "niestety nadal nic" - nie wiemy. Szklanej kuli brak.
EDIT:
Sposób podany przez Sir_Lucjana działa, vide:

==> Skończyłem tworzenie: packettracer 7.0-2 (pon, 31 paź 2016, 07:35:25 CET)

Hardware: AMD: A8-7410 APU with Radeon R5
Software (podaję wyłącznie odrębności): Arch testing+kde-unstable, kernel linux-pb (4.19.8 m.in. PDS, UKSM, BFQ-MQ/SQ), amdgpu (dla CIK), KDE, patche z POLAUR

Offline

#7 2016-10-31 14:43:41

sir_lucjan
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-20
Liczba postów: 839

Odp: Instalacja Packet Tracer

Krótka piłka - jeśli chcesz uzyskać pomóc, pisz nieco jaśniej i dokładniej. Czyli do każdego problemu komplet możliwych informacji. W tym wypadków logów kompilatora. Bez tego tylko tracisz czas, bo nie uzyskasz pomocy - bo niby jak, jeśli nie wiemy, co jest nie tak. Sposób podany przeze mnie działa, sprawdziłem. Nie pisałbym czegoś bez pokrycia.


Dell Inspiron 15-3542 (3542-2538) || Arch Linux || [linux-lucjan-git]
[AUR]  [GitHub]  [GitLab]

Offline

#8 2016-11-07 19:17:32

Bakr
Użytkownik
Data rejestracji: 2016-10-29
Liczba postów: 44

Odp: Instalacja Packet Tracer

Aktualnie wyświetla się taki komunikat:

==> Tworzę pakiet: packettracer 7.0-2 (pon, 7 lis 2016, 19:16:15 CET)
==> Sprawdzanie zależności potrzebnych do uruchomienia...
==> Instaluję brakujące zależności...
błąd:  pakiet lib32-openssl nie został znaleziony
błąd:  pakiet lib32-qt4 nie został znaleziony
błąd:  pakiet lib32-libpng nie został znaleziony
==> BŁĄD: 'pacman' nie mógł zainstalować brakujących zależności

Ostatnio edytowany przez Bakr (2016-11-07 19:18:56)

Offline

#9 2016-11-07 19:19:18

marcin82
Moderator
Lokalizacja: Sosnowiec
Data rejestracji: 2015-08-20
Liczba postów: 154

Odp: Instalacja Packet Tracer

Odhaszuj, de facto włącz repozytorium multilib w /etc/pacman.conf:

[multilib]
Include = /etc/pacman.d/mirrorlist

Potem:

# pacman -Syy

marcin82

Offline

#10 2016-11-12 20:23:50

Bakr
Użytkownik
Data rejestracji: 2016-10-29
Liczba postów: 44

Odp: Instalacja Packet Tracer

Obecny problem (powstały prawdopodobnie po aktualizacji systemu) polega na tym, że po po połączeniu dwóch urządzeń w programie (np. komputera i switcha) wyłącza się reakcja na kliknięcia myszki wewnątrz programów, tzn. mogę się przełączać między programami, ale nie mogę np. dodać kolejnego urządzenia w Packet Tracer lub zamknąć karty w przeglądarce.

Offline

#11 2016-11-12 21:29:54

pavbaranov
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-22
Liczba postów: 1,661
WWW

Odp: Instalacja Packet Tracer

Co to ma wspólnego z instalacją?


Hardware: AMD: A8-7410 APU with Radeon R5
Software (podaję wyłącznie odrębności): Arch testing+kde-unstable, kernel linux-pb (4.19.8 m.in. PDS, UKSM, BFQ-MQ/SQ), amdgpu (dla CIK), KDE, patche z POLAUR

Offline

#12 2016-11-12 21:53:56

sir_lucjan
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-20
Liczba postów: 839

Odp: Instalacja Packet Tracer

Jeden wątek = jeden problem. Jeśli chcesz uzyskać odpowiedź, załóż oddzielny temat.


Dell Inspiron 15-3542 (3542-2538) || Arch Linux || [linux-lucjan-git]
[AUR]  [GitHub]  [GitLab]

Offline

Stopka

Napędzają nas PacmanVPS i MegiTeam

Forum oparte na FluxBB