Nie jesteś zalogowany na forum.

#1 2016-10-30 15:26:11

Bakr
Użytkownik
Data rejestracji: 2016-10-29
Liczba postów: 44

Instalacja drukarki

Witam,

W jaki sposób zainstalować drukarkę na Archu?
Model to HP Deskjet 845c
Drukarka jest podłączona kablem USB do laptopa.

W menu Ustawienia > Drukarki (gnome) wyświetla sie komunikat "Systemowa usługa drukowania jest niedostępna".

Offline

#2 2016-10-30 18:54:47

marcin82
Moderator
Lokalizacja: Sosnowiec
Data rejestracji: 2015-08-20
Liczba postów: 154

Odp: Instalacja drukarki

Zainstaluj pakiet cups i uruchom usługę cups. Zainstaluj też pakiet hplip. Więcej znajdziesz tutaj:
https://wiki.archlinux.org/index.php/CUPS#USB
https://wiki.archlinux.org/index.php/CU … LIP_Driver .

Jeśli ustawienia drukarek w Gnome nadal nie będą dostępne wyloguj się i zaloguj ponownie. Jeśli nadal nie będzie działać sprawdź w przeglądarce czy możesz wejść na "stronę":
http://localhost:631 .


marcin82

Offline

#3 2016-10-30 22:30:47

Bakr
Użytkownik
Data rejestracji: 2016-10-29
Liczba postów: 44

Odp: Instalacja drukarki

Po wydaniu komendy hpsetup -u wyświetla się:

HP Linux Imaging and Printing System (ver. 3.16.9)
Printer/Fax Setup Utility ver. 9.0
Copyright (c) 2001-15 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.
warning: GUI Modules PyQt4 and PyQt5 are not installed
error: hp-setup requires GUI support (try running with --qt3). Also, try using interactive (-i) mode.
[bartek@thinkpadt540p ~]$

Ostatnio edytowany przez Bakr (2016-10-30 22:32:16)

Offline

#4 2016-10-31 07:31:14

pavbaranov
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-22
Liczba postów: 1,661
WWW

Odp: Instalacja drukarki

Bakr napisał/a:

Po wydaniu komendy hpsetup -u wyświetla się:

(...)
warning: GUI Modules PyQt4 and PyQt5 are not installed
error: hp-setup requires GUI support (try running with --qt3). Also, try using interactive (-i) mode.
[bartek@thinkpadt540p ~]$

Cyt. ze wskazanej Ci strony wiki:

To run with qt frontend:
# hpsetup -u

Nie zainstalowałeś opcjonalnych zależności do hplip, w tym python-pyqt5 - nie masz zatem możiwości uruchomienia hpsetup z "qt frontend" :)
Podążając za tym samym wiki (następna linijka):

To run with command line:
# hp-setup -i

lub jeśli chcesz mieć GUI - doinstaluj python-pyqt5 (ew. inne zależności opcjonalne, jakie Ci potrzebne, a najlepiej wszystkie).


Hardware: AMD: A8-7410 APU with Radeon R5
Software (podaję wyłącznie odrębności): Arch testing+kde-unstable, kernel linux-pb (4.19.8 m.in. PDS, UKSM, BFQ-MQ/SQ), amdgpu (dla CIK), KDE, patche z POLAUR

Offline

#5 2016-10-31 10:58:42

sir_lucjan
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-20
Liczba postów: 839

Odp: Instalacja drukarki

Zainstalowałeś hplip-plugin z AUR?


Dell Inspiron 15-3542 (3542-2538) || Arch Linux || [linux-lucjan-git]
[AUR]  [GitHub]  [GitLab]

Offline

#6 2016-10-31 11:18:55

pavbaranov
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-22
Liczba postów: 1,661
WWW

Odp: Instalacja drukarki

Lucek - on nie zainstalował sobie paczek niezbędnych do GUI, a chce w ten sposób uruchomić hplip. Inna sprawa, czy ów hplip-plugin na pewno mu potrzebny? Zob.: http://hplipopensource.com/hplip-web/plugin.html, gdzie ponoć jest aktualna, pełna lista urządzeń HP wymagających pluginu.
Zgodnie z:
http://www.openprinting.org/printer/HP/HP-DeskJet_845C
http://hplipopensource.com/hplip-web/mo … _845c.html
zainstalować (prawidłowo) hplip i... ma działać.


Hardware: AMD: A8-7410 APU with Radeon R5
Software (podaję wyłącznie odrębności): Arch testing+kde-unstable, kernel linux-pb (4.19.8 m.in. PDS, UKSM, BFQ-MQ/SQ), amdgpu (dla CIK), KDE, patche z POLAUR

Offline

#7 2016-10-31 11:23:05

sir_lucjan
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-20
Liczba postów: 839

Odp: Instalacja drukarki

U mnie bez hplip-plugin nie drukuje, stąd to pytanie.


Dell Inspiron 15-3542 (3542-2538) || Arch Linux || [linux-lucjan-git]
[AUR]  [GitHub]  [GitLab]

Offline

#8 2016-11-03 22:08:08

Bakr
Użytkownik
Data rejestracji: 2016-10-29
Liczba postów: 44

Odp: Instalacja drukarki

Aktualnie wyskakuje mi taki oto błąd:

Using queue name: DeskJet_845C
Locating PPD file... Please wait.
error: No PPD found for model deskjet_845c using old algorithm.
error: Unable to find an appropriate PPD file.

Witryna: http://localhost:631 jest niedotępna.
Podczas próby aktywacji CUPS systemctl enable cups    |     systemctl start cups   pokazuje Failed to enable unit: No such file or directory

Ostatnio edytowany przez Bakr (2016-11-03 22:13:20)

Offline

#9 2016-11-03 22:53:39

pavbaranov
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-22
Liczba postów: 1,661
WWW

Odp: Instalacja drukarki

Nie podniosłeś CUPSa. https://wiki.archlinux.org/index.php/CUPS#Installation
To po pierwsze.
Podnieś i zobacz co to da.


Hardware: AMD: A8-7410 APU with Radeon R5
Software (podaję wyłącznie odrębności): Arch testing+kde-unstable, kernel linux-pb (4.19.8 m.in. PDS, UKSM, BFQ-MQ/SQ), amdgpu (dla CIK), KDE, patche z POLAUR

Offline

Stopka

Napędzają nas PacmanVPS i MegiTeam

Forum oparte na FluxBB