Nie jesteś zalogowany na forum.

#1 2016-06-15 10:03:04

addos
Użytkownik
Data rejestracji: 2015-09-01
Liczba postów: 142

[Rozw.] KDE powiadomienia - która paczka za to odpowiedzialna?

Podpowiedzcie mi proszę, która biblioteka/paczka jest odpowiedzialna za sposób w jaki użytkownik KDE jest powiadamiany komunikatami o jakiś zdarzeniach, np. skopiowano plik, itp.
Nieprzeczytane komunikaty odkładają się na stosie i w tzw. tray widać ich liczbę w kółku.
Nawet jeżeli znikną to potem mogę je przejrzeć i usunąć.

Wczoraj pobrałem sporo paczek i któraś z nich namieszała w moim zmiksowanym KDE tak, że komunikat czasami się pojawia, a czasami nie.
Nawet jeżeli już się pojawi to wygląda bardzo prymitywnie i gdy już zniknie, to nigdzie nie można go odczytać.
Problem jest wtedy gdy on się pojawia przez krótką chwilę a mnie nie ma przy komputerze, albo patrzę się w innym kierunku.
Wtedy nawet nie wiem, że coś się pojawiło bo nie ma tej ikonki z nieprzeczytanymi powiadomieniami.

Nie przesiadłem się do końca na Plasmę 5 bo jak dla mnie nie nadaje się jeszcze na przesiadkę.
Częściowo jestem na KDE4 a część paczek mam z 5.
Oczywiście skutkuje to tym, że czasami gdy coś po aktualizacji działa nie tak jak ja bym chciał, to muszę wykonywać downgrade i dodawać paczkę do ignorowanych.
Ta liczba cały czas powolutku rośnie i jestem świadomy, że nastąpi kiedyś taki moment, że będę musiał albo zablokować całe KDE, ale przesiąść się na Plasma 5.
Dopóki jednak nie będzie to działało tak, jak to było/jest w KDE4 to nici z mojej przesiadki.
Tym razem poszło sporo paczek a ja nie wiem, która to dokładnie paczka jest odpowiedzialna za te powiadomienia.
Czy może mi pomóc?

Ten paczki zostały wczoraj pociągnięte, więc to któraś z nich:

[2016-06-14 11:53] [ALPM] upgraded libcdio-paranoia (10.2+0.93+1-1 -> 10.2+0.93+1-2)
[2016-06-14 11:53] [ALPM] upgraded orc (0.4.25-1 -> 0.4.25-2)
[2016-06-14 13:42] [ALPM] upgraded signond (8.58-1 -> 8.59-1)
[2016-06-14 17:44] [ALPM] upgraded qt5-base (5.6.0-7 -> 5.6.1-1)
[2016-06-14 17:44] [ALPM] upgraded qt5-x11extras (5.6.0-1 -> 5.6.1-1)
[2016-06-14 17:44] [ALPM] upgraded qt5-script (5.6.0-1 -> 5.6.1-1)
[2016-06-14 17:44] [ALPM] upgraded qt5-svg (5.6.0-1 -> 5.6.1-1)
[2016-06-14 17:44] [ALPM] upgraded qt5-xmlpatterns (5.6.0-1 -> 5.6.1-1)
[2016-06-14 17:44] [ALPM] upgraded qt5-declarative (5.6.0-1 -> 5.6.1-1)
[2016-06-14 17:44] [ALPM] upgraded kde-cli-tools (5.6.4-1 -> 5.6.5-1)
[2016-06-14 17:44] [ALPM] upgraded kde-gtk-config (5.6.4-1 -> 5.6.5-1)
[2016-06-14 17:44] [ALPM] upgraded kuiserver (5.6.4-1 -> 5.6.5.1-1)
[2016-06-14 17:44] [ALPM] upgraded qt5-imageformats (5.6.0-2 -> 5.6.1-1)
[2016-06-14 17:44] [ALPM] upgraded qt5-location (5.6.0-1 -> 5.6.1-1)
[2016-06-14 17:44] [ALPM] upgraded qt5-multimedia (5.6.0-1 -> 5.6.1-1)
[2016-06-14 17:44] [ALPM] upgraded qt5-quickcontrols (5.6.0-1 -> 5.6.1-1)
[2016-06-14 17:44] [ALPM] upgraded qt5-sensors (5.6.0-1 -> 5.6.1-1)
[2016-06-14 17:44] [ALPM] upgraded qt5-webchannel (5.6.0-1 -> 5.6.1-1)
[2016-06-14 17:44] [ALPM] upgraded qt5-webkit (5.6.0-4 -> 5.6.1-1)
[2016-06-14 17:44] [ALPM] upgraded qt5-tools (5.6.0-2 -> 5.6.1-1)
[2016-06-14 17:44] [ALPM] upgraded qt5-translations (5.6.0-1 -> 5.6.1-1)
[2016-06-14 21:23] [ALPM] upgraded qt5-base (5.6.1-1 -> 5.6.1-2)
[2016-06-14 21:24] [ALPM] upgraded kdelibs (4.14.20-1 -> 4.14.21-1)
[2016-06-14 21:35] [ALPM] upgraded libpng (1.6.22-1 -> 1.6.23-1)
[2016-06-14 21:35] [ALPM] upgraded device-mapper (2.02.154-3 -> 2.02.155-1)
[2016-06-14 21:35] [ALPM] upgraded lvm2 (2.02.154-3 -> 2.02.155-1)
[2016-06-14 21:35] [ALPM] upgraded jemalloc (4.2.0-1 -> 4.2.1-1)
[2016-06-14 21:46] [ALPM] upgraded gpgmepp (16.04.1-1 -> 16.04.2-1)
[2016-06-14 21:46] [ALPM] upgraded ark (16.04.1-1 -> 16.04.2-1)
[2016-06-14 21:46] [ALPM] upgraded baloo-widgets (16.04.1-1 -> 16.04.2-1)
[2016-06-14 21:46] [ALPM] upgraded dolphin (16.04.1-2 -> 16.04.2-1)
[2016-06-14 21:46] [ALPM] upgraded dolphinpart4 (16.04.1-1 -> 16.04.2-1)
[2016-06-14 21:46] [ALPM] upgraded filelight (16.04.1-1 -> 16.04.2-1)
[2016-06-14 21:46] [ALPM] upgraded libkipi (16.04.1-1 -> 16.04.2-1)
[2016-06-14 21:46] [ALPM] upgraded libkdcraw (16.04.1-1 -> 16.04.2-1)
[2016-06-14 21:46] [ALPM] upgraded gwenview (16.04.1-1 -> 16.04.2-1)
[2016-06-14 21:46] [ALPM] upgraded kate (16.04.1-2 -> 16.04.2-1)
[2016-06-14 21:46] [ALPM] upgraded kcalc (16.04.1-1 -> 16.04.2-1)
[2016-06-14 21:46] [ALPM] upgraded kcalcore (16.04.1-1 -> 16.04.2-1)
[2016-06-14 21:46] [ALPM] upgraded kpimtextedit (16.04.1-1 -> 16.04.2-1)
[2016-06-14 21:46] [ALPM] upgraded kcalutils (16.04.1-1 -> 16.04.2-1)
[2016-06-14 21:46] [ALPM] upgraded kcolorchooser (16.04.1-1 -> 16.04.2-1)
[2016-06-14 21:46] [ALPM] upgraded kcontacts (16.04.1-1 -> 16.04.2-1)
[2016-06-14 21:46] [ALPM] upgraded kde-syndication (16.04.1-1 -> 16.04.2-1)
[2016-06-14 21:46] [ALPM] upgraded kdebase-runtime (16.04.1-1 -> 16.04.2-1)
[2016-06-14 21:46] [ALPM] upgraded kdebase-kdepasswd (16.04.1-1 -> 16.04.2-1)
[2016-06-14 21:46] [ALPM] upgraded kdebase-kdialog (16.04.1-1 -> 16.04.2-1)
[2016-06-14 21:46] [ALPM] upgraded kdebase-keditbookmarks (16.04.1-1 -> 16.04.2-1)
[2016-06-14 21:46] [ALPM] upgraded kdebase-kfind (16.04.1-1 -> 16.04.2-1)
[2016-06-14 21:46] [ALPM] upgraded kdebase-konqueror (16.04.1-1 -> 16.04.2-1)
[2016-06-14 21:46] [ALPM] upgraded kdebase-konq-plugins (16.04.1-1 -> 16.04.2-1)
[2016-06-14 21:46] [ALPM] upgraded kdegraphics-kolourpaint (16.04.1-1 -> 16.04.2-1)
[2016-06-14 21:46] [ALPM] upgraded kdegraphics-ksaneplugin (16.04.1-1 -> 16.04.2-1)
[2016-06-14 21:46] [ALPM] upgraded kdegraphics-mobipocket (16.04.1-1 -> 16.04.2-1)
[2016-06-14 21:46] [ALPM] upgraded kdegraphics-okular (16.04.1-1 -> 16.04.2-1)
[2016-06-14 21:46] [ALPM] upgraded kdemultimedia-kmix (16.04.1-1 -> 16.04.2-1)
[2016-06-14 21:46] [ALPM] upgraded kdeutils-kdf (16.04.1-1 -> 16.04.2-1)
[2016-06-14 21:46] [ALPM] upgraded kdeutils-kgpg (16.04.1-1 -> 16.04.2-1)
[2016-06-14 21:46] [ALPM] upgraded kdeutils-sweeper (16.04.1-1 -> 16.04.2-1)
[2016-06-14 21:46] [ALPM] upgraded kholidays (16.04.1-1 -> 16.04.2-1)
[2016-06-14 21:46] [ALPM] upgraded kldap (16.04.1-1 -> 16.04.2-1)
[2016-06-14 21:46] [ALPM] upgraded kio-pim (16.04.1-1 -> 16.04.2-1)
[2016-06-14 21:46] [ALPM] upgraded kmime (16.04.1-1 -> 16.04.2-1)
[2016-06-14 21:46] [ALPM] upgraded kmbox (16.04.1-1 -> 16.04.2-1)
[2016-06-14 21:46] [ALPM] upgraded libkomparediff2 (16.04.1-1 -> 16.04.2-1)
[2016-06-14 21:46] [ALPM] upgraded kompare (16.04.1-1 -> 16.04.2-1)
[2016-06-14 21:46] [ALPM] upgraded konsole (16.04.1-1 -> 16.04.2-1)
[2016-06-14 21:46] [ALPM] upgraded krdc (16.04.1-1 -> 16.04.2-1)
[2016-06-14 21:46] [ALPM] upgraded ktimer (16.04.1-1 -> 16.04.2-1)
[2016-06-14 21:46] [ALPM] upgraded libastro (16.04.1-2 -> 16.04.2-1)
[2016-06-14 21:46] [ALPM] upgraded libkcddb (16.04.1-1 -> 16.04.2-1)
[2016-06-14 21:46] [ALPM] upgraded libktnef (16.04.1-1 -> 16.04.2-1)
[2016-06-14 21:46] [ALPM] upgraded marble-data (16.04.1-2 -> 16.04.2-1)
[2016-06-14 21:46] [ALPM] upgraded marble (16.04.1-2 -> 16.04.2-1)
[2016-06-14 21:46] [ALPM] upgraded print-manager (16.04.1-1 -> 16.04.2-1)
[2016-06-15 00:01] [ALPM] upgraded libcups (2.1.3-2 -> 2.1.4-1)
[2016-06-15 00:01] [ALPM] upgraded xkeyboard-config (2.17-2 -> 2.18-1)
[2016-06-15 00:01] [ALPM] upgraded cups (2.1.3-2 -> 2.1.4-1)
[2016-06-15 00:01] [ALPM] upgraded libinput (1.3.0-2 -> 1.3.1-1)
[2016-06-15 02:09] [ALPM] upgraded pacman-mirrorlist (20160610-1 -> 20160614-1)

Zdaję sobie sprawę, że część z powyższego mogłem wyciąć ale zostawiam całość na wszelki wypadek.

EDIT:

Poniższe paczki mam zablokowane (dodane do ignorowanych):

IgnorePkg   = firefox firefox-i18n-pl ktorrent libktorrent libksysguard knemo kde-l10n-pl kdebase-workspace kdebase-lib kdegraphics-ksnapshot kactivities-frameworks kio-extras akonadi akonadi-calendar akonadi-client akonadi-contact akonadi-mime akonadi-notes akonadi-search akonadi-socialutils akregator kaddressbook kalarm kalarmcal kdepim-runtime kidentitymanagement kimap kleopatra kmail kmailtransport kontact kontactinterface korganizer kwalletmanager kwallet libkdepim

Oczywiście Firefox też tu wylądował bo też wydziwiają co wersję :)

Ostatnio edytowany przez addos (2016-06-15 16:16:46)


Info przy ew. problemach: Arch Linux x64, Plasma 5 (aktualna), CPU C2D E8400 (3GHz, 6MB cache), ASUS P5Q-PRO (BIOS, bez UEFI), RAM 8GB (DDR2, Dual), GPU GF 9600GT (PCI-E, 512MB), SSD 250GB MLC (GPT, discard, Grub 2, all ext4), HDD 1TB (7200, SATA, AHCI, NCQ, MBR, all ext4), monitor 1920x1080@60Hz DVI, audio: ASUS Xonar DX (PCI-E x1, 5.1 analog, ALSA bez PulseAudio), klaw. PS/2, mysz USB

Offline

#2 2016-06-15 12:17:18

pavbaranov
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-22
Liczba postów: 1,661
WWW

Odp: [Rozw.] KDE powiadomienia - która paczka za to odpowiedzialna?

Cóż - KDE4 nie ma już wsparcia w Arch Linux, zatem - brutalnie mówiąc - musisz sobie z czymś takim, co masz radzić praktycznie sam. Bóg jeden też raczy wiedzieć co u Ciebie za to odpowiada. W obecnym środowisku od KDE jest to (o ile się nie mylę) knotifications należące do KF5. Jedyne paczki, które są jeszcze bibliotekami z KDE4, które instalowałeś wczoraj, to kdelibs i kdebase-runtime.

Twój system jest tak wymieszany, że aż dziw, że jeszcze w ogóle pracuje. Zwróć uwagę na to w jakich wersjach masz paczki programów, które są od siebie zależne (np. dolphin i kio-extras, a to jedynie jeden przykład). Nawet same biblioteki KDE4. Te programy, biblioteki są zwykle tak pomyślane by współpracowały ze sobą w określonej wersji. Tak też są paczkowane. Sposób aktualizacji, jaki wybrałeś jest również niewspierany przez Archa.

Powtórzę się po wczorajszej wypowiedzi arojasa - jeśli chcesz korzystać z KDE4, to musisz zmienić dystrybucję na taką, w której jest ona jeszcze obecna.

Są jeszcze jakieś "niezależne" repozytoria, w których KDE4 dla Archa jest trzymane, ale - co do zasady - zainstalować to, co tam jest i trzymać system bez zmian, a już na pewno nie wpuszczać nowych wersji paczek z KDE. Inaczej się praktycznie nie da, a i to rozwiązanie jest mocno wątpliwe.


Hardware: AMD: A8-7410 APU with Radeon R5
Software (podaję wyłącznie odrębności): Arch testing+kde-unstable, kernel linux-pb (4.19.8 m.in. PDS, UKSM, BFQ-MQ/SQ), amdgpu (dla CIK), KDE, patche z POLAUR

Offline

#3 2016-06-15 16:11:12

addos
Użytkownik
Data rejestracji: 2015-09-01
Liczba postów: 142

Odp: [Rozw.] KDE powiadomienia - która paczka za to odpowiedzialna?

Ha! A jednak udało się :)
Rzeczywiście paczka odpowiedzialna za moje zmartwienie to kdebase-runtime - poleciała jako kolejna do ignorowanych.
Dopóki to co robię będzie działać, to będę się trzymał KDE4.

A czy to cud, że mi to działa? Przecież był okres przejściowy gdzie jeszcze było wsparcie i to też działało, to czemu teraz miało by nie działać?
Oczywiście, że programiści nie wspierają więc to na mojej głowie leży sprawdzanie czy wszystko jest OK.
Trudno.... będę to robił aż napotkam ścianę... i wtedy albo się przesiądę, albo przez jakiś czas zostanę.
Mimo wszystko Plasma 5 jest nieunikniona ale w mojej opinii na razie jest jeszcze do poprawienia sporo rzeczy.


Info przy ew. problemach: Arch Linux x64, Plasma 5 (aktualna), CPU C2D E8400 (3GHz, 6MB cache), ASUS P5Q-PRO (BIOS, bez UEFI), RAM 8GB (DDR2, Dual), GPU GF 9600GT (PCI-E, 512MB), SSD 250GB MLC (GPT, discard, Grub 2, all ext4), HDD 1TB (7200, SATA, AHCI, NCQ, MBR, all ext4), monitor 1920x1080@60Hz DVI, audio: ASUS Xonar DX (PCI-E x1, 5.1 analog, ALSA bez PulseAudio), klaw. PS/2, mysz USB

Offline

#4 2016-06-15 16:52:45

pavbaranov
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-22
Liczba postów: 1,661
WWW

Odp: [Rozw.] KDE powiadomienia - która paczka za to odpowiedzialna?

Cud, że działa :) Masz w systemie paczki b. różnych wersji, które nie są przewidziane do wspólnego działania. Stąd też i takie problemy. Okres przejściowy skończył się w sierpniu ub.r. Od tego czasu KDE4 już nie ma. Są dystrybucje, które usiłują to jeszcze utrzymywać (bo przecież nie wspierać). U Ciebie nie działa (niekiedy) z uwagi na to, że system masz po prostu pomieszany do granic przyzwoitości, zrobiony bez - z całym szacunkiem - ale wiedzy o tym, jak winno to wyglądać, by jeszcze działało (innymi słowy działa metoda prób i błędów). Twój wybór, ale gdybym się na coś takiego decydował - zrobiłbym inaczej.

Jeśli chodzi o "poprawienie" Plasma 5. To inne środowisko. To nie KDE4 przeprotowane do Qt5 i QML. Nie będzie to działać tak, jak KDE4 nigdy. Przez 2 tygodnie, lata już temu, psioczyłem na Plasmę ile wlezie. Teraz uważam, że mimo wszystko jest ok. Poprawieniu pewnie i to i owo wymaga, ale bez ludzi, którzy tego używają i zgłaszają swoje pomysły, wątpliwości, czy błędy - nie należy oczekiwać, że będzie lepiej. Na pewno zaś nie będzie tak, jak było w KDE4. I poniekąd już wiem, że na całe szczęście.


Hardware: AMD: A8-7410 APU with Radeon R5
Software (podaję wyłącznie odrębności): Arch testing+kde-unstable, kernel linux-pb (4.19.8 m.in. PDS, UKSM, BFQ-MQ/SQ), amdgpu (dla CIK), KDE, patche z POLAUR

Offline

Stopka

Napędzają nas PacmanVPS i MegiTeam

Forum oparte na FluxBB