Nie jesteś zalogowany na forum.

#1 2018-08-26 08:02:43

Kx_liner
Użytkownik
Data rejestracji: 2015-10-25
Liczba postów: 152

Błąd w aktualizacji phonon-qt4 Rozwiązany

Dawno mnie tutaj nie było, ale mam mały problem, z którym nie mogę sobie poradzić.
Otóż w AUR jest nowa wersja pakietu phonon-qt4 i Octopi mi to sygnalizuje. Nie wiem jak mu jednak "wytłumaczyć", żeby się "uspokoił".
Przy aktualizacji wyskakuje mi coś takiego:

==> Weryfikowanie podpisów plików źródłowych za pomocą gpg...phonon-qt4-gstreamer
    phonon-4.10.1.tar.xz ... NIE ZGADZA SIĘ (nieznany klucz publiczny B92A5F04EC949121)
==> BŁĄD: Jeden lub więcej podpisów PGP nie może zostać zweryfikowanych!
==> BŁĄD:Makepkg nie był w stanie zbudować phonon-qt4.

Korzystam z AUR, bo jest tam kilka paczek, których potrzebuję i dlatego interesują mnie ich aktualizacje.

Ostatnio edytowany przez Kx_liner (2018-08-26 09:46:33)


Używam środowiska Plazma + Lenovo ThinkPad T520 Intel Core i5

Offline

#2 2018-08-26 09:19:09

pavbaranov
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-22
Liczba postów: 1,661
WWW

Odp: Błąd w aktualizacji phonon-qt4 Rozwiązany

Jest coś takiego jak wiki Archa dotyczące GPG oraz podręcznik makepkg. W jednym i w drugim masz rozwiązanie.

PS: Sprawdź sobie, czy w ogóle phonon-qt4 jest Ci jeszcze potrzebny w systemie (generalnie bardzo mocno Arch został oczyszczony z paczek związanych z Qt4 i nie zawiera ani jednej wymagającej kdelibs). Ostatnio w repozytoriach zachodzą duże zmiany. Fakt, że phonon-qt jest obecnie w repozytorium dostępny wyłącznie w wersji Qt5 oznacza, że żadna paczka znajdująca się w repozytorium nie wymaga już phonon-qt4. Jeśli nie masz jakiejkolwiek paczki, która jej wymaga (sprawdź np. w AUR lub wydając polecenie:

pacman -Qi phonon-qt4

), to spokojnie się możesz jej pozbyć.


Hardware: AMD: A8-7410 APU with Radeon R5
Software (podaję wyłącznie odrębności): Arch testing+kde-unstable, kernel linux-pb (4.19.8 m.in. PDS, UKSM, BFQ-MQ/SQ), amdgpu (dla CIK), KDE, patche z POLAUR

Offline

#3 2018-08-26 09:25:31

Kx_liner
Użytkownik
Data rejestracji: 2015-10-25
Liczba postów: 152

Odp: Błąd w aktualizacji phonon-qt4 Rozwiązany

$ sudo pacman -Qi phonon-qt4
[sudo] hasło użytkownika wojtek: 
Nazwa                 : phonon-qt4
Wersja                : 4.10.1-1
Opis                  : The multimedia framework for KDE4
Architektura          : x86_64
Adres url             : http://phonon.kde.org/
Licencje              : LGPL
Grupy                 : Brak
Dostarcza             : Brak
Zależy od             : qt4  libpulse  phonon-qt4-backend
Opcjonalne zależności : pulseaudio: PulseAudio support [zainstalowano]
Wymagany przez        : kdelibs  phonon-qt4-gstreamer
Opcjonalny dla        : Brak
Komfliktuje z         : Brak
Zastępuje             : Brak
Rozmiar po instalacji : 1148,00 KiB
Autor pakietu         : Antonio Rojas <arojas@archlinux.org>
Data zbudowania       : pią, 27 kwi 2018, 13:04:39
Data zainstalowania   : nie, 1 lip 2018, 10:47:40
Powód zainstalowania  : Zależność innego pakietu
Skrypt instalacyjny   : Nie
Potwierdzone przez    : Podpis

Zrobiłem

 $ sudo gpg --import public.key B92A5F04EC949121
[sudo] hasło użytkownika wojtek: 
gpg: keybox '/root/.gnupg/pubring.kbx' created
gpg: can't open 'public.key': Nie ma takiego pliku ani katalogu
gpg: can't open 'B92A5F04EC949121': Nie ma takiego pliku ani katalogu
gpg: Ogółem przetworzonych kluczy: 0

Coś tutaj chyba nie tak, albo ja czegoś nie rozumiem.

Ostatnio edytowany przez Kx_liner (2018-08-26 09:32:29)


Używam środowiska Plazma + Lenovo ThinkPad T520 Intel Core i5

Offline

#4 2018-08-26 09:30:22

pavbaranov
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-22
Liczba postów: 1,661
WWW

Odp: Błąd w aktualizacji phonon-qt4 Rozwiązany

Kx_liner napisał/a:
$ sudo pacman -Qi phonon-qt4
[sudo] hasło użytkownika wojtek: 
Nazwa                 : phonon-qt4
Wymagany przez        : kdelibs  phonon-qt4-gstreamer

No to teraz sprawdź te dwie paczki, czy są Ci potrzebne w systemie. Żadna z nich nie jest wymagana do szczęścia przez żaden pakiet w repozytorium (stąd obie są teraz, wraz zresztą z innymi phonon-qt4-* w AUR). Pierwszej możesz potrzebować jedynie opcjonalnie w środowisku opartym o Qt dla zachowania natywnych okien dialogowych itp. w libreoffice-still; nie potrzebujesz jej już dla libreoffice-fresh - ta wersja w ogóle nie ma VCL_KDE4).


Hardware: AMD: A8-7410 APU with Radeon R5
Software (podaję wyłącznie odrębności): Arch testing+kde-unstable, kernel linux-pb (4.19.8 m.in. PDS, UKSM, BFQ-MQ/SQ), amdgpu (dla CIK), KDE, patche z POLAUR

Offline

#5 2018-08-26 09:41:06

Kx_liner
Użytkownik
Data rejestracji: 2015-10-25
Liczba postów: 152

Odp: Błąd w aktualizacji phonon-qt4 Rozwiązany

To takie "w koło Macieju" jak pacman jest mądrzejszy od użytkownika

$ sudo pacman -Rns phonon-qt4
[sudo] hasło użytkownika wojtek: 
sprawdzanie zależności…
błąd:  nie udało się przygotować transakcji (nie udało się rozwiązać zależności)
:: kdelibs: usuwanie phonon-qt4 łamie zależność 'phonon-qt4'
:: phonon-qt4-gstreamer: usuwanie phonon-qt4 łamie zależność 'phonon-qt4'

Sprawa załatwiona; były dwie niepotrzebne paczki, które generowały tę zależność.

Ostatnio edytowany przez Kx_liner (2018-08-26 09:45:14)


Używam środowiska Plazma + Lenovo ThinkPad T520 Intel Core i5

Offline

#6 2018-08-26 09:47:22

pavbaranov
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-22
Liczba postów: 1,661
WWW

Odp: Błąd w aktualizacji phonon-qt4 Rozwiązany

Kurcze, nie to nie jest "takie w koło Macieju", ale w końcu należałoby się nauczyć używać podstawowego narzędzia w Archu, jakim jest pacman.
Nie usuniesz komendą pacman -Rns phonon-qt4 wraz z paczkami, które od niego zależą. Musisz użyć albo tej komendy i "dorzucić" do niej paczki zależne od phonon-qt4, albo użyć np:

pacman -Rcns phonon-qt4

(uwaga z tym Rcns, bo usunie to kaskadowo zależności, czyli innymi słowy patrz co dokładnie ta komenda chce Ci zrobić; jeśli żadna paczka w Twoim systemie nie jest zależna od kdelibs, phonon-qt4-gstreamer i phonon-qt4, to po prostu zostaną usunięte te trzy; jeśli coś jest jeszcze zależne, to pojawią się w usuwanych paczkach; jeśli są jakieś paczki, które mają je w opcjonalnych, to pojawi się o tym ostrzeżenie).


Hardware: AMD: A8-7410 APU with Radeon R5
Software (podaję wyłącznie odrębności): Arch testing+kde-unstable, kernel linux-pb (4.19.8 m.in. PDS, UKSM, BFQ-MQ/SQ), amdgpu (dla CIK), KDE, patche z POLAUR

Offline

#7 2018-08-26 09:50:20

Kx_liner
Użytkownik
Data rejestracji: 2015-10-25
Liczba postów: 152

Odp: Błąd w aktualizacji phonon-qt4 Rozwiązany

Masz jak zwykle rację, ale ja postąpiłem ostrożnie, sprawdzając zależności i dochodząc w końcu do sedna.


Używam środowiska Plazma + Lenovo ThinkPad T520 Intel Core i5

Offline

Stopka

Napędzają nas PacmanVPS i MegiTeam

Forum oparte na FluxBB