Nie jesteś zalogowany na forum.

#1 2018-05-29 10:50:31

pavbaranov
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-22
Liczba postów: 1,661
WWW

Pacman 5.1.0

Od wczoraj pacman pojawił się w nowej wersji 5.1.0. Lista zmian jest dostępna tutaj: https://git.archlinux.org/pacman.git/tree/NEWS#n3.  Proszę zwrócić uwagę, że część programów, jakie do tej pory było zawartych w pacman 5.0 zostało wyłączonych do odrębnej paczki pacman-contib (zob.: https://git.archlinux.org/pacman-contri … /README.md. Jeśli ktoś zatem potrzebuje takich narzędzi jak np. updpkgsums, rankmirrors, czy paccache, to winien zainstalować tę paczkę. Jak już też wiemy pacman-optimize nie jest już poleceniem dostępnym czy to wraz z paczką pacman, czy pacman-contrib.

Jednocześnie, jeśli ktokolwiek z Was używa jakichkolwiek tzw. AUR-helperów lub też innych nakładek na pacmana, to może się spodziewać, że część z nich (bodaj korzystająca z libalpm) przestanie działać. Dotyczy to na pewno popularnych narzędzi jak yaourt, pamac, octopi, czy pkgbrowser (pewnie jeszcze jakichś innych). Programy te muszą zostać zaktualizowane (np. pamac ma już nową wersję) lub przebudowane. W przypadku octopi udostępniłem dwie wersje budowane z GIT w POLAUR (zob.: https://forum.archlinux.org.pl/viewtopi … 4271#p4271); przypominam, że w tym przypadku przebudowana winna zostać również paczka alpm_octopi_utils. Jeśli ktoś używa ostatniej, stabilnej wersji octopi i chciałby odpowiedni PKGBUILD (wymaga patcha, bo inaczej nie zbuduje się na Qt5.11), to wiadomo gdzie to zgłosić (chyba, że wcześniej udostępnię). Jeśli chodzi o pkgbrowser, to jak się wydaje, wystarcza zwykłe przebudowanie paczki.

Przypominam też, że popularny pacaur nie jest już nadal rozwijany (zob.: https://github.com/rmarquis/pacaur) i raczej w tym przypadku nie można będzie liczyć na jakiekolwiek jego dostosowanie do nowej wersji pacmana; czas znaleźć inne rozwiązanie (np. trizen).


Hardware: AMD: A8-7410 APU with Radeon R5
Software (podaję wyłącznie odrębności): Arch testing+kde-unstable, kernel linux-pb (4.19.8 m.in. PDS, UKSM, BFQ-MQ/SQ), amdgpu (dla CIK), KDE, patche z POLAUR

Offline

#2 2018-05-29 12:22:35

Viperoo
Użytkownik
Data rejestracji: 2015-08-31
Liczba postów: 39
WWW

Odp: Pacman 5.1.0

Yay działa


blog.szmijewski.pl

Offline

#3 2018-05-29 15:11:32

nycko
Użytkownik
Data rejestracji: 2015-10-31
Liczba postów: 32
WWW

Odp: Pacman 5.1.0

pacaur też działa po przebudowaniu, chociaż nie polecam ;)

Offline

#4 2018-05-29 16:04:49

pavbaranov
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-22
Liczba postów: 1,661
WWW

Odp: Pacman 5.1.0

W AUR zaczęły się pojawiać już nowe wersje paczek do przebudowania, m.in. pkgbrowser.


Hardware: AMD: A8-7410 APU with Radeon R5
Software (podaję wyłącznie odrębności): Arch testing+kde-unstable, kernel linux-pb (4.19.8 m.in. PDS, UKSM, BFQ-MQ/SQ), amdgpu (dla CIK), KDE, patche z POLAUR

Offline

Stopka

Napędzają nas PacmanVPS i MegiTeam

Forum oparte na FluxBB