Nie jesteś zalogowany na forum.

#1 2018-02-24 07:14:36

EROSMRW
Użytkownik
Data rejestracji: 2018-02-24
Liczba postów: 6

Strasznie długi czas ładowania systemu

Witam serdecznie,
Mam problem. Od jakiegoś czasu (w sumie nie wiem już od kiedy) strasznie wydłużył mi się czas ładowania systemu. To nawet nie kwestia jednej usługi, ale wszystkich. Ponadto poniższe wartości uzyskane są nadysku SSD :/ :

$ analyze
Startup finished in 3.093s (kernel) + 20.190s (initrd) + 1min 28.207s (userspace) = 1min 51.492s
graphical.target reached after 39.688s in userspace
$ analyze blame
         48.623s org.cups.cupsd.service
         48.237s tlp.service
         48.219s polkit.service
         47.960s colord.service
         38.400s upower.service
         38.044s NetworkManager.service
           683ms lvm2-monitor.service
           465ms initrd-switch-root.service
           448ms dev-sda2.device
           204ms bluetooth.service
           198ms nftables.service
           194ms cpupower.service
           188ms accounts-daemon.service
           184ms alsa-restore.service
           169ms systemd-modules-load.service
           135ms systemd-udev-trigger.service
           132ms systemd-rfkill.service
           119ms systemd-fsck-root.service
           113ms systemd-timesyncd.service
           102ms udisks2.service
            90ms systemd-logind.service
            87ms [email protected]
            67ms systemd-udevd.service
            67ms [email protected]
            64ms initrd-parse-etc.service
            60ms systemd-journal-flush.service
            59ms [email protected]
            57ms kmod-static-nodes.service
            57ms dev-hugepages.mount
            54ms systemd-tmpfiles-clean.service
            51ms [email protected]
            48ms wpa_supplicant.service
            43ms dev-mqueue.mount
            43ms systemd-journald.service
            38ms systemd-binfmt.service
            35ms gdm.service
            35ms systemd-remount-fs.service
            31ms systemd-tmpfiles-setup-dev.service
            27ms systemd-tmpfiles-setup.service
            25ms initrd-cleanup.service
            21ms [email protected]:intel_backlight.service
            20ms sys-kernel-debug.mount
            17ms var.mount
            14ms systemd-sysctl.service
            14ms boot.mount
            13ms sys-fs-fuse-connections.mount

Będę wdzięczny za pomoc.
Proszę podajcie, jakie informacje potrzebujecie.

Offline

#2 2018-02-24 08:51:05

barthalion
Developer
Lokalizacja: Poznań
Data rejestracji: 2015-08-20
Liczba postów: 225
WWW

Odp: Strasznie długi czas ładowania systemu

systemd-analyze critical-chain
systemd-analyze plot

Offline

#3 2018-02-24 09:29:46

pavbaranov
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-22
Liczba postów: 2,029
WWW

Odp: Strasznie długi czas ładowania systemu

A ja mam jeszcze pytanie: jakiego kernela używasz oraz czy na innym jest tak samo?


Hardware: AMD: A8-7410 APU with Radeon R5; Arch testing+kde-unstable, kernel linux-pb, KDE+poprawki
https://deviantart.com/pavbaranov/ https://pavbaranov.blogspot.com https://linux-pavbaranov.blogspot.com

Offline

#4 2018-02-24 11:14:50

Viperoo
Użytkownik
Data rejestracji: 2015-08-31
Liczba postów: 39
WWW

Odp: Strasznie długi czas ładowania systemu

38.044s NetworkManager.service

Obstawiam że to jest problemem, korzystasz z neta po kablu czy wifi?


blog.szmijewski.pl

Offline

#5 2018-02-24 11:35:43

EROSMRW
Użytkownik
Data rejestracji: 2018-02-24
Liczba postów: 6

Odp: Strasznie długi czas ładowania systemu

Już odpowiadam. :)

$ systemd-analyze critical-chain
The time after the unit is active or started is printed after the "@" character.
The time the unit takes to start is printed after the "+" character.

graphical.target @2.183s
└─upower.service @1.381s +801ms
  └─basic.target @1.366s
    └─sockets.target @1.366s
      └─dbus.socket @1.366s
        └─sysinit.target @1.357s
          └─systemd-update-done.service @1.345s +11ms
            └─ldconfig.service @1.053s +290ms
              └─local-fs.target @1.051s
                └─run-user-120.mount @40.407s
                  └─local-fs-pre.target @979ms
                    └─lvm2-monitor.service @289ms +690ms
                      └─lvm2-lvmetad.service @362ms
                        └─lvm2-lvmetad.socket @288ms
                          └─system.slice
                            └─-.slice

https://megawrzuta.pl/download/6981d94f … 2a099.html

Używam archowego oficjalnego jądra bez modyfikacji. Jeżeli chodzi o sieć, to korzystam z neta po kablu, ale wifi mam ciągle włączone - często odłączam kabel.

Offline

#6 2018-02-24 12:52:56

barthalion
Developer
Lokalizacja: Poznań
Data rejestracji: 2015-08-20
Liczba postów: 225
WWW

Odp: Strasznie długi czas ładowania systemu

Sprawdź, czy z wyłączonym gdm coś się poprawi. (Jeśli tak, będziemy myśleć co mu tyle zajmuje.)

Offline

#7 2018-02-24 14:03:35

EROSMRW
Użytkownik
Data rejestracji: 2018-02-24
Liczba postów: 6

Odp: Strasznie długi czas ładowania systemu

Przy wyłączonym gdm to samo.

[~] lukasz > analyze
Startup finished in 3.097s (kernel) + 20.108s (initrd) + 50.631s (userspace) = 1min 13.838s
graphical.target reached after 2.011s in userspace
[~] lukasz > analyze blame
         48.987s tlp.service
         29.458s org.cups.cupsd.service
           718ms upower.service
           586ms lvm2-monitor.service
           482ms initrd-switch-root.service
           429ms dev-sda2.device
           279ms NetworkManager.service
           216ms polkit.service
           189ms systemd-modules-load.service
           146ms nftables.service
           137ms systemd-udev-trigger.service
           134ms bluetooth.service
           130ms cpupower.service
           109ms systemd-logind.service
           101ms udisks2.service
            95ms systemd-hostnamed.service
            76ms systemd-udevd.service
            76ms systemd-timesyncd.service
            68ms systemd-localed.service
            66ms [email protected]
            65ms systemd-journal-flush.service
            61ms initrd-parse-etc.service
            56ms colord.service
            51ms alsa-restore.service

Offline

#8 2018-02-24 15:20:02

pavbaranov
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-22
Liczba postów: 2,029
WWW

Odp: Strasznie długi czas ładowania systemu

Dwa procesy robią swoje: tlp i cups.
Na drugi - być może mam pomysł (rozumiem, że uruchamiasz tego laptopa bez podłączonej fizycznie drukarki):

sudo systemctl disable org.cups.cupsd.service && sudo systemctl enable org.cups.cupsd.socket

To powinno dawać możliwość drukowania po podłączeniu drukarki, a system nie szuka jej bez sensu przy starcie, gdy jej nie ma.


Hardware: AMD: A8-7410 APU with Radeon R5; Arch testing+kde-unstable, kernel linux-pb, KDE+poprawki
https://deviantart.com/pavbaranov/ https://pavbaranov.blogspot.com https://linux-pavbaranov.blogspot.com

Offline

#9 2018-02-24 15:26:52

EROSMRW
Użytkownik
Data rejestracji: 2018-02-24
Liczba postów: 6

Odp: Strasznie długi czas ładowania systemu

tlp wyłączyłem i nic.
Co do drukarki to mam ją połączoną po sieci - nie jest bezpośrednio połączona z laptopem. Zaraz sprawdzę czy powyższe polecenie pomoże.

-------------------------
Aktualizacja:
tlp wyłączone, cups wyłączony, a w ich miejsce wskoczyły inne usługi i czas ładowania ten sam czyli powyżej minuty. Dziwna sprawa. Teraz to są upower i NetworkManager.

Ostatnio edytowany przez EROSMRW (2018-02-24 16:07:55)

Offline

#10 2018-02-25 07:32:29

pavbaranov
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-22
Liczba postów: 2,029
WWW

Odp: Strasznie długi czas ładowania systemu

Ok, nie niem czy to dobry trop, ale coś mi się przypomniało. Spróbuj wyłączyć podnoszenie sieci WIFI przy starcie systemu. Jeśli wróci do normy, to chyba wiem, gdzie problem.


Hardware: AMD: A8-7410 APU with Radeon R5; Arch testing+kde-unstable, kernel linux-pb, KDE+poprawki
https://deviantart.com/pavbaranov/ https://pavbaranov.blogspot.com https://linux-pavbaranov.blogspot.com

Offline

#11 2018-02-25 09:24:16

EROSMRW
Użytkownik
Data rejestracji: 2018-02-24
Liczba postów: 6

Odp: Strasznie długi czas ładowania systemu

Niestety, wyłączenie Wifi nie pomogło. Natomiast wyłączenie upower i tlp spowodowało, że userspace wyniósł już 2 sekundy. Jest lepiej. Ciekawi mnie natomiast to że kernel i initrd są wyższe niż były. Jeszcze nie tak dawno ( z ok miesiąc temu ) było 7-8 sekund zamiast 24.

[~] lukasz > analyze
Startup finished in 3.095s (kernel) + 20.177s (initrd) + 1.685s (userspace) = 24.958s
graphical.target reached after 1.684s in userspace

[~] lukasz > analyze blame
         28.729s wpa_supplicant.service
           603ms lvm2-monitor.service
           465ms initrd-switch-root.service
           457ms dev-sda2.device
           276ms NetworkManager.service
           227ms upower.service
           170ms systemd-modules-load.service
           160ms accounts-daemon.service
           140ms systemd-udev-trigger.service
           111ms nftables.service
           107ms polkit.service
           102ms udisks2.service
            84ms systemd-localed.service
            81ms systemd-timesyncd.service
            71ms [email protected]
            67ms systemd-udevd.service
            67ms systemd-logind.service
            66ms org.cups.cupsd.service
            63ms initrd-parse-etc.service
            61ms systemd-binfmt.service
            59ms kmod-static-nodes.service
            59ms systemd-journal-flush.service
            53ms systemd-hostnamed.service
            52ms [email protected]

Ostatnio edytowany przez EROSMRW (2018-02-25 09:26:00)

Offline

#12 2018-02-25 23:27:14

marcin82
Moderator
Lokalizacja: Sosnowiec
Data rejestracji: 2015-08-20
Liczba postów: 178

Odp: Strasznie długi czas ładowania systemu

Pokaż jeszcze wynik:

dmesg | grep -iE 'error|warning|failed'

Zainstaluj pakiet smartmontools, włącz usługę:

systemctl enable smartd
systemctl start smartd

Potem pokaż - masz jeden dysk twardy czy więcej?

smartctl -a /dev/sda

Nie mam SSD, ale zobaczymy co pokaże SMART.


marcin82

Offline

#13 2018-02-27 17:46:36

EROSMRW
Użytkownik
Data rejestracji: 2018-02-24
Liczba postów: 6

Odp: Strasznie długi czas ładowania systemu

Przepraszam za przerwę. Miałem nieoczekiwany wyjazd.

Przedstawiam wynik 1 polecenia:

[    0.142107] acpi PNP0A08:00: _OSC failed (AE_ERROR); disabling ASPM
[    0.278992] pci 0000:01:00.0: BAR 6: failed to assign [mem size 0x00080000 pref]
[    1.481035] pci 0000:00:1a.0: EHCI: BIOS handoff failed (BIOS bug?) 01010001
[    2.681037] pci 0000:00:1d.0: EHCI: BIOS handoff failed (BIOS bug?) 01010001
[    3.053368] RAS: Correctable Errors collector initialized.
[    4.320545] ata1.01: failed to IDENTIFY (I/O error, err_mask=0x2)
[    9.904107] ata2.00: failed to resume link (SControl 0)
[   10.497101] ata1.01: failed to IDENTIFY (I/O error, err_mask=0x2)
[   16.256099] ata2.01: failed to resume link (SControl 0)
[   25.864097] ata1.00: SRST failed (errno=-16)
[   26.665076] ata1.01: failed to IDENTIFY (I/O error, err_mask=0x2)
[   33.664877] ACPI Warning: SystemIO range 0x0000000000000428-0x000000000000042F conflicts with OpRegion 0x0000000000000400-0x000000000000047F (\PMIO) (20170831/utaddress-247)
[   33.664892] ACPI Warning: SystemIO range 0x0000000000000540-0x000000000000054F conflicts with OpRegion 0x0000000000000500-0x0000000000000563 (\GPIO) (20170831/utaddress-247)
[   33.664897] ACPI Warning: SystemIO range 0x0000000000000540-0x000000000000054F conflicts with OpRegion 0x0000000000000500-0x000000000000055F (\_SB.PCI0.PEG0.PEGP.GPIO) (20170831/utaddress-247)
[   33.664903] ACPI Warning: SystemIO range 0x0000000000000530-0x000000000000053F conflicts with OpRegion 0x0000000000000500-0x0000000000000563 (\GPIO) (20170831/utaddress-247)
[   33.664907] ACPI Warning: SystemIO range 0x0000000000000530-0x000000000000053F conflicts with OpRegion 0x0000000000000500-0x000000000000055F (\_SB.PCI0.PEG0.PEGP.GPIO) (20170831/utaddress-247)
[   33.664912] ACPI Warning: SystemIO range 0x0000000000000500-0x000000000000052F conflicts with OpRegion 0x0000000000000500-0x0000000000000563 (\GPIO) (20170831/utaddress-247)
[   33.664916] ACPI Warning: SystemIO range 0x0000000000000500-0x000000000000052F conflicts with OpRegion 0x0000000000000500-0x000000000000055F (\_SB.PCI0.PEG0.PEGP.GPIO) (20170831/utaddress-247)
[   34.128248] platform regulatory.0: Direct firmware load for regulatory.db failed with error -2
[   34.128250] cfg80211: failed to load regulatory.db
[   34.324575] ACPI Warning: \_SB.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20170831/nsarguments-100)
[   35.239162] ata1.01: SError: { HostInt 10B8B }
[   36.038452] ata1.01: failed to IDENTIFY (I/O error, err_mask=0x2)
[   39.971100] usb 1-1.3: device descriptor read/64, error -110
[   47.584115] ata1.01: failed to IDENTIFY (I/O error, err_mask=0x4)
[   48.382433] ata1.01: failed to IDENTIFY (I/O error, err_mask=0x2)
[   51.072104] usb 1-1.3: device not accepting address 7, error -32
[   54.524150] ata1.01: SError: { HostInt 10B8B }
[   55.321101] ata1.01: failed to IDENTIFY (I/O error, err_mask=0x2)
[   61.185073] ata1.01: failed to IDENTIFY (I/O error, err_mask=0x2)
[   72.672118] ata1.01: failed to IDENTIFY (I/O error, err_mask=0x4)
[   82.696100] ata1.00: SRST failed (errno=-16)
[   83.480134] ata1.01: SError: { HostInt 10B8B }
[   84.281115] ata1.01: failed to IDENTIFY (I/O error, err_mask=0x2)
[   90.369118] ata1.01: failed to IDENTIFY (I/O error, err_mask=0x2)
[   96.512234] ata1.01: failed to IDENTIFY (I/O error, err_mask=0x2)

Wynik 2 polecenia:

=== START OF INFORMATION SECTION ===
Device Model:     SPCC Solid State Disk
Serial Number:    A46207710BCB00119304
LU WWN Device Id: 5 000000 000000000
Firmware Version: SBFM71.0
User Capacity:    120,034,123,776 bytes [120 GB]
Sector Size:      512 bytes logical/physical
Rotation Rate:    Solid State Device
Form Factor:      2.5 inches
Device is:        Not in smartctl database [for details use: -P showall]
ATA Version is:   ACS-4 (minor revision not indicated)
SATA Version is:  SATA 3.2, 6.0 Gb/s (current: 6.0 Gb/s)
Local Time is:    Tue Feb 27 17:45:26 2018 CET
SMART support is: Available - device has SMART capability.
SMART support is: Enabled

=== START OF READ SMART DATA SECTION ===
SMART overall-health self-assessment test result: PASSED

General SMART Values:
Offline data collection status:  (0x00)	Offline data collection activity
					was never started.
					Auto Offline Data Collection: Disabled.
Self-test execution status:      (   0)	The previous self-test routine completed
					without error or no self-test has ever 
					been run.
Total time to complete Offline 
data collection: 		(65535) seconds.
Offline data collection
capabilities: 			 (0x79) SMART execute Offline immediate.
					No Auto Offline data collection support.
					Suspend Offline collection upon new
					command.
					Offline surface scan supported.
					Self-test supported.
					Conveyance Self-test supported.
					Selective Self-test supported.
SMART capabilities:            (0x0003)	Saves SMART data before entering
					power-saving mode.
					Supports SMART auto save timer.
Error logging capability:        (0x01)	Error logging supported.
					General Purpose Logging supported.
Short self-test routine 
recommended polling time: 	 (   2) minutes.
Extended self-test routine
recommended polling time: 	 (  30) minutes.
Conveyance self-test routine
recommended polling time: 	 (   6) minutes.

SMART Attributes Data Structure revision number: 16
Vendor Specific SMART Attributes with Thresholds:
ID# ATTRIBUTE_NAME          FLAG     VALUE WORST THRESH TYPE      UPDATED  WHEN_FAILED RAW_VALUE
  1 Raw_Read_Error_Rate     0x000b   100   100   050    Pre-fail  Always       -       0
  9 Power_On_Hours          0x0012   100   100   000    Old_age   Always       -       3347
 12 Power_Cycle_Count       0x0012   100   100   000    Old_age   Always       -       855
168 Unknown_Attribute       0x0012   100   100   000    Old_age   Always       -       0
170 Unknown_Attribute       0x0003   088   088   010    Pre-fail  Always       -       4294967359
173 Unknown_Attribute       0x0012   100   100   000    Old_age   Always       -       1769525
192 Power-Off_Retract_Count 0x0012   100   100   000    Old_age   Always       -       68
194 Temperature_Celsius     0x0023   067   067   000    Pre-fail  Always       -       33 (Min/Max 33/33)
218 Unknown_Attribute       0x000b   100   100   050    Pre-fail  Always       -       0
231 Temperature_Celsius     0x0013   100   100   000    Pre-fail  Always       -       97
241 Total_LBAs_Written      0x0012   100   100   000    Old_age   Always       -       2862

SMART Error Log Version: 1
No Errors Logged

SMART Self-test log structure revision number 1
No self-tests have been logged.  [To run self-tests, use: smartctl -t]

SMART Selective self-test log data structure revision number 0
Note: revision number not 1 implies that no selective self-test has ever been run
 SPAN  MIN_LBA  MAX_LBA  CURRENT_TEST_STATUS
    1        0        0  Not_testing
    2        0        0  Not_testing
    3        0        0  Not_testing
    4        0        0  Not_testing
    5        0        0  Not_testing
Selective self-test flags (0x0):
  After scanning selected spans, do NOT read-scan remainder of disk.
If Selective self-test is pending on power-up, resume after 0 minute delay.

Offline

#14 2018-02-27 19:34:17

pavbaranov
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-22
Liczba postów: 2,029
WWW

Odp: Strasznie długi czas ładowania systemu

Zmień kernel na np. LTS i spróbuj.


Hardware: AMD: A8-7410 APU with Radeon R5; Arch testing+kde-unstable, kernel linux-pb, KDE+poprawki
https://deviantart.com/pavbaranov/ https://pavbaranov.blogspot.com https://linux-pavbaranov.blogspot.com

Offline

Stopka

Forum oparte na FluxBB