Nie jesteś zalogowany na forum.

#1 2018-02-17 10:51:03

pavbaranov
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-22
Liczba postów: 1,657
WWW

Repozytorium PKGBUILDów

Pragniemy poinformować, że od wczoraj udostępniliśmy repozytorium PKGBUILDów, które z jakichś przyczyn nie są przez nas umieszczane w AUR. Te z nich, które uzyskają jakąś popularność i jednocześnie nie będą kolidować z polityką Archa być może zostaną umieszczone również (bądź przeniesione) do AUR. Niemniej jednak część z tych paczek w ogóle nie ma szans, by tam się znaleźć.
Dotyczy to głównie, ale nie wyłącznie, repozytorium repo-refreshed gdzie będą umieszczane PKGBUILDy aplikacji, które znajdują się w oficjalnych repozytoriach Archa, a uzupełnione o jakieś patche z wersji rozwojowych (chodzi o np. poprawki błędów, które są przeznaczone do następnych wersji czy dodania jakichś funkcjonalności, które w takich wersjach mogą, ale nie muszą się znaleźć). Te nigdy nie trafią do AUR. Jeśli ktoś się zdecyduje na ich użytkowanie, to czyni to na własne ryzyko. W przypadku zaobserwowania błędnego działania tak zbudowanej paczki, czy błędnego działania środowiska itp. w pierwszej kolejności zalecamy powrócenie oryginalnej paczki z repozytorium. Nawet jeśli system będzie działać, to w przypadku przedstawiania problemów na forum prosimy o zamieszczanie informacji, że korzystacie z paczki zbudowanej z tego repozytorium.

Krótka charakterystyka repozytoriów:
1. AUR-rebased
Tutaj trafiają PKGBUILDy aplikacji, które znajdują się w AUR, ale które są udostępniane z jakimiś zmianami w stosunku do nich. Mogą to być np. inaczej budowane wersje (choćby budowane na Qt5, a nie Qt4), wersje z jakimiś usprawnieniami (np. dodana opcja kompilacji "pod dany procesor"), czy dodatkami (np. jakieś pluginy, tematy, czy lokalizacje). Będziemy się starać, by paczki tak budowane różniły się nazwą od tych, które są w AUR i - albo umożliwiały koegzystencję takich aplikacji, albo instalowały się w zamian aplikacji z AUR.

2. repo-refreshed
Jak już wspomniałem - tu trafiają "odmienione" paczki tego, co znajduje się w oficjalnych repozytoriach Archa, ale uzupełnione o coś. Będą to na przykład poprawki, które już są dostępne, ale przeznaczone do następnych wydań (poprawkowych lub głównych), a nawet uzupełniane o pewne funkcjonalności, które nie wiadomo, czy i kiedy trafią do wydania oficjalnego. W przypadku tych paczek proszę pamiętać, że numeracja przez nas stosowana będzie się różnić w stosunku do oficjalnej jedynie tzw. pkgrel, które w przypadku pojawienia się nowej wersji paczki w repozytorium Archa zawsze spowoduje aktualizację paczki z repo-refreshed do wersji z oficjalnych repozytoriów. (Np. znajdująca się tam wersja kwin ma numer 5.12.1-2.1 i w przypadku, gdy pojawi się zarówno wersja 5.12.1-3, jak i wersja 5.12.2 czy 5.13.0, to paczka zbudowana z tego repozytorium zostanie zaktualizowana do tych właśnie wersji). W takim przypadku w "naszym" repozytorium pojawi się nowa wersja, która - jeśli ktoś będzie chciał zachować poprzednią funkcjonalność - będzie musiała zostać znów zbudowana. Oczywiście nowe wersje pojawią się tu wyłącznie wówczas, gdy będzie to miało sens, czyli przede wszystkim, gdy nowa wersja dostępna w repozytoriach oficjalnych nie inkorporuje również patchy, które nakładamy. Nowe wersje pojawią się również tylko wówczas, jeśli będą dawały się jeszcze budować oraz - przynajmniej wg naszych testów (wszak mamy dość skromne możliwości ich przeprowadzania) - nie będą sprawiać problemów w systemie. Jeśli zatem nowa paczka w tym repozytorium nie pojawi się wkrótce po aktualizacji paczek z oficjalnego repozytorium, to najprawdopodobniej tak właśnie ma być (ale proszę ewentualnie pytać). Paczki budowane z repo-refreshed proszę traktować jako eksperymentalne. W żadnym wypadku nie wolno ich dodawać do paczek ignorowanych przy aktualizacji.
Jeśli zastanawiacie się w ogóle po co tego typu paczki umieszczamy, to robimy to albo dlatego, że sami takich używamy, albo (i chyba przede wszystkim) bowiem ktoś na taką paczkę wyraził zapotrzebowanie.

3. new-branded
To repozytorium przeznaczone dla aplikacji, których nie ma ani w repozytorium, ani w AUR. Mają największą szansę znaleźć się w AUR i prawdopodobnie gdy tego typu zgłoszenia będą występować, to tak się stanie. Jeśli przy budowie paczki otrzymacie informację, że jakiejś zależności makepkg nie może znaleźć, to wówczas proszę sprawdzić, czy nie ma jej w AUR bądź w tym właśnie repozytorium.

4. recompilated
Jak na razie takie repozytorium istnieje, ale nie wiemy, czy będzie istnieć zawsze. Tutaj umieszczane będą głównie PKGBUILDy umożliwiające "przerobienie" aplikacji, które dostępne są w wersjach binarnych do formatu paczek obsługiwanego przez pacman.

5. pkg-trunk
Tutaj będą umieszczane PKGBUILD wyłącznie! dla osób testujących programy i wyłącznie dla osób, które wiedzą co robią i w dużej mierze będą sobie w stanie poradzić z jakimiś błędami, które mogą pojawić się w związku z ich używaniem (choćby tak proste rzeczy, jak umiejętność przywrócenia oryginalnych wersji z repozytorium bez konieczności używania sesji graficznej itp.). Paczki budowane z tego repozytorium należy traktować jako eksperymentalne.
Będą tu umieszczane wczesne wersje (alpha, beta), wersje kandydujące (RC) itp. Tutaj też, a nie w repo-refreshed będziemy umieszczać PKGBUILDy paczek znajdujących się w takich repozytoriach Archa jak kde-unstable czy gnome-unstable uzupełnione o patche z GIT, które łatają jakieś problemy uwidocznione w fazie testowania tych programów.
Niektóre z nich (jak przykładowo kf5-rc1) będą składać się z wielu PKGBUILDów, które będą - niekiedy - musiały być budowane i instalowane w określonej kolejności. Niekiedy też będą one wymagać udostępnienia systemowi repozytoriów testing; zostaniecie o tym powiadomieni. Proszę śledzić informacje na forum, albowiem tutaj będziemy podawać sposób ich budowania. Podobnie jak w przypadku repozytorium repo-refreshed w przypadku używania takich paczek w systemie prosimy o bezwględne informowanie o tym przy zgłaszaniu jakichkolwiek problemów z funkcjonowaniem systemu. W takim przypadku też, pierwszej kolejności zalecamy "powrót" do oryginalnych paczek dostępnych w repozytoriach.

Raz jeszcze: programy budowane głównie z repozytoriów repo-refreshed oraz pkg-build należy traktować jako eksperymentalne. Mogą one być niestabilne lub wywoływać niestabilności systemu włącznie z brakiem możliwości jego uruchomienia. Są przez nas zamieszczane wyłącznie dla zaawansowanych użytkowników, którzy chcą się przyczynić do ich rozwoju, choćby przez wdrożenie się do testów i sygnalizowanie błędów twórcom tych programów na wczesnych fazach ich rozwoju.

Oczywiście nie ograniczamy się wyłącznie do umieszczania PKGBUILDów, które sami tworzymy na własne potrzeby, ale jesteśmy otwarci na Wasze propozycje, które prosimy umieszczać w wątku: https://forum.archlinux.org.pl/viewtopic.php?id=245 lub https://forum.archlinux.org.pl/viewtopic.php?id=614. Możecie również skorzystać z opcji github "pull requests".

Wszelkie uwagi do PKGBUILDów i działania paczek budowanych z tych repozytoriów prosimy zgłaszać bądź tutaj na forum (ten dział) bądź bezpośrednio na github w "Issues".

Wszelkie paczki budowane z tych repozytoriów nie mają żadnego wsparcia ze strony Archa i jesteśmy wyłącznymi ich opiekunami i wyłącznie społeczność tego repozytorium za nie odpowiada oraz może udzielić jakiegokolwiek wsparcia. Raz jeszcze podkreślam - w przypadku zgłaszania jakichkolwiek problemów z systemem, w którym znajdować się będą paczki budowane w oparciu o PKGBUILDy z repozytoriów repo-refreshed oraz pkg-trunk proszę nas o tym informować.

I jeszcze informacja dla użytkowników Manjaro. Ogólnie - nie wspieramy. Repozytoria inne niż repo-refreshed oraz pkg-trunk winny tu być możliwe do wykorzystania. Paczki w dwu ostatnich dostępne mogą być w zasadzie wyłącznie dla użytkowników Manjaro Unstable.

EDIT:
Dodane zostało repozytorium highest-experimental - zob.: https://forum.archlinux.org.pl/viewtopi … 3966#p3966


Hardware: AMD: A8-7410 APU with Radeon R5
Software (podaję wyłącznie odrębności): Arch testing+kde-unstable, kernel linux-pb (4.19.8 m.in. PDS, UKSM, BFQ-MQ/SQ), amdgpu (dla CIK), KDE, patche z POLAUR

Offline

#2 2018-02-18 12:26:24

pavbaranov
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-22
Liczba postów: 1,657
WWW

Odp: Repozytorium PKGBUILDów

Stan na 18.02.2018 r. Wszelkie programy budowane w wersjach "git" będą miały zmieniany PKGBUILD wyłącznie wówczas, gdy będzie tego wymagał kod, konieczność przebudowania lub konieczność wprowadzenia innych jakichś poprawek. Jeśli nie zostało napisane inaczej, to wszystkie programy są w ostatnich dostępnych wersjach.
1. AUR-rebased:
- qstopmotion-qt5 - budowany na Qt5, a nie na Qt4 jak w AUR

2. New-branded:
- breeze-rainbow-folders - zob.: https://kdeonlinux.wordpress.com/2016/0 … w-folders/
- gimagereader-qt5-git - wersja gImageReader budowana na Qt5 oraz bezpośrednio z GIT
- kooka-git - program typu OCR obecnie budowany na Qt5
- nomad-firewall-git - GUI do zapory sieciowej pochodzące z Nomad Desktop
- qtchat - program do czatu w sieci lokalnej - zob: https://github.com/zuzuf/qtchat
- simplelogin-git - bardzo prosty DM
- smaragd-git - silnik umożliwiający w Plasma obsługę tematów Emerald/Beryl
- swapusage - skrypt odczytujący użycie swap
- sylfilter - filtr antyspamowy
- psi-plus-full-git - psi-plus wraz z wbudowanymi pluginami (silnik Webengine)
- psi-plus-webkit-full-git - psi-plus wraz z wbudowanymi pluginami (silnik Webkit)

3. Repo-refreshed
- plasma-desktop - wersja 5.12.1 z następującymi patchami: kdebug-390428, D10485.patch, kdebug-370588, kdebug-390502, kdebug-390353, D10259 oraz enable-smooth-scaling-for-icon
- dolphin - wersja 17.12.2 z patchem CCBUG-342056
- kio - wersja 5.43 z patchami: kdebug-389595, kdebug-388887, kdebug-382437, CCBUG-384561, D10124, D10045
- kwin - wersja 5.12.1 z patchami: D9848, D10100, D10180, D10181, D10281 (to jest już 3 nasze wydanie)

Legenda: patche kdebug/KDEBUG odnoszą się do bugs.kde.org, patche DXXXXX - odnoszą się do phabricator.kde.org, inne są (a na pewno będą sukcesywnie) opisane w treści PKGBUILDów

18.02.2018 - dodane:
1. Repo-refreshed
- konsole - szereg patchy; obecne wydanie jest drugim dzisiejszym


Hardware: AMD: A8-7410 APU with Radeon R5
Software (podaję wyłącznie odrębności): Arch testing+kde-unstable, kernel linux-pb (4.19.8 m.in. PDS, UKSM, BFQ-MQ/SQ), amdgpu (dla CIK), KDE, patche z POLAUR

Offline

#3 2018-02-19 14:22:38

pavbaranov
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-22
Liczba postów: 1,657
WWW

Odp: Repozytorium PKGBUILDów

19.02.2018 - dodane, bądź zmienione:
1. Repo-refreshed
- ark - dodany bugfix
- kdeplasma-addons - dodane bugfiksy
- kio - kolejna wersja, dodane kolejne bugfiksy
- gwenview - dodane bugfiksy
- okular - dodane bugfiksy
- systemsettings - dodany bugfix (będzie w 5.12.2)

2. New-branded
- kdbg - zob.: https://www.opendesktop.org/s/Linux-Apps/p/1127159/

3. AUR-rebased
- crusta - zob.: http://www.crustabrowser.com/; nasza (obecna) wersja w odróżnieniu do AUR jest budowana z aktualnego "stable"


Hardware: AMD: A8-7410 APU with Radeon R5
Software (podaję wyłącznie odrębności): Arch testing+kde-unstable, kernel linux-pb (4.19.8 m.in. PDS, UKSM, BFQ-MQ/SQ), amdgpu (dla CIK), KDE, patche z POLAUR

Offline

#4 2018-02-19 17:21:39

sir_lucjan
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-20
Liczba postów: 839

Odp: Repozytorium PKGBUILDów

19.02.2018 - dodane, bądź zmienione:

1. Repo pkg-trunk
- linux-api-headers-experimental-git - linux-api-headers budowane z repozytorium stabilnego -  https://git.kernel.org/pub/scm/linux/ke … table.git/

- linux-api-headers-trunk-git - linux-api-headers budowane z repozytorium "stable-rc" - zawierającej wersję kandydującą do repozytorium stabilnego - https://git.kernel.org/pub/scm/linux/ke … le-rc.git/

- llvm-git - llvm budowane z mirroru https://github.com/llvm-mirror/llvm


Dell Inspiron 15-3542 (3542-2538) || Arch Linux || [linux-lucjan-git]
[AUR]  [GitHub]  [GitLab]

Offline

#5 2018-02-19 22:23:42

pavbaranov
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-22
Liczba postów: 1,657
WWW

Odp: Repozytorium PKGBUILDów

19.02.2018 - dodane:
1. Repo-refreshed
- plasma-workspace - bugfiksy


Hardware: AMD: A8-7410 APU with Radeon R5
Software (podaję wyłącznie odrębności): Arch testing+kde-unstable, kernel linux-pb (4.19.8 m.in. PDS, UKSM, BFQ-MQ/SQ), amdgpu (dla CIK), KDE, patche z POLAUR

Offline

#6 2018-02-20 10:25:52

barthalion
Developer
Lokalizacja: Poznań
Data rejestracji: 2015-08-20
Liczba postów: 219
WWW

Odp: Repozytorium PKGBUILDów

sir_lucjan napisał/a:

19.02.2018 - dodane, bądź zmienione:

1. Repo pkg-trunk
- linux-api-headers-experimental-git - linux-api-headers budowane z repozytorium stabilnego -  https://git.kernel.org/pub/scm/linux/ke … table.git/

- linux-api-headers-trunk-git - linux-api-headers budowane z repozytorium "stable-rc" - zawierającej wersję kandydującą do repozytorium stabilnego - https://git.kernel.org/pub/scm/linux/ke … le-rc.git/

A za 3, 2, 1, ktoś sobie strzeli w stopę, bo podbijanie linux-api-headers bez przebudowania toolchaina to strzelanie sobie w stopę.

Offline

#7 2018-02-20 14:12:42

sir_lucjan
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-20
Liczba postów: 839

Odp: Repozytorium PKGBUILDów

Dlatego paczkę umieściłem w pkg-trunk - a w opisie jest zawarte ostrzeżenie. W PKGBUILD również jest informacja o toolchainie.

Mogę to zawsze usunąć, jeśli to taki problem, jednakże uważam, że ostrzeżenie wystarczy.

Edit:

20.02.2018 - repozytorium highest-experimental

- przeniosłem linux-api-headers do specjalnie wydzielonego repozytorium, przeznaczonego na projekty bardzo eksperymentalne.

Repo highest-experimental przeznaczone będzie na PKGBUILDy w wersji eksperymentalnej, niestabilnej, przeznaczone wyłącznie dla osób mające odpowiednią wiedzę, by poradzić sobie w przypadku nieprawidłowego działania systemu. Jednym słowem, pkg-trunk na sterydach.


Dell Inspiron 15-3542 (3542-2538) || Arch Linux || [linux-lucjan-git]
[AUR]  [GitHub]  [GitLab]

Offline

#8 2018-02-20 23:01:09

pavbaranov
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-22
Liczba postów: 1,657
WWW

Odp: Repozytorium PKGBUILDów

20.02.2018
1. repo-refreshed
- kaffeine - dodane bugfiksy
- solid - dodane bugfiksy
- kactivities-stats - dodane bugfiksy
- kwindowsystem - dodane usprawnienia; UWAGA, by działało to tak jak zamierzone, polecane jest również zainstalowanie plasma-workspace 5.12.1-1.1 z naszego repozytorium.


Hardware: AMD: A8-7410 APU with Radeon R5
Software (podaję wyłącznie odrębności): Arch testing+kde-unstable, kernel linux-pb (4.19.8 m.in. PDS, UKSM, BFQ-MQ/SQ), amdgpu (dla CIK), KDE, patche z POLAUR

Offline

#9 2018-02-21 00:41:57

pavbaranov
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-22
Liczba postów: 1,657
WWW

Odp: Repozytorium PKGBUILDów

21.02.2018
1. repo-refreshed
- KIO - dodane bugfiksy
- kwin - dodane nowe "użyteczności" (D9638)


Hardware: AMD: A8-7410 APU with Radeon R5
Software (podaję wyłącznie odrębności): Arch testing+kde-unstable, kernel linux-pb (4.19.8 m.in. PDS, UKSM, BFQ-MQ/SQ), amdgpu (dla CIK), KDE, patche z POLAUR

Offline

#10 2018-02-21 00:44:23

sir_lucjan
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-20
Liczba postów: 839

Odp: Repozytorium PKGBUILDów

21.02.2018
1. repo new-branded

- psi-plus-clean-full-git - psi-plus-full-git pozbawione wsparcia webkit/webengine.


Dell Inspiron 15-3542 (3542-2538) || Arch Linux || [linux-lucjan-git]
[AUR]  [GitHub]  [GitLab]

Offline

#11 2018-02-21 01:34:52

pavbaranov
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-22
Liczba postów: 1,657
WWW

Odp: Repozytorium PKGBUILDów

21.02.2018
1. repo-refreshed
- plasma-workspace - przebudowane do wersji 5.12.2
- kwin - przebudowane do wersji 5.12.2
- systemsettings - usunięte (te same patche są w wersji w repozytorium oficjalnym)
- plasma-desktop - usunięte (te same patche są w wersji w repozytorium oficjalnym)
- kdeplasma-addons - usunięte (te same patche są w wersji w repozytorium oficjalnym)


Hardware: AMD: A8-7410 APU with Radeon R5
Software (podaję wyłącznie odrębności): Arch testing+kde-unstable, kernel linux-pb (4.19.8 m.in. PDS, UKSM, BFQ-MQ/SQ), amdgpu (dla CIK), KDE, patche z POLAUR

Offline

#12 2018-02-22 10:57:54

pavbaranov
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-22
Liczba postów: 1,657
WWW

Odp: Repozytorium PKGBUILDów

22.02.2018
1. Repozytorium new-branded
- clamav-av - nakładka na clamav w Qt5; proszę zwrócić uwagę, że jest to jedynie nakładka, wymaga również instalacji clamav, który jest opcjonalną zależnością (nie jest wymagany ani do budowy, ani do pracy "samego" GUI); autor prosi o dołączenie się w zakresie tłumaczenia programu - mam plik lokalizacyjny na język polski, ale nie jest w 100% ukończony, jeśli ktoś pragnąłby się dołączyć byłbym wdzięczny


Hardware: AMD: A8-7410 APU with Radeon R5
Software (podaję wyłącznie odrębności): Arch testing+kde-unstable, kernel linux-pb (4.19.8 m.in. PDS, UKSM, BFQ-MQ/SQ), amdgpu (dla CIK), KDE, patche z POLAUR

Offline

#13 2018-02-22 14:43:27

sir_lucjan
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-20
Liczba postów: 839

Odp: Repozytorium PKGBUILDów

W  kwestii tłumaczenia zgadamy się  na IRC bądź toksie.


Dell Inspiron 15-3542 (3542-2538) || Arch Linux || [linux-lucjan-git]
[AUR]  [GitHub]  [GitLab]

Offline

#14 2018-02-22 21:13:59

pavbaranov
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-22
Liczba postów: 1,657
WWW

Odp: Repozytorium PKGBUILDów

22.02.2018
1. repo-refreshed
- gwenvwiev - dodany nowy patch
- plasma-framework - dodane patche głównie służące optymalizacji pracy w środowisku Plazma


Hardware: AMD: A8-7410 APU with Radeon R5
Software (podaję wyłącznie odrębności): Arch testing+kde-unstable, kernel linux-pb (4.19.8 m.in. PDS, UKSM, BFQ-MQ/SQ), amdgpu (dla CIK), KDE, patche z POLAUR

Offline

#15 2018-02-23 16:46:14

pavbaranov
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-22
Liczba postów: 1,657
WWW

Odp: Repozytorium PKGBUILDów

23.02.2018
1. repo-refreshed
- plasma-framework
- plasma-workspace
W obu przypadkach optymalizacyjne patche. UWAGA: w fazie testów. Nie są jeszcze dodane jako planowane do żadnego wydania.


EDIT:
1. repo-refreshed:
- kio


Hardware: AMD: A8-7410 APU with Radeon R5
Software (podaję wyłącznie odrębności): Arch testing+kde-unstable, kernel linux-pb (4.19.8 m.in. PDS, UKSM, BFQ-MQ/SQ), amdgpu (dla CIK), KDE, patche z POLAUR

Offline

#16 2018-02-24 10:01:35

pavbaranov
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-22
Liczba postów: 1,657
WWW

Odp: Repozytorium PKGBUILDów

24.02.2018
1. new-branded
- kopete-git - to wersja dobrze znanego komunikatora, która jest kompletnie przebudowana i występuje tu w wersji opartej o KF5 obecnie budowana w sposób, gdzie opcjonalne zależności są "wbudowane" w program (np. wsparcie dla Gadu-Gadu) - być może to zmienię. UWAGA: nie mam starej wersji kopete - nie wiem, czy ta "przejmuje" oraz co przejmuje z tamtej wersji. Jeśli ktoś używa ostatniej, dostępnej (17.08.3 - z 17.12 wyleciała, albowiem nie była przeportowana do KF5) wersji, a chciałby spróbować tej, to proszę sobie zrobić kopię kontaktów itd.
2. repo-refreshed
- solid - usunięte, bowiem 5.43.0-2 jest tożsame z naszym

EDIT:
1. new-branded
- kopete-git - dzięki @slawul udało się usunąć pewne błędy, zatem nowe pkgrel
- ttf-nocturne
- rewir-fonts
- olympic-fonts
Trzy paczki z fontami otf i ttf (niech Was nie myli nazwa pierwszej - do zmiany pójdzie).


Hardware: AMD: A8-7410 APU with Radeon R5
Software (podaję wyłącznie odrębności): Arch testing+kde-unstable, kernel linux-pb (4.19.8 m.in. PDS, UKSM, BFQ-MQ/SQ), amdgpu (dla CIK), KDE, patche z POLAUR

Offline

#17 2018-02-25 08:22:59

pavbaranov
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-22
Liczba postów: 1,657
WWW

Odp: Repozytorium PKGBUILDów

Tym razem nie o paczkach. Jeśli ktoś napotyka jakieś problemy z naszymi PKBUILDami, to tymczasowo zapraszamy na któryś z kanałów na IRC: #archlinux.org.pl lub #archownia.pl. Niebawem uruchomimy prawdopodobnie też kanał dedykowany POLAUR jak również stworzymy jakąś listę mailingową lub coś podobnego.
Wszelka wasza pomoc, jak choćby zgłaszanie nam problemów z budowaniem paczek na podstawie naszych PKGBUILDów (choć staramy się, by były one poprawne, to wypadki się zdarzają) jest mile widziana.


Hardware: AMD: A8-7410 APU with Radeon R5
Software (podaję wyłącznie odrębności): Arch testing+kde-unstable, kernel linux-pb (4.19.8 m.in. PDS, UKSM, BFQ-MQ/SQ), amdgpu (dla CIK), KDE, patche z POLAUR

Offline

#18 2018-02-25 11:15:07

pavbaranov
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-22
Liczba postów: 1,657
WWW

Odp: Repozytorium PKGBUILDów

25.02.2018
1. repo-refreshed
- kapidox - patch na błąd: https://bugs.kde.org/show_bug.cgi?id=390904

EDIT1:
2. new-branded
- qtrsed-git - GUI dla sed. Więcej: https://www.opendesktop.org/s/Apps/p/1130808/ i sam doprawdy chciałbym wiedzieć jak to działa :)
- qtcmd2-git - w sumie jak mogło zabraknąć pracy naszego forumowego kolegi @piomiq - menedżer plików - więcej: http://qtcmd.nes.pl

EDIT2:
3. repo-refreshed
- kwin - dodane następne patche z nadchodzących wersji
- kate/kwrite - dodane patche z nadchodzącej wersji
- gwenview - dodane nowe patche z nadchodzącej wersji
- ark - dodane nowe patche z nadchodzącej wersji
- kwayland - dodane patche z 5.44
- okular - dodane nowe patche z nadchodzącej wersji

EDIT3:
4. repo-refreshed
- okular - dalsze bugfiksy

EDIT4:
5. repo-refreshed
- plasma-workspace - jeszcze jeden bugfix


Hardware: AMD: A8-7410 APU with Radeon R5
Software (podaję wyłącznie odrębności): Arch testing+kde-unstable, kernel linux-pb (4.19.8 m.in. PDS, UKSM, BFQ-MQ/SQ), amdgpu (dla CIK), KDE, patche z POLAUR

Offline

#19 2018-02-26 16:24:23

pavbaranov
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-22
Liczba postów: 1,657
WWW

Odp: Repozytorium PKGBUILDów

26.02.2018
1. repo-refreshed
- kxmlgui - dodany patch kdebug::373653

EDIT:
1. repo-refreshed
- kxmlgui - dodany patch kdebug::390623


Hardware: AMD: A8-7410 APU with Radeon R5
Software (podaję wyłącznie odrębności): Arch testing+kde-unstable, kernel linux-pb (4.19.8 m.in. PDS, UKSM, BFQ-MQ/SQ), amdgpu (dla CIK), KDE, patche z POLAUR

Offline

#20 2018-02-28 09:17:05

pavbaranov
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-22
Liczba postów: 1,657
WWW

Odp: Repozytorium PKGBUILDów

28.02.2018
1. new-branded
- CloudConnector - więcej: https://www.opendesktop.org/s/Apps/p/1128220/


Hardware: AMD: A8-7410 APU with Radeon R5
Software (podaję wyłącznie odrębności): Arch testing+kde-unstable, kernel linux-pb (4.19.8 m.in. PDS, UKSM, BFQ-MQ/SQ), amdgpu (dla CIK), KDE, patche z POLAUR

Offline

#21 2018-03-02 12:48:49

pavbaranov
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-22
Liczba postów: 1,657
WWW

Odp: Repozytorium PKGBUILDów

2.03.2018
1. aur-rebased
- falkon-git
I to wymaga nieco dłuższego wyjaśnienia. Dlaczego w ogóle, skoro jest w AUR? Najprościej - bowiem PKGBUILD w AUR jest obecnie już wadliwy. Żeby nie było kolizji pewnie zmienię nazwę "swojego", a najprawdopodobniej po prostu - po testach - podeślę nowy PKGBUILD opiekunowi w AUR.
Zasadnicze zmiany (pomijając doprowadzenie w ogóle do działania), to dodanie plików językowych (o tym jeszcze później), oraz wyłączenie GNOME keyring (sprawia problemy przy niektórych ustawieniach) oraz opcjonalne włączenie możliwości zbudowania paczki z umożliwieniem wykorzystywania nowych wtyczek dla Falkona.
-- paczka językowa jest obecnie ściągnięta z wersji stabilnej i dodana po prostu w źródłach; niestety nie wiem jeszcze gdzie się one znajdują, ale i tak nie ma to większego znaczenia, albowiem plik spolszczający został przeze mnie dość mocno zmieniony; usunąłem odwołania do QupZilli i w to miejsce są wstawione do Falkona oraz spolszczyłem znaczną część nieptrzetłumaczonych jeszcze fragmentów; jeśli ktoś chce korzystać w wersji stabilnej z tego tłumaczenia musi przebudować falkona dostępnego w repozytorium z użyciem mojego pliku językowego (zrobię PKGBUILD jeśli będzie takie życzenie),
-- włączenie funkcji eksperymentalnych; wymagają zbudowania dwu paczek z AUR shiboken2-git oraz pyside2-common-git (ta ostatnia buduje się stosunkowo długo); paczka python-pyside2-git jest budowana w jej ramach - niczego zatem nie trzeba jeszcze dodatkowo budować. Oprócz tego trzeba odkomentować w depends i makedepends to co opisane w PKGBUILD. UWAGA: paczki te muszą być zbudowane na tej samej wersji Qt5, co falkon - w przeciwnym razie kompilacja falkona nie jest możliwa. Także w przypadku zmiany wersji Qt (a nadchodzi 5.11) konieczne będzie przebudowanie wszystkich 3 paczek.
-- wyłączona funkcja GNOME keyring - być może to jest jakiś błąd programu, ale choć libgnome-keyring jest potrzebny przy kompilacji (jako makedepends), a potem stanowi już wyłącznie zależność opcjonalną, to zbudowanie programu w ten sposób powoduje, że po włączeniu wsparcia dla KWallet nie wiadomo dlaczego program pluje błędami związanymi z libgnome-keyring i w ogóle go szuka; postanowiłem wyłączyć, wychodząc z założenia, że Falkona będą raczej używać osoby, które korzystają z Plasma ewentualnie z innych środowisk opartych o Qt, gdzie libgnome-keyring w ogóle nie jest potrzebne.
PS: Paczka ta pewnie niebawem będzie ewoluować (np. CMakeLists.txt, które jest obecnie w źródłach zostanie zastąpione sedem, być może uda mi się dotrzeć do plików *.po, być może uda podrzucić moje tłumaczenie /po testach/).

EDIT:
2. new-branded
- plasma-theme-ktrans - po prostu wystrój dla Plazmy
3. wip
W katalogu translate jest katalog falkon, a w nim obecne tłumaczenie dla niego (z moimi poprawkami) - jeśli ktoś ma ochotę, to niech się zaktywzuje, bo trzeba je dokończyć.


Hardware: AMD: A8-7410 APU with Radeon R5
Software (podaję wyłącznie odrębności): Arch testing+kde-unstable, kernel linux-pb (4.19.8 m.in. PDS, UKSM, BFQ-MQ/SQ), amdgpu (dla CIK), KDE, patche z POLAUR

Offline

#22 2018-03-03 10:28:56

pavbaranov
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-22
Liczba postów: 1,657
WWW

Odp: Repozytorium PKGBUILDów

3.03.2018
1. new-branded
- elf-dissector-git: Program do przeglądania, analizy i optymalizacji plików ELF (zob.: https://pl.wikipedia.org/wiki/Executabl … ble_Format)

EDIT 1:
2. pkg-trunk
- KDE Frameworks 5.44rc1 (kf5rc) - tylko dla osób, które chcą się włączyć w testy nowej wersji frameworków; opis kolejności instalacji w how2build.txt; uwaga tym razem jest aż 5 katalogów, w których pomieszczone jest całe kf5 - zostały one podzielone na Tiery wg informacji zawartych metainfo; kolejność budowania można delikatnie zmienić, na co wskazują zależności wymienione w ww. pliku.
Więcej: http://linux-pavbaranov.blogspot.com/20 … terow.html

EDIT 2:
3. aur-rebased
- phototonic - wersja 2.0

EDIT 3:
4. new-branded
- quick-usb-formatter-git ; proste narzędzie do formatowania pendrive fork kf5 z Chakry


Hardware: AMD: A8-7410 APU with Radeon R5
Software (podaję wyłącznie odrębności): Arch testing+kde-unstable, kernel linux-pb (4.19.8 m.in. PDS, UKSM, BFQ-MQ/SQ), amdgpu (dla CIK), KDE, patche z POLAUR

Offline

#23 2018-03-04 10:46:45

pavbaranov
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-22
Liczba postów: 1,657
WWW

Odp: Repozytorium PKGBUILDów

4.03.2018
1. repo-refreshed
- kwin - dodany patch na KDEBUG 390314


Hardware: AMD: A8-7410 APU with Radeon R5
Software (podaję wyłącznie odrębności): Arch testing+kde-unstable, kernel linux-pb (4.19.8 m.in. PDS, UKSM, BFQ-MQ/SQ), amdgpu (dla CIK), KDE, patche z POLAUR

Offline

#24 2018-03-05 17:30:29

pavbaranov
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-22
Liczba postów: 1,657
WWW

Odp: Repozytorium PKGBUILDów

5.03.2018
1. repo-refreshed
- kget - załatany błąd: https://bugs.kde.org/show_bug.cgi?id=390612


Hardware: AMD: A8-7410 APU with Radeon R5
Software (podaję wyłącznie odrębności): Arch testing+kde-unstable, kernel linux-pb (4.19.8 m.in. PDS, UKSM, BFQ-MQ/SQ), amdgpu (dla CIK), KDE, patche z POLAUR

Offline

#25 2018-03-05 18:26:18

Viperoo
Użytkownik
Data rejestracji: 2015-08-31
Liczba postów: 39
WWW

Odp: Repozytorium PKGBUILDów

@pavbaranov jak byście planowali automatyczne bulidy paczek to chętnie bym coś pomógł.


blog.szmijewski.pl

Offline

Stopka

Napędzają nas PacmanVPS i MegiTeam

Forum oparte na FluxBB