Nie jesteś zalogowany na forum.

#1 2018-01-16 11:33:18

infomaniak
Zbanowany
Data rejestracji: 2015-09-12
Liczba postów: 68

[SOLVED] TeamViewer - nie startuje

Prośba o pomoc w uruchomieniu TeamViwer'a. Dystrybucja - Antergos. Aktualizowana na bieżąco. W konsoli wygląda to tak:

[maras@maras-asus ~]$ /home/maras/Programy/teamviewer13/tv_bin/script/teamviewer
 
Init...
CheckCPU: SSE2 support: yes
Checking setup...
Launching TeamViewer ...
Starting network process (no daemon)
Network process started (972)
Launching TeamViewer GUI ...

no i na tym koniec. Google  w różnych wątkach podpowaidają żeby zrobić downgrade paczki lib32-freetype2 ale to nie działa. Innych Podpowiedzi nie znalazłem. Będę wdzięczny za pomoc.

Ostatnio edytowany przez infomaniak (2018-01-23 01:09:42)


Registered Linux User # 469143.

Offline

#2 2018-01-16 11:59:05

Viperoo
Użytkownik
Data rejestracji: 2015-08-31
Liczba postów: 39
WWW

Odp: [SOLVED] TeamViewer - nie startuje

Czemu nie zainstalujesz z AUR? https://aur.archlinux.org/packages/teamviewer/

Wtedy zainstaluje wszystkie zależności.


blog.szmijewski.pl

Offline

#3 2018-01-16 12:34:18

pavbaranov
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-22
Liczba postów: 1,661
WWW

Odp: [SOLVED] TeamViewer - nie startuje

Może dlatego, że woli natywną wersję 13.
@infomaniak: Sprawdziłeś: https://community.teamviewer.com/t5/Kno … 1516102288? Masz to wszystko zainstalowane oraz poinstalowane prawidłowo? Niestety z informacji, które przekazałeś wygląda, że... nic nie wygląda. Sieć (dla TV) zostaje podniesiona, bo demon nie działa w tle, włącza się GUI, które z jakichś powodów się nie włącza.


Hardware: AMD: A8-7410 APU with Radeon R5
Software (podaję wyłącznie odrębności): Arch testing+kde-unstable, kernel linux-pb (4.19.8 m.in. PDS, UKSM, BFQ-MQ/SQ), amdgpu (dla CIK), KDE, patche z POLAUR

Offline

#4 2018-01-16 19:39:30

marcin82
Moderator
Lokalizacja: Sosnowiec
Data rejestracji: 2015-08-20
Liczba postów: 154

Odp: [SOLVED] TeamViewer - nie startuje

Sprawdź jednak z AUR, ale teamviewer-beta. Wersja natywna, bez wine, zabaw z freetype i całego zastępu lib32. U mnie gui startuje i działa normalnie. Czasami zdarzy mu się podczas sesji przywiesić, ale to pewnie choroby wieku dziecięcego ...


marcin82

Offline

#5 2018-01-16 20:21:04

infomaniak
Zbanowany
Data rejestracji: 2015-09-12
Liczba postów: 68

Odp: [SOLVED] TeamViewer - nie startuje

wszystko było zainstalowane. TW działał jeszcze do niedawna bez problemu. Nie używam go codziennie więc nie wiem dokładnie kiedy coś się zes...ało. No ale teraz nie działa żadna z natywnych wersji 11, 12, 12.2 no i ostatnia 13.

Zainstalowałem z AUR wersję teamviewer-beta. O dziwo uruchomiła się bez problemu jednak sukces jest połowiczny. Na dole okna wyświetla komunikat: "Brak gotowości. Sprawdź swoje połączenie internetowe." Oczywiście połączenie jest ok.


Registered Linux User # 469143.

Offline

#6 2018-01-18 20:14:35

infomaniak
Zbanowany
Data rejestracji: 2015-09-12
Liczba postów: 68

Odp: [SOLVED] TeamViewer - nie startuje

hmm odpowiedzi brak ale...
po wykonaniu:

sudo teamviewer --daemon stop

a potem:

sudo teamviewer --daemon start

wysztko jest ok, startuje i działa.
Da się to jakoś ogarnąć?

sudo systemctl disable teamviewerd

nie działa


Registered Linux User # 469143.

Offline

#7 2018-01-18 21:52:09

pavbaranov
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-22
Liczba postów: 1,661
WWW

Odp: [SOLVED] TeamViewer - nie startuje

Skoro pobrana wersja z teamviewer.com nie działa, a zbudowana z AUR tak, to albo wersja od TV nie jest "kompatybilna" z Archem (ale już dostarczane przezeń deby tak), albo w istocie brakowało jakichś zależności. Mniejsza o to. Do niedawna TV działał zupełnie inaczej i nie był aplikacją natywną linuksa (działał przez wine). Od wersji 13 działa zupełnie inaczej i jest to "preview", a zatem może coś nie działać. Zgłoś twórcom, albowiem nikt inny niie wie co jest tak w kodzie.

Nie mam bladego pojęcia co oznacza:

sudo systemctl disable teamviewerd

"nie działa", albowiem "nie działa" nie mówi kompletnie nic i nikomu. Nie wiem też co chciałeś tym osiągnąć. To polecenie wyłącza teamviewerd, który jest TV niezbędny do prawidłowego działania. Podczas instalacji TV wyświetliła Ci się treść pochodząca z pliku teamviewer.install:

The Teamviewer daemon must be running for Teamviewer to work.
Execute 'systemctl enable teamviewerd' in a terminal.

Czyli "demon Teamviewer musi być uruchomiony dla działania Teamviewer. Wykonaj 'systemctl enable teamviewerd' w konsoli. Innymi słowy odwrotnie do tego co piszesz.

PS. Nie podbijaj wątku, a dopisuj, edytując poprzedni, jeśli nie zostało nic po nim odpowiedziane przez kogokolwiek.


Hardware: AMD: A8-7410 APU with Radeon R5
Software (podaję wyłącznie odrębności): Arch testing+kde-unstable, kernel linux-pb (4.19.8 m.in. PDS, UKSM, BFQ-MQ/SQ), amdgpu (dla CIK), KDE, patche z POLAUR

Offline

#8 2018-01-23 01:07:38

infomaniak
Zbanowany
Data rejestracji: 2015-09-12
Liczba postów: 68

Odp: [SOLVED] TeamViewer - nie startuje

systemctl enable teamviewerd

to działa. Po restarcie maszyny TV wstaje jak trzeba bez najmniejszego problemu. Dzięki za wsparcie. Zamykam temat


Registered Linux User # 469143.

Offline

Stopka

Napędzają nas PacmanVPS i MegiTeam

Forum oparte na FluxBB