Nie jesteś zalogowany na forum.

#1 2017-10-24 23:09:46

addos
Użytkownik
Data rejestracji: 2015-09-01
Liczba postów: 151

PlayOnLinux - baaaaardzo malutkie (oraz źle wyrównane) okna

W związku z tym, że chciałem mieć kilka różnych wersji Wine obok siebie to zacząłem się pobawić programem PlayOnLinux (POL).
Mam wszystko w najnowszych wersjach na chwilę obecną. Cały system w gałęzi stabilnej i update na max.
Przed zabawą Wine i POL skasowałem wszystkie pliki i katalogi mające związek z nimi (sprawdziłem cały profil użytkownika).

Jeżeli uruchomię samego Wine (nie POL) to wszystko działa poprawnie. Aktualny Wine to 2.19.
Nic na tym Wine nie mam. Po prostu uruchamiam np. winecfg i pokazuje się okno z różnymi ustawieniami.

Jeżeli to samo zrobię w POL na wersji Wine tej samej czyli 2.19 to wszystko jest OK.
Natomiast jeżeli dodam jakąkolwiek starszą wersję Wine, np. 2.0 lub 2.5 lub inną, to mam takie problemy:
a) okna są zbyt małe bo nie mieszczą się przyciski, tak jakby ktoś narysował je na 95% tego jak powinny wyglądać. Oczywiście mogę złapać za krawędź i to okno rozciągnąć, chociaż są takie, które mają to zablokowane.
b) i ten punkt jest najgorszy, bo gdy próbuję w POL uruchomić cokolwiek z zakładki "Wine", np. Skonfiguruj Wine, Edytor rejestru, Menadżer zadań, Control Panel, to otwierają mi się okienka tak malutkie, że nic w nich nie widać, coś w stylu 5x5 pikseli, jest tylko obramowanie, nawet nie da się tego ani powiększyć, ani rozciągnąć.

Przypominam, że punkt b) wykonany w POL na wersji Wine 2.19 (czyli tej zainstalowanej w systemie) nie ma tych problemów.
Problemów nie mam też gdy wrzucę do POL bardzo starą wersję Wine, np. 1.0

Szukałem trochę po internecie różnych opisów bo niektórzy ludzie mają ten sam problem, ale nic u mnie nie pomaga.
Na jednym z zagranicznych forów ktoś zasugerował, że wxpython3.0 to powoduje, i napisał, że gdy cofnie się do wxpython2.8 (z AUR) to jest OK.
Wgrałem go (wxpython2.8) a on wymusił instalację gstreamer0.10-base oraz gstreamer0.10-base-plugins.
Niestety ale nie pomogło, więc odinstalowałem te w/w paczki.
Ten zabieg tylko pogorszył sprawę, bo teraz winecfg nie uruchamia mi się z GUI, a tylko z konsoli. Z GUI nic się nie dzieje - nie ma żadnej reakcji.
Nie wiem co się stało, ale sytuacja jest gorsza niż przedtem :)
Sprawdziłem na innym użytkowniku, i tam winecfg uruchamia się z GUI, więc będę musiał poszukać gdzieś jakiegoś ustawienia, które to blokuje.


Może ktoś już z tym kiedyś walczył, i wie co jest tego przyczyną? :)

Ostatnio edytowany przez addos (2017-10-25 08:37:17)


Info przy ew. problemach: Arch Linux x64, Plasma 5 (aktualna), CPU C2D E8400 (3GHz, 6MB cache), ASUS P5Q-PRO (BIOS, bez UEFI), RAM 8GB (DDR2, Dual), GPU GF 9600GT (PCI-E, 512MB), SSD 250GB MLC (GPT, discard, Grub 2, all ext4), HDD 1TB (7200, SATA, AHCI, NCQ, MBR, all ext4), monitor [email protected] DVI, audio: ASUS Xonar DX (PCI-E x1, 5.1 analog, ALSA bez PulseAudio), klaw. PS/2, mysz USB

Offline

Stopka

Forum oparte na FluxBB