Nie jesteś zalogowany na forum.

#1 2016-05-05 13:55:35

Hepita
Użytkownik
Lokalizacja: Kościerzyna
Data rejestracji: 2016-05-05
Liczba postów: 15

[prawdopodobnie solved]Instalacja Archa + KDE - dziwne zachowanie SDDM

Wiedziałem że jak tylko się wezmę za Archa to będę musiał coś zepsuć. Witam wszystkich, jako że to mój pierwszy post na forum :)

A więc, po instalacji bazowego systemu zainstalowałem grupy pakietów: xorg oraz plasma oraz sterowniki do grafiki od Nvidii. Z wszystkim się uporałem, rebootuję system, uruchamia się SDDM, wpisuję hasło, klikam enter i... nic się nie dzieje, tylko kursor zmienia kształt na krzyżyk, jak widać na screenie: http://i.imgur.com/z6wDd1t.jpg
Nic się nie da zrobić, jedyne rozwiązanie to przełączenie się na konsolę i reboot. I tak w kółko.
Aha, w logu Xorga nie ma żadnych błędów, konfigurację robiłem przez "nvidia-xconfig", jeśli ma to jakieś znaczenie.
Macie jakieś pomysły? Z góry dzięki za pomoc :)

Btw, musiałem ręcznie wklepać "systemctl enable sddm.service" czyli w Archu to się nie robi automatycznie, jak np. w Debianie? :)

Ostatnio edytowany przez Hepita (2016-05-05 17:50:16)

Offline

#2 2016-05-05 14:04:28

sir_lucjan
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-20
Liczba postów: 839

Odp: [prawdopodobnie solved]Instalacja Archa + KDE - dziwne zachowanie SDDM

W Arch Linux nic nie robi się automatycznie, wszystko musisz robić samodzielnie - taki urok tej dystrybucji.

Na sam początek zdradź, jaką masz kartę graficzną oraz jakie sterowniki do niej wgrałeś. To jedna z podstawowych informacji, która jest kluczowa. Po drugie, jak instalowałeś Plasmę - całą grupę plasma?


Dell Inspiron 15-3542 (3542-2538) || Arch Linux || [linux-lucjan-git]
[AUR]  [GitHub]  [GitLab]

Offline

#3 2016-05-05 14:08:16

Hepita
Użytkownik
Lokalizacja: Kościerzyna
Data rejestracji: 2016-05-05
Liczba postów: 15

Odp: [prawdopodobnie solved]Instalacja Archa + KDE - dziwne zachowanie SDDM

Nvidia GTX 750 Ti, zainstalowałem sterownik z pakietu "nvidia" (czyli wersja 364.19-1)
Tak, instalowałem całą grupę plasma.

Ostatnio edytowany przez Hepita (2016-05-05 14:11:40)

Offline

#4 2016-05-05 15:31:54

gaim
Użytkownik
Data rejestracji: 2015-08-26
Liczba postów: 47
WWW

Odp: [prawdopodobnie solved]Instalacja Archa + KDE - dziwne zachowanie SDDM

Niepotrzebnie robiłeś

nvidia-xconfig

Jak mówi wiki nie robi się już tego, w większości przypadków powinno wystarczyć zainstalowanie tylko

nvidia nvidia-libgl

Offline

#5 2016-05-05 15:43:44

Hepita
Użytkownik
Lokalizacja: Kościerzyna
Data rejestracji: 2016-05-05
Liczba postów: 15

Odp: [prawdopodobnie solved]Instalacja Archa + KDE - dziwne zachowanie SDDM

Faktycznie... usunąłem /etc/X11/xorg.conf (bo z tego co pamiętam to polecenie nvidia-xconfig utworzyło ten plik, wcześniej go nie było). W logach nie ma żadnych błędów, ale problem pozostaje.

Offline

#6 2016-05-05 16:48:31

Hepita
Użytkownik
Lokalizacja: Kościerzyna
Data rejestracji: 2016-05-05
Liczba postów: 15

Odp: [prawdopodobnie solved]Instalacja Archa + KDE - dziwne zachowanie SDDM

To musi być błąd SDDM, bo zainstalowałem lightdm + gtk-greeter (gtk bo było mniej danych do pobrania niż przy kde-greeter) plasma się uruchamia. Ale nie będę całe życie korzystał z lightdm :D

Ostatnio edytowany przez Hepita (2016-05-05 17:09:17)

Offline

#7 2016-05-05 17:27:42

pavbaranov
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-22
Liczba postów: 1,662
WWW

Odp: [prawdopodobnie solved]Instalacja Archa + KDE - dziwne zachowanie SDDM

SDDM jest ostatnio do d... :) Jeśli z jakichś przyczyn nie potrzebujesz uruchamiania waylanda, to proponuję cdm (zob.: http://forum.archlinux.org.pl/viewtopic … 1209#p1209) - przynajmniej pozbędziesz się niepotrzebnych narzutów "lekkiego" lightdm (sprawdzałem - brał więcej zasobów niż niegdysiejszy KDM).
Możesz również spróbować sddm-git z AUR.


Hardware: AMD: A8-7410 APU with Radeon R5
Software (podaję wyłącznie odrębności): Arch testing+kde-unstable, kernel linux-pb (4.19.10rc m.in. PDS, UKSM, BFQ-MQ/SQ), amdgpu (dla CIK), KDE, patche z POLAUR

Online

#8 2016-05-05 17:46:25

gaim
Użytkownik
Data rejestracji: 2015-08-26
Liczba postów: 47
WWW

Odp: [prawdopodobnie solved]Instalacja Archa + KDE - dziwne zachowanie SDDM

A co akceleracją, sterownik działa?

Offline

#9 2016-05-05 17:47:27

Hepita
Użytkownik
Lokalizacja: Kościerzyna
Data rejestracji: 2016-05-05
Liczba postów: 15

Odp: [prawdopodobnie solved]Instalacja Archa + KDE - dziwne zachowanie SDDM

Dzięki pavbaranov, sprawdzę to.

Problem rozwiązany (chyba). w sumie z czystej ciekawości, siedząc w ustawieniach systemowych zmieniłem motyw sddm po czym zablokowałem lightdm i uruchomiłem sddm - przy logowaniu nadal się wyświetla krzyżyk zamiast kursora, z tą różnicą że tylko przez jakąś sekundę - potem ładnie się odpala KDE.

Druga sprawa, zarówno sddm jak i lightdm mają rozwalony antyaliasing czcionek. Nie żeby mi to przeszkadzało (w końcu przez ile sekund dziennie się patrzy na ekran logowania? :D) ale jeśli da się to jakoś prosto naprawić to czemu nie, ma ktoś jakiś pomysł?

gaim, w sumie nie sprawdzałem czy wystartował na nvidii czy nouveau, działa to działa ;) zaraz sprawdzę, tylko się przeloguję bo teraz siedzę na Ubuntu (na archu jeszcze nic nie doinstalowałem oprócz konsole i qtfm, wieczorami mam zbyt wolny internet :D)

Sprawdziłem, system ładnie wstał na sterowniku nvidii.

Ostatnio edytowany przez Hepita (2016-05-05 17:55:17)

Offline

Stopka

Napędzają nas PacmanVPS i MegiTeam

Forum oparte na FluxBB