Nie jesteś zalogowany na forum.

#1 2015-12-11 13:39:24

tyffan
Użytkownik
Data rejestracji: 2015-12-11
Liczba postów: 2

catalyst-utils

Witam wszystkich użytkowników Arch linux.

Jestem szcześliwym posiadaczem Archa od paru dni i ciągle napotykam jakieś przeszkody. Nie mniej jednak do tej pory jakoś sobie radziłem, aż tu nagle podczas instalacji sterowników do ati wyskakuje mi błąd

wczytywanie pakietów…
rozwiązywanie zależności…
ostrzeżenie: nie można rozwiązać "xorg-server<1.18.0", zależności od "catalyst-utils"
:: Następujący pakiet nie mógł zostać zaktualizowany w wyniku niespełnionych zależności:
      catalyst-utils

:: Czy chcesz pominąć powyższy pakiet przy aktualizacji? [t/N]
błąd:  nie udało się przygotować transakcji (nie udało się rozwiązać zależności)
:: catalyst-utils: wymaga xorg-server<1.18.0
==> OSTRZEŻENIE:Twoje pakiety są zapisane w /tmp/yaourt-tmp-tyffan
cp: zamazać „/tmp/yaourt-tmp-tyffan/catalyst-utils-15.9-2-x86_64.pkg.tar.xz”?
==> Powtórzyć budowanie catalyst?[t/N]
==> ----------------------------------
==>

Z tego co wyczytałem catalyst wymaga xorg-server 1.18.0 a zainstalowany mam 1.18.0-3 i dalej nie mam pojęcia co zrobić...

Przepraszam, jesli źle umieściłem posta i zapomniałem czegoś dodać. To mój pierwszy post na jakimś forum od 10 lat :D

Ostatnio edytowany przez tyffan (2015-12-11 13:42:10)

Offline

#2 2015-12-11 14:58:20

pavbaranov
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-22
Liczba postów: 1,661
WWW

Odp: catalyst-utils

Catalyst już tak ma, że nie nadąża z kompatybilnością swoich sterowników z najnowszymi wersjami X.Org. Dlatego m.in. nie jest oficjalnie wspierany przez Archa.
Skrypty budujące catalyst-utils z AUR mają ustawione, że wersja xorg-server musi być niższa od 1.18.0, czyli może pochodzić co najwyżej z rodziny 1.17.x.
Wyjść masz kilka:
- cofnąć xorg-server do wcześniejszej wersji i zablokować możliwość upgrade'u,
- zastosować nieoficjalne repozytorium Catalyst dla Archa prowadzone przez Vi0L0 (zob.: https://wiki.archlinux.org/index.php/AM … repository),
- znaleźć jakiś patch i modlić się, że w przypadku Twojej karty, oraz zainstalowanej wersji X.Org, zmusi on do instalacji Catalysta oraz by potem to dobrze działało (najwięcej informacji znajdziesz tu: https://bbs.archlinux.org/viewtopic.php?id=57084),
- ... przejść na otwarte sterowniki.
Osobiście, lata temu zdecydowałem się na to ostatnie rozwiązanie, gdyż jest najmniej kłopotliwe. Drugie, akceptowalne to repozytorium Vi0L0 - to on dba o to, by wszystko ze sobą pracowało. Pozostałe dwa - aczkolwiek możliwe - bywają dość kłopotliwe. Pozostawiłbym je sobie wyłącznie, gdybym był na tyle dobrze obeznanym w obsłudze linuksa, w tym również Archa, by stosowanie tego rozwiązania nie było dla mnie kłopotliwe. Wybór pomiędzy zdecydowaniem się na sterowniki otwarte oraz na Catalysta z repozytorium przebiega na linii rodzaju zastosowań komputera. Zwykle Catalyst oferuje nieco lepszą (jeszcze) wydajność w 3D.


Hardware: AMD: A8-7410 APU with Radeon R5
Software (podaję wyłącznie odrębności): Arch testing+kde-unstable, kernel linux-pb (4.19.8 m.in. PDS, UKSM, BFQ-MQ/SQ), amdgpu (dla CIK), KDE, patche z POLAUR

Offline

#3 2015-12-11 18:15:51

tyffan
Użytkownik
Data rejestracji: 2015-12-11
Liczba postów: 2

Odp: catalyst-utils

Próbowałem zastosować się do drugiej opcji, ale repozytoria Vi0L0 chyba przestały działać. Zostanę jednak przy otwartych sterownikach. Dzięki za pomoc.

Offline

#4 2015-12-11 19:04:28

pavbaranov
Administrator
Lokalizacja: Kraków
Data rejestracji: 2015-08-22
Liczba postów: 1,661
WWW

Odp: catalyst-utils

Nie, one działają (na pewno). Natomiast niekiedy jest problem z przepustowością serwera, na którym są (o ile się nie mylę). Zresztą zerknij: http://catalyst.wirephire.com/ - jak byk są :)


Hardware: AMD: A8-7410 APU with Radeon R5
Software (podaję wyłącznie odrębności): Arch testing+kde-unstable, kernel linux-pb (4.19.8 m.in. PDS, UKSM, BFQ-MQ/SQ), amdgpu (dla CIK), KDE, patche z POLAUR

Offline

Stopka

Napędzają nas PacmanVPS i MegiTeam

Forum oparte na FluxBB